Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Java was started but returned exit code=1(Eclipse Crashing)
Java was started but returned exit code=1 [message #1144505] Fri, 18 October 2013 23:11 Go to next message
Mirage Leung is currently offline Mirage LeungFriend
Messages: 1
Registered: October 2013
Junior Member
Java was started but returned exit code=1
C;\windows\system32\java.exe
-Dosgi.requiredJavaVersion=1.6
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-jar C:\Program
Files\eclipse\\plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
-os win32
-ws win32
-arch x86_64
-showsplash C:\Program
Files\eclipse\\plugins\org.eclipse.platform_4.3.1.v20130911-1000\splash.bmp
-launcher C:\Program Files\eclipse\eclipsec.exe
-name Eclipsec
--launcher.library C:\Program
Files\eclipse\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20130807-1835\eclipse_1503.dll
-startup C:\Program
Files\eclipse\\plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
--launcher.appendVmargs
-exitdata 15f8_54
-product org.eclipse.epp.package.java.product
-vm C:\windows\system32\java.exe
-vmargs
-Dosgi.requiredJavaVersion=1.6
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-jar C:\Program
Files\eclipse\\plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
Re: Java was started but returned exit code=1 [message #1145785 is a reply to message #1144505] Sat, 19 October 2013 19:48 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 10/19/2013 12:35 PM, Mirage Leung wrote:
> Java was started but returned exit code=1
> C;\windows\system32\java.exe
> -Dosgi.requiredJavaVersion=1.6
> -Xms40m
> -Xmx512m
> -XX:MaxPermSize=256m
> -jar C:\Program
> Files\eclipse\\plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
>
> -os win32
> -ws win32
> -arch x86_64
> -showsplash C:\Program
> Files\eclipse\\plugins\org.eclipse.platform_4.3.1.v20130911-1000\splash.bmp
> -launcher C:\Program Files\eclipse\eclipsec.exe
> -name Eclipsec
> --launcher.library C:\Program
> Files\eclipse\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20130807-1835\eclipse_1503.dll
>
> -startup C:\Program
> Files\eclipse\\plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
>
> --launcher.appendVmargs
> -exitdata 15f8_54
> -product org.eclipse.epp.package.java.product
> -vm C:\windows\system32\java.exe
> -vmargs
> -Dosgi.requiredJavaVersion=1.6
> -Xms40m
> -Xmx512m
> -XX:MaxPermSize=256m
> -jar C:\Program
> Files\eclipse\\plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar

You should get a proper JRE and not use the one stuffed down under
C:\windows\system32. Make sure that the width of the JRE you choose
matches that of Eclipse (32-bit JRE with 32-bit Eclipse or 64-bit JRE
with 64-bit Eclipse).
Re: Java was started but returned exit code=1 [message #1385185 is a reply to message #1145785] Wed, 04 June 2014 20:15 Go to previous messageGo to next message
arun kumar is currently offline arun kumarFriend
Messages: 1
Registered: June 2014
Junior Member
I have the same problem. When I click on MyEclipseBlue, I get the same exact error message in a Window. so far I have not seen any solution that works. Senior staff in my office suggested that I re-install Eclipse. There's got to be a better solution.

Russell Bateman: what do you mean by get a proper JRE? I'm a new Java Developer. So please elaborate your statement.
Re: Java was started but returned exit code=1 [message #1385190 is a reply to message #1385185] Wed, 04 June 2014 21:07 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
Since MyEclipse Blue is a commercial product from another company, I suggest you seek out whatever support channel is offered by that company. Also make sure to follow all the advice in the Announcement at the top of this forum titled Trouble getting Eclipse to run? READ THIS FIRST
Re: Java was started but returned exit code=1 [message #1385203 is a reply to message #1385185] Thu, 05 June 2014 00:30 Go to previous message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 06/04/2014 02:21 PM, arun kumar wrote:
> I have the same problem. When I click on MyEclipseBlue, I get the same
> exact error message in a Window. so far I have not seen any solution
> that works. Senior staff in my office suggested that I re-install
> Eclipse. There's got to be a better solution.
>
> Russell Bateman: what do you mean by get a proper JRE? I'm a new Java
> Developer. So please elaborate your statement.

As Eric suggests, you should take this up in a MyEclipse forum. No
matter, the problem is very likely that you do not have a JDK downloaded
from, for example, Sun. Go to java.sun.com, click Downloads, Popular
Downloads, Downloads for Developers, etc. and download the appropriate
copy of the Java 7 developer kit for your OS/hardware.
Previous Topic:How to change font for tree view selected element?
Next Topic:multiple IDEs
Goto Forum:
  


Current Time: Thu Nov 26 17:37:30 GMT 2020

Powered by FUDForum. Page generated in 0.03254 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top