Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » org.eclipse.ui.wizards.datatransfer.ImportOperation missing in M6?
org.eclipse.ui.wizards.datatransfer.ImportOperation missing in M6? [message #174241] Sun, 28 December 2003 12:27 Go to next message
Eclipse UserFriend
Originally posted by: mp.scholz.t-online.de

Dear folks,

I'm developing a plugin presently which uses
org.eclipse.ui.wizards.datatransfer.ImportOperation.

While using the M4 build of Eclipse everything was okay, for the
stated class was contained in workbench.jar of the
org.eclipse.ui.workbench_3.0.0 plugin.
When upgrading to M6 today, though, I now get compilation errors for the
unchanged project stating that the class
org.eclipse.ui.wizards.datatransfer.ImportOperation cannot be found any
longer!
A quick glance into workbench.jar indeed reveals that the wizards package
is no longer contained in the jar file (while all others expected packages
are).

This is the case on the Linux gtk distribution
(eclipse-SDK-3.0M6-linux-gtk.zip) and the Win32 distribution
(eclipse-SDK-3.0-win32.zip) as well.

So where is org.eclipse.ui.wizardsdatatransfer.ImportOperation now? Has it
moved somewhere?

Regards,
Matthias Paul Scholz
Re: ImportOperation moved to ide.jar in another plugin! [message #174596 is a reply to message #174241] Tue, 30 December 2003 12:59 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: mp.scholz.t-online.de

As a matter of fact, after searching the jar files of the plugins I
discovered the stated class in the ide.jar of the (new?)
org.eclipse.ui.ide plugin.
It seems to have moved there from its former place at workbench.jar in the
org.eclipse.ui.workbench plugin (in 3.0 M4).

Has this been stated anywhere?

If not, it should have been done: some plugins can no longer be compiled
if the new required plugin (org.eclipse.ui.ide in this case) is not stated
in the plugin's xml file.
Or is there a way to do such things automatically when upgrading?



Matthias Paul Scholz wrote:

> Dear folks,

> I'm developing a plugin presently which uses
> org.eclipse.ui.wizards.datatransfer.ImportOperation.

> While using the M4 build of Eclipse everything was okay, for the
> stated class was contained in workbench.jar of the
> org.eclipse.ui.workbench_3.0.0 plugin.
> When upgrading to M6 today, though, I now get compilation errors for the
> unchanged project stating that the class
> org.eclipse.ui.wizards.datatransfer.ImportOperation cannot be found any
> longer!
> A quick glance into workbench.jar indeed reveals that the wizards package
> is no longer contained in the jar file (while all others expected packages
> are).

> This is the case on the Linux gtk distribution
> (eclipse-SDK-3.0M6-linux-gtk.zip) and the Win32 distribution
> (eclipse-SDK-3.0-win32.zip) as well.

> So where is org.eclipse.ui.wizardsdatatransfer.ImportOperation now? Has it
> moved somewhere?

> Regards,
> Matthias Paul Scholz
Re: ImportOperation moved to ide.jar in another plugin! [message #177064 is a reply to message #174596] Thu, 08 January 2004 09:42 Go to previous message
Eclipse UserFriend
Originally posted by: daniel.megert.gmx.net

Matthias Paul Scholz wrote:

>As a matter of fact, after searching the jar files of the plugins I
>discovered the stated class in the ide.jar of the (new?)
>org.eclipse.ui.ide plugin.
>It seems to have moved there from its former place at workbench.jar in the
>org.eclipse.ui.workbench plugin (in 3.0 M4).
>
>Has this been stated anywhere?
>
>
Sure. You should at least read the New and Noteworthy (in your case 3.0
M5) pages.

Dani

>If not, it should have been done: some plugins can no longer be compiled
>if the new required plugin (org.eclipse.ui.ide in this case) is not stated
>in the plugin's xml file.
>Or is there a way to do such things automatically when upgrading?
>
>
>
>Matthias Paul Scholz wrote:
>
>
>
>>Dear folks,
>>
>>
>
>
>
>>I'm developing a plugin presently which uses
>>org.eclipse.ui.wizards.datatransfer.ImportOperation.
>>
>>
>
>
>
>>While using the M4 build of Eclipse everything was okay, for the
>>stated class was contained in workbench.jar of the
>>org.eclipse.ui.workbench_3.0.0 plugin.
>>When upgrading to M6 today, though, I now get compilation errors for the
>>unchanged project stating that the class
>>org.eclipse.ui.wizards.datatransfer.ImportOperation cannot be found any
>>longer!
>>A quick glance into workbench.jar indeed reveals that the wizards package
>>is no longer contained in the jar file (while all others expected packages
>>are).
>>
>>
>
>
>
>>This is the case on the Linux gtk distribution
>>(eclipse-SDK-3.0M6-linux-gtk.zip) and the Win32 distribution
>>(eclipse-SDK-3.0-win32.zip) as well.
>>
>>
>
>
>
>>So where is org.eclipse.ui.wizardsdatatransfer.ImportOperation now? Has it
>>moved somewhere?
>>
>>
>
>
>
>>Regards,
>> Matthias Paul Scholz
>>
>>
>
>
>
>
Previous Topic:content completion descriptions
Next Topic:Rich Client Platform?
Goto Forum:
  


Current Time: Sat Apr 25 02:15:29 GMT 2015

Powered by FUDForum. Page generated in 0.01660 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software