Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Class not found exception in packaged plug-in. Xtext file .ui generate
Class not found exception in packaged plug-in. Xtext file .ui generate [message #1076896] Thu, 01 August 2013 01:42 Go to next message
Mayerli Romero is currently offline Mayerli RomeroFriend
Messages: 3
Registered: July 2013
Junior Member
Hello

I'm package a plugin made for me called mView. I create my plug in using xtext and it generate 2 files more than my original project (mView.test and mView.ui) I have a problem with deploying of my packaged plug-in (i.e., when it is not started in a runtime workbench).

The error is:

Plug-in mView.ui was unable to load class org.xtext.example.mydsl.ui.MViewExecutableExtensionFactory.

org.eclipse.core.runtime.CoreException: Plug-in mView.ui was unable to load class org.xtext.example.mydsl.ui.MViewExecutableExtensionFactory. at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.throwException(RegistryStrategyOSGI.java:194) at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:176) at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:905) at ..... Caused by: java.lang.ClassNotFoundException: org.xtext.example.mydsl.ui.MViewExecutableExtensionFactory at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:501) at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:421) at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:412) ....

I already ensure of the jdk and jre compatibility and all its ok. In the part of the MANIFIEST of the plug-in I already check the jar file that contains the plug-in classes and be listed in the Bundle-ClassPath. In the dependency's of the plug-in appears xtext and in the file built.properties is check the source folder in SourceBuild and BinaryBuild, but I can't find it more to do, I would greatly appreciate your help.

sorry for my English. Thank You!

PD: just for information. I package my plug-in following this turorial: http: //www.vogella.com/ articles/ EclipsePlugIn/ article.html#p2deployplugin_overview
Re: Class not found exception in packaged plug-in. Xtext file .ui generate [message #1076922 is a reply to message #1076896] Thu, 01 August 2013 02:40 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14076
Registered: July 2009
Senior Member
Hi can you please share your code

--
Need training, onsite consulting or any other kind of help for Xtext?
Go visit http://xtext.itemis.com or send a mail to xtext at itemis dot de


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Class not found exception in packaged plug-in. Xtext file .ui generate [message #1077387 is a reply to message #1076922] Thu, 01 August 2013 16:16 Go to previous messageGo to next message
Mayerli Romero is currently offline Mayerli RomeroFriend
Messages: 3
Registered: July 2013
Junior Member
I already fix it. The proyects that xtext generate mView.test and mView.ui dont have the built.properties file. I copy this file of the principal proyect, paste and modify in each project. And it works!... Thank You Smile
Re: Class not found exception in packaged plug-in. Xtext file .ui generate [message #1766746 is a reply to message #1076922] Mon, 26 June 2017 17:09 Go to previous messageGo to next message
Christian Schulze is currently offline Christian SchulzeFriend
Messages: 8
Registered: October 2011
Junior Member
Hi Christian,

I got the same issue within my project (on branch master):
https://github.com/marc-christian-schulze/structs4java

Could you please have a look at the sources?

I already checked the build.properties files but they seem to be ok.


Best regards
Christian

[Updated on: Mon, 26 June 2017 17:11]

Report message to a moderator

Re: Class not found exception in packaged plug-in. Xtext file .ui generate [message #1766747 is a reply to message #1766746] Mon, 26 June 2017 17:25 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14076
Registered: July 2009
Senior Member
for me it looks like the complete maven config is broken (config of source folders etc ...)
this might be caused by not checking in .classpath /.project files


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Class not found exception in packaged plug-in. Xtext file .ui generate [message #1766748 is a reply to message #1766747] Mon, 26 June 2017 18:08 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14076
Registered: July 2009
Senior Member
i just built with pure maven and not importing anything into eclipse and it worked fine after installing into a eclipse.

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Class not found exception in packaged plug-in. Xtext file .ui generate [message #1766924 is a reply to message #1766748] Wed, 28 June 2017 18:24 Go to previous messageGo to next message
Christian Schulze is currently offline Christian SchulzeFriend
Messages: 8
Registered: October 2011
Junior Member
Seems I found my mistakes:

1. Eclipse Configuration not generated by m2e-Connector:
My assumption was that the m2e plugin has a connector to configure Eclipse properly for the xtext plugin but it didn't.
But copying the example configuration from your github project resolved almost all error markers:
https://github.com/xtext/maven-xtext-example

2. Forgot to install the MWE 2 language SDK:
After copying the Eclipse configuration only the following error message was left:
"Bundle org.eclipse.emf.mwe2.launch cannot be resolved"
After some web crawling I read in the following article that I missed to install the "MWE 2 language SDK" plugin:
https://www.eclipse.org/forums/index.php/t/164527/

But after that Eclipse gladly runs my plugin in the debugger. :)

Best regards
Christian
Re: Class not found exception in packaged plug-in. Xtext file .ui generate [message #1766925 is a reply to message #1766748] Wed, 28 June 2017 18:24 Go to previous messageGo to next message
Christian Schulze is currently offline Christian SchulzeFriend
Messages: 8
Registered: October 2011
Junior Member
Seems I found my mistakes:

1. Eclipse Configuration not generated by m2e-Connector:
My assumption was that the m2e plugin has a connector to configure Eclipse properly for the xtext plugin but it didn't.
But copying the example configuration from your github project resolved almost all error markers:
https://github.com/xtext/maven-xtext-example

2. Forgot to install the MWE 2 language SDK:
After copying the Eclipse configuration only the following error message was left:
"Bundle org.eclipse.emf.mwe2.launch cannot be resolved"
After some web crawling I read in the following article that I missed to install the "MWE 2 language SDK" plugin:
https://www.eclipse.org/forums/index.php/t/164527/

But after that Eclipse gladly runs my plugin in the debugger. :)

Best regards
Christian
Re: Class not found exception in packaged plug-in. Xtext file .ui generate [message #1766926 is a reply to message #1766748] Wed, 28 June 2017 18:25 Go to previous messageGo to next message
Christian Schulze is currently offline Christian SchulzeFriend
Messages: 8
Registered: October 2011
Junior Member
Seems I found my mistakes:

1. Eclipse Configuration not generated by m2e-Connector:
My assumption was that the m2e plugin has a connector to configure Eclipse properly for the xtext plugin but it didn't.
But copying the example configuration from your github project resolved almost all error markers:
https://github.com/xtext/maven-xtext-example

2. Forgot to install the MWE 2 language SDK:
After copying the Eclipse configuration only the following error message was left:
"Bundle org.eclipse.emf.mwe2.launch cannot be resolved"
After some web crawling I read in the following article that I missed to install the "MWE 2 language SDK" plugin:
https://www.eclipse.org/forums/index.php/t/164527/

But after that Eclipse gladly runs my plugin in the debugger. :)

Best regards
Christian
Re: Class not found exception in packaged plug-in. Xtext file .ui generate [message #1766927 is a reply to message #1766748] Wed, 28 June 2017 18:25 Go to previous message
Christian Schulze is currently offline Christian SchulzeFriend
Messages: 8
Registered: October 2011
Junior Member
Seems I found my mistakes:

1. Eclipse Configuration not generated by m2e-Connector:
My assumption was that the m2e plugin has a connector to configure Eclipse properly for the xtext plugin but it didn't.
But copying the example configuration from your github project resolved almost all error markers:
https://github.com/xtext/maven-xtext-example

2. Forgot to install the MWE 2 language SDK:
After copying the Eclipse configuration only the following error message was left:
"Bundle org.eclipse.emf.mwe2.launch cannot be resolved"
After some web crawling I read in the following article that I missed to install the "MWE 2 language SDK" plugin:
https://www.eclipse.org/forums/index.php/t/164527/

But after that Eclipse gladly runs my plugin in the debugger. :)

Best regards
Christian
Previous Topic:Problem with external ecore model
Next Topic:X-Text Linking Services
Goto Forum:
  


Current Time: Sat Oct 23 12:20:32 GMT 2021

Powered by FUDForum. Page generated in 0.01982 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top