Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Lua Development Tools » Strange problem trying to use LDT on second machine(cannot load
Strange problem trying to use LDT on second machine [message #1072350] Mon, 22 July 2013 15:19 Go to next message
Burt Bicksler is currently offline Burt BickslerFriend
Messages: 9
Registered: July 2013
Junior Member
I'm new to Lua, and LDT. What I've seen with LDT is great but I'm having some challenges, the the current frustration is trying to duplicate the configuration for a project on my notebook that I finally got running on my desktop machine.

Both machines are running Ubuntu 12.04 LTS. I'm working with a project that uses lgi, and because I couldn't get the internal interpreters to work and play well with lgi I followed a suggestion to use the Lua version that is installed on my system.

I set up both Lua 5.2 and Lua 5.1 which I have on my desktop.

Note that from the command line I was able to build and test some simple GUI LUA programs with no problems. And after much fiddling I was able to get things set up with the external interpreters so that I could build using Lua 5.2 and run the application with no problem from LDT.

Of course I couldn't debug since I don't have a luasocket module for 5.2 yet, but I could run the applications in LDT.

So next I wanted to set up the same thing on the notebook where I'm doing most of the actual devlopment work.

As far as I can see I've duplicated the configuration the same as on the desktop but I'm hitting some issues on the notebook:

When I attempt to run a program that previously worked in LDT (non-Gui, just hello world) If I use internal Lua 5.1 it works, including debugging as before. But if I use the internal Lua 5.1 I get the following error:
Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/bbick/.eclipse/org.eclipse.platform_3.7.0_155965261/configuration/org.eclipse.osgi/bundles/202/1/.cp/lib/ cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(
at java.lang.ClassLoader.loadLibrary(
at java.lang.Runtime.loadLibrary0(
at java.lang.System.loadLibrary(
at com.naef.jnlua.NativeSupport$DefaultLoader.load(
at com.naef.jnlua.LuaState.<clinit>(

I've searched and is found here:

Note that this particular problem happens on both the desktop and the notebook. If I use the Ubuntu Lua 5.2 it runs fine in LDT.

Also there is no issue using the Ubuntu Lua 5.2 from the command line. How do I go about tracking down the source of this particular problem?

The other problem is that the lgi test GUI application.

I can now get that to run fine in LDT on the desktop and notebook using the external Ubuntu Lua 5.2.

But with the LDT internal Lua 5.2 I get the same error as above, and possible others if that is fixed. Is there a chance that with the build path set that I could get lgi working with the internal Lua 5.2 to get debugging working, or is it not worth exploring?

Thanks for any suggestions. (I had done a search for anything related to in the forum and on Goole but haven't found anything useful).


Re: Strange problem trying to use LDT on second machine [message #1072801 is a reply to message #1072350] Tue, 23 July 2013 14:16 Go to previous messageGo to next message
Simon Bernard is currently offline Simon BernardFriend
Messages: 341
Registered: July 2009
Senior Member

If I understand you have severals problems :

1) You can not run a "print "hello" with embedded lua 5.2 on ubuntu 12.04 => this looks like a bug.
Could you say me the arch of your ubuntu (32 or 64 bit) ? and the version of java used to launch LDT ?

2) Waiting we find a solution for the embedded interpreter problem, I propose to you to install a compatible version of luasocket and add it to the path of your interpreter in LDT and you will be able to debug it.

Re: Strange problem trying to use LDT on second machine [message #1073836 is a reply to message #1072801] Thu, 25 July 2013 15:23 Go to previous messageGo to next message
Marc Aubry is currently offline Marc AubryFriend
Messages: 86
Registered: August 2012
Hi Burt,

I have reproduce your bug, and file a bug about it:

It seems this bug affect only ubuntu 32bit.
Re: Strange problem trying to use LDT on second machine [message #1074033 is a reply to message #1073836] Fri, 26 July 2013 00:53 Go to previous message
Burt Bicksler is currently offline Burt BickslerFriend
Messages: 9
Registered: July 2013
Junior Member
Thanks Marc,

I was going to respond that I'm running the 32 bit version of Ubuntu 12.04 LTS but I'd been cranking on the Lua application I had been charged with enhancing, so just got to surface for air.

Glad that it appears that I am not the only one seeing the problem, and thanks for logging the bug.

Previous Topic:Variable Reference Issue
Next Topic:Execution Environment imported by default
Goto Forum:

Current Time: Mon Aug 08 02:22:46 GMT 2022

Powered by FUDForum. Page generated in 0.02295 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top