Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Eclipse RCP P2 Update(Update for the base RCP product using P2)
Eclipse RCP P2 Update [message #1027526] Wed, 27 March 2013 04:15
Priyank Thakkar is currently offline Priyank ThakkarFriend
Messages: 8
Registered: August 2012
Junior Member
I am developing an RCP P2 update and badly stuck with P2 update functionality. My query is as mentioned below:

1. I created RCP Mail Template application. (
2. Added product configuration file MailProduct.product
3. Added org.eclipse.equinox.p2.ui.sdk as a dependency in the dependency tab if my plugin project. After adding this, I got Intall New Software and Check for Update options under the help menu.
4. Added p2.inf file with following content.


5. Converted a product to feature based product.
6. Created a feature project (com.project.feature.mail)
7. Added in the plugin tab of feature com.project.feature.mail
8. Launched RCP product via product file. As it failed, I went to run configuration, added required plugin. Application launched successfully after that.
9. Exported the product. Exported product worked fine.
10. Now I made some changes to
11. Updated com.project.feature.mail verstion to 1.0.100.quailfier (earlier version 1.0.0.quialifier)
12. Added an update site project. Added category with id com.project.category.mail. Added mail feature with version 1.0.100.qualifier.
13. Clicked on build all, moved generated features, plugin, artifact and repository.xml to a local http server (tomcat)
14. I tried to update the com.project.feature.mail via, check for update option. It is connecting to the update site. When I put the update site URL in browser it leads me to site.xml and the output is as mentioned below:

<feature url="features/com.test.feature.mail_1.0.100.201303270908.jar" id="com.test.feature.mail" version="">
<category name="com.test.category.core"/>
<category-def name="com.test.category.core" label="Core"/>

15. It says no update found, while the install new software page shows the updated com.project.feature.mail with updated versio. In proceeding ahead with installation, it tells only update is possible while update cannot find the new update.

If you need any other infomation do let me know.

Kindly guild me how provide update for base product.
Previous Topic:My Project icon is missing
Next Topic:RCP Headless application
Goto Forum:

Current Time: Mon Jan 24 23:34:43 GMT 2022

Powered by FUDForum. Page generated in 0.02292 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top