Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Data Source issue which is not picking dynamically
Data Source issue which is not picking dynamically [message #1007543] Wed, 06 February 2013 11:30 Go to next message
K SREEDHAR REDDY Reddy is currently offline K SREEDHAR REDDY ReddyFriend
Messages: 8
Registered: February 2013
Junior Member
Hi,

I have created a report and linked with the other report.

The data source will directly applied by the dynamically based on the application invoked.

But when i use the drill down the data source is nor applying for the drill now report dynamically based on the application invoked.

Can any one help me in this.

please let me know your contact number so that i can explain you the issue

Thank in advance.

Regards,
Sreedhar.
Re: Data Source issue which is not picking dynamically [message #1007627 is a reply to message #1007543] Wed, 06 February 2013 19:19 Go to previous messageGo to next message
Michael Williams is currently offline Michael WilliamsFriend
Messages: 1925
Registered: July 2009
Senior Member

Could you create a hidden parameter in your drill down report and pass the dataSource information through it? Let me know if I'm misunderstanding.

Michael

Developer Evangelist, Silanis
Re: Data Source issue which is not picking dynamically [message #1007769 is a reply to message #1007627] Thu, 07 February 2013 13:17 Go to previous messageGo to next message
K SREEDHAR REDDY Reddy is currently offline K SREEDHAR REDDY ReddyFriend
Messages: 8
Registered: February 2013
Junior Member


Hi Michael,

The data source is not showing as a parameter in the drop down list so how can i pass as Hidden parameter.

Can you please let me know

Regards,
Sreedhar.
Re: Data Source issue which is not picking dynamically [message #1007770 is a reply to message #1007769] Thu, 07 February 2013 13:19 Go to previous messageGo to next message
K SREEDHAR REDDY Reddy is currently offline K SREEDHAR REDDY ReddyFriend
Messages: 8
Registered: February 2013
Junior Member
Hi,

Data source is not a parameter it is hold the connection and scheme details of the system with which it dynamically call that particular machine details where it is actually deployed.

Regards,
Sreedhar.
Re: Data Source issue which is not picking dynamically [message #1007837 is a reply to message #1007770] Thu, 07 February 2013 17:06 Go to previous messageGo to next message
Michael Williams is currently offline Michael WilliamsFriend
Messages: 1925
Registered: July 2009
Senior Member

Right, but you say the first report is getting these details just fine. The problem is the drill down report, right? Do you use the same determining method to pick the correct dataSource in the drill down report and it's just not working? If so, you could try creating a report parameter in the drill down report by right clicking on parameters in the data explorer and choosing new parameter. In the parameter editor, you'd select the is hidden check bock. When you go back to the master and go to edit the drill down hyperlink, you should now be able to pass a value through your parameter to the other report. So, if you pass the correct dataSource information from the first report to this parameter, you can now use it in the setup of the second report.

Michael

Developer Evangelist, Silanis
Re: Data Source issue which is not picking dynamically [message #1007849 is a reply to message #1007837] Thu, 07 February 2013 17:49 Go to previous messageGo to next message
K SREEDHAR REDDY Reddy is currently offline K SREEDHAR REDDY ReddyFriend
Messages: 8
Registered: February 2013
Junior Member
Hi,

I created the same and passed all the parameter and its almost solved my problem.

Need to deploy in other servers and test accordingly.

Thanks for you prompt help.

Regards,
Sreedhar.
Re: Data Source issue which is not picking dynamically [message #1007850 is a reply to message #1007849] Thu, 07 February 2013 17:51 Go to previous messageGo to next message
Michael Williams is currently offline Michael WilliamsFriend
Messages: 1925
Registered: July 2009
Senior Member

Great! You're welcome! Let me know the results of the testing!

Michael

Developer Evangelist, Silanis
Re: Data Source issue which is not picking dynamically [message #1008154 is a reply to message #1007837] Mon, 11 February 2013 06:42 Go to previous messageGo to next message
K SREEDHAR REDDY Reddy is currently offline K SREEDHAR REDDY ReddyFriend
Messages: 8
Registered: February 2013
Junior Member
Hi Michael,

I working fine.

Thanks for your prompt reply.

Regards,
Sreedhar.
Re: Data Source issue which is not picking dynamically [message #1008156 is a reply to message #1008154] Mon, 11 February 2013 06:49 Go to previous messageGo to next message
K SREEDHAR REDDY Reddy is currently offline K SREEDHAR REDDY ReddyFriend
Messages: 8
Registered: February 2013
Junior Member
Hi Michael,

I have one more issue

I have displayed 3 rows in report and doing aggregate for one column using above columns data. During this the aggregation is not picking the actual sum value.

let me give an example

I have 2 in row1, 3 in row2, 4 in row3 when i try to do the sum aggregation the result must be 2+3+4=9 But unfortunately i am getting the count as 11. some time first row value will add twice some times second row like that i put a variable running count to check which row it is adding.

The running count for next is missing (1 for row1,2 for row2,4 for row3) in this case row2 value is adding up then the count from the above example is 12 instead of 9


Can you please let me know why this can happen.

IS there any way i have remove duplicate adding of hidden rows are some thing.

Regards,
Sreedhar.

Re: Data Source issue which is not picking dynamically [message #1008249 is a reply to message #1008156] Mon, 11 February 2013 18:14 Go to previous messageGo to next message
Michael Williams is currently offline Michael WilliamsFriend
Messages: 1925
Registered: July 2009
Senior Member

Do you have a visibility expression on your row or anything? If so, can you try using a filter in your aggregation with the same condition?

Michael

Developer Evangelist, Silanis
Re: Data Source issue which is not picking dynamically [message #1008253 is a reply to message #1008249] Mon, 11 February 2013 18:30 Go to previous messageGo to next message
K SREEDHAR REDDY Reddy is currently offline K SREEDHAR REDDY ReddyFriend
Messages: 8
Registered: February 2013
Junior Member
Hi Michael,

I solved the aggregation issue but i have the problem in handling dates using between in oracle.

some time if the in the system is 11-02-2013 but if i gave from and to as 11-02-2013 no rows are returning how to handle this in Birt to get the record with same from and to date and there exists a record also.

i am struck up here and this is the crucial thing i need to figure out.

If you have any code(java script) set to handle the date can you please send me.

All your suggestion are working good to me

Thanks in Advance

Regards,
Sreedhar.
Re: Data Source issue which is not picking dynamically [message #1008483 is a reply to message #1008253] Tue, 12 February 2013 17:18 Go to previous messageGo to next message
Michael Williams is currently offline Michael WilliamsFriend
Messages: 1925
Registered: July 2009
Senior Member

One possibility would be to check your start and end date parameters. If they're the same, edit your query to be where date = theDate instead of using between.

What kind of date handling code would you like? Just one that shows a start and end date that can handle the situation of the dates the same? Or something else? If you'd like an example report, let me know your BIRT version.


Michael

Developer Evangelist, Silanis
Re: Data Source issue which is not picking dynamically [message #1008507 is a reply to message #1008483] Tue, 12 February 2013 18:54 Go to previous messageGo to next message
K SREEDHAR REDDY Reddy is currently offline K SREEDHAR REDDY ReddyFriend
Messages: 8
Registered: February 2013
Junior Member
Hi Michael,

My Birt version is 3.2.22.

I am passing the date in the following format 06.02.2013.

From date and To date will not be same all the time beacuse of time zone off set if i send the parameter like 06.02.2013 and 12.02.2013 it some time displays the 13.02.2013 values also

oracle stores the value in GMT format but when displaying or doing filtering i need to add time zone to display.

if you can provide me some java script code to get time zone and add to the date.

i tried all the possible ways available on the net but still no advance from there.

Please help me with the code if you have.

Thanks in advance,

Regards,
Sreedhar.

[Updated on: Tue, 12 February 2013 19:02]

Report message to a moderator

Re: Data Source issue which is not picking dynamically [message #1008527 is a reply to message #1007543] Tue, 12 February 2013 21:09 Go to previous message
Michael Williams is currently offline Michael WilliamsFriend
Messages: 1925
Registered: July 2009
Senior Member

Take a look at the beforeOpen script of the dataSet. It takes a string value date dd.MM.yyyy for start and end date. It separates them into a string representation of what the database takes. In this case, it's yyyy-MM-dd. If the parameter values are the same, the query's where statement uses '='. If they're different, it uses between. For the sample database, this wasn't necessary, if the values were the same between worked just fine to show the values from just that day.

As for the timezone offset, you should be able to use the function getTimezoneOffset() to grab the offset in minutes. Then, use the BIRTDateTime functions to add/subtract the minutes to/from your date.


Michael

Developer Evangelist, Silanis
Previous Topic:Isolating birt classes from web app
Next Topic:BIRT report w/ parameter fails when ? placed in SQL where clause
Goto Forum:
  


Current Time: Thu Dec 02 01:36:30 GMT 2021

Powered by FUDForum. Page generated in 0.02941 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top