Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Juno Update Site Problem (Win7, 64-bit)
Juno Update Site Problem (Win7, 64-bit) [message #894840] Tue, 10 July 2012 17:34 Go to next message
Robert Sanders is currently offline Robert SandersFriend
Messages: 1
Registered: July 2012
Junior Member
I've been using Eclipse Juno since it came out and its been running fine for me on Windows 7, 32-but system; however I was getting fairly consistent memory errors when I tried to launch it.

Today I tried to install onto a Windows 7 (Pro), 64-bit system. I installed the Java 1.7.05 64bit JDK, then extracted the 64-bit zip archive for Eclipse Juno JEE edition.

Everything starts fine; however when I go to "Help" > "Install New Software" and then select the update site "Juno -". However I get a "There are no categorized items" message. When I uncheck the "Group items by category" check box then I get what appears to be list of the top-level IDE packages, e.g. "Eclipse for Testers", "Eclipse IDE for C/C++ Developers", etc... I was able to install from the "Market". My 32-bit install is working fine.

For now, I will probably just install the 32-bit versions of Java and Eclipse, but I am wondering if this might not be an issue with the update site's metadata so I thought I'd post it here and see if someone more knowledgeable knew.

My 'About Eclipse' is attached.
Re: Juno Update Site Problem (Win7, 64-bit) [message #900433 is a reply to message #894840] Tue, 07 August 2012 05:47 Go to previous messageGo to next message
Michael Kriegel is currently offline Michael KriegelFriend
Messages: 7
Registered: June 2012
Junior Member
I have exactly the same issue using Juno 64bit, but on Linux host. Any fixes so far?

Version: Juno Release
Build id: 20120614-1722
Re: Juno Update Site Problem (Win7, 64-bit) [message #900658 is a reply to message #900433] Wed, 08 August 2012 04:53 Go to previous message
Michael Kriegel is currently offline Michael KriegelFriend
Messages: 7
Registered: June 2012
Junior Member
Okay structured now:

I installed Eclipse Juno Release, Build id: 20120614-1722, 64bit, by extracting the content of the tar.gz-archive to a folder on my Suse Linux Enterprise Server Machine with:

~> java -version
java version "1.6.0_33"
Java(TM) SE Runtime Environment (build 1.6.0_33-b03)
Java HotSpot(TM) 64-Bit Server VM (build 20.8-b03, mixed mode)

The user has full access to this folder. The Program runs completely fine but when I try to install plugins using the dialogue "Install new software..." I got issues with unmet dependencies, which could not be installed for many different plugins I tried to install (e.g. Mylyn connectors, Actifsource, Atlassian Jira, Subversive) and all of those plugins - required by the listed ones - seem to be coming from the softwaresite "Juno -".

Following screenshot shows the initial issue when e.g. trying to install Mylyn Hudson Connector, but the Issue is not(!) just with this plugin but with countless others, too (notice Version 0.0.0 of the missing dependency):


So as a second try I opened the Juno-software-site and it found no packages on the site:


As can be seen nothing is found. Unchecking the box "Group items by category" leads to some "metapackages" (dont know how to call them) to be shown:


Those I cannot install as well, see next screenshot (notice version 0.0.0 for the missing dependency):


When I select "All available sites" in the "Install new Software"-Dialogue I get the categories of the Juno-software-site but they are empty and clicking one of them it shows up version 0.0.0:


Now the questions:

1) How can I install plugins / new software. Is there some configuration which I might have to check? I dont think that it is a connection issue, as I am able to see all software from many other software sites and I can also reach the Juno update site using a web browser from my computer.

2) If the issue is on the update site, is there any mirror/alternative site/address which I might try to find the missing dependencies in?

3) Are there any further information which would be necessary for others to be able to help me?

Thank you in advance for your time, Michael
  • Attachment: e5.JPG
    (Size: 79.64KB, Downloaded 1636 times)
  • Attachment: e1.JPG
    (Size: 51.59KB, Downloaded 1484 times)
  • Attachment: e2.JPG
    (Size: 72.61KB, Downloaded 1517 times)
  • Attachment: e3.JPG
    (Size: 60.77KB, Downloaded 1518 times)
  • Attachment: e4.JPG
    (Size: 63.36KB, Downloaded 1541 times)

[Updated on: Wed, 08 August 2012 04:54]

Report message to a moderator

Previous Topic:eclipse crashes at startup
Next Topic:problem with PhysX
Goto Forum:

Current Time: Mon May 16 16:59:57 GMT 2022

Powered by FUDForum. Page generated in 0.03543 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top