Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Cloned project contains changes(I clone a project and notice files are changed)
Cloned project contains changes [message #893340] Tue, 03 July 2012 15:43 Go to next message
Jens Rantil is currently offline Jens RantilFriend
Messages: 2
Registered: July 2012
Junior Member
So, I've been fighting git's newline-autofix-features all day. Initially I was having trouble making a clean clone using command line git. 'git status' showed files had changed and 'git diff' hinted it had something to do with the automagic line ending fixes that git makes. I fixed this by --globally setting core.autocrlf=native and core.whitespace=cr-at-eol and cloning the project once again.

Five minutes later I clone the same project in EGit and EGit tells me the files are modified when they are not. Any input? Just a push in any direction would do.

Additional things:

  • If it wasn't for the fact that I was running Eclipse Juno with EGit- I would guess I am experiencing this as mentioned in this thread. However, that bug seems to be fixed in 2.0-final, which I am running.
  • Eclipse file compare shows no differences.
  • command line 'git status' in the same EGit project tells me no modified files exists.
  • Window > Preferences > Team > Git > Configuration shows the correct (core.autocrlf and core.whitespace) config settings.
  • I also tried setting the *.jsp file type to binary in Window > Preferences > Team > File Content which was my last hope. Does not seem to help anything. Evil or Very Mad
Re: Cloned project contains changes [message #893753 is a reply to message #893340] Thu, 05 July 2012 13:03 Go to previous message
Jens Rantil is currently offline Jens RantilFriend
Messages: 2
Registered: July 2012
Junior Member
I seem to have found a workaround for this issue:

  1. Remove all files and folders except '.git' in the checkout out project.
  2. Execute "git config --local core.autcrlf false" in the project folder.
  3. Perform a hard reset in EGit.

Has worked at two occasions.
Previous Topic:Remove project from workspace only
Next Topic:Add to version control
Goto Forum:

Current Time: Sat Sep 19 10:36:51 GMT 2020

Powered by FUDForum. Page generated in 0.02022 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top