Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » Extended Model needs class/type instance of the referenced Base Model
Extended Model needs class/type instance of the referenced Base Model [message #885005] Tue, 12 June 2012 08:55 Go to next message
Bugra Derre is currently offline Bugra DerreFriend
Messages: 5
Registered: June 2012
Junior Member
Hello,

I'm new in the topic of the Eclipse Modeling Framework. Actually I have a BaseModel.ecore. In another EMF Project, I have a ExtendingModel.ecore which references BaseModel.ecore. The ExtendingModel.ecore needs an instance of a type in BaseModel.ecore.

Starting the editor for the ExtendingModel.ecore shows only the modeling elements for the ExtendingModel.ecore but not the elements for BaseModel.ecore.

This is the current problem I have. I need an instance of a Class/Type in BaseModel.ecore for my ExtendingModel.ecore. How do I achieve this? Is there any good practice? Did I understand something wrong?

I appreciate any help.
Re: Extended Model needs class/type instance of the referenced Base Model [message #885022 is a reply to message #885005] Tue, 12 June 2012 09:28 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30631
Registered: July 2009
Senior Member
Bugra,

Comments below.

On 12/06/2012 10:55 AM, Bugra Derre wrote:
> Hello,
>
> I'm new in the topic of the Eclipse Modeling Framework. Actually I
> have a BaseModel.ecore. In another EMF Project, I have a
> ExtendingModel.ecore which references BaseModel.ecore. The
> ExtendingModel.ecore needs an instance of a type in BaseModel.ecore.
>
> Starting the editor for the ExtendingModel.ecore shows only the
> modeling elements for the ExtendingModel.ecore but not the elements
> for BaseModel.ecore.
Show's it where? The properties view or the initial wizard?
>
> This is the current problem I have. I need an instance of a Class/Type
> in BaseModel.ecore for my ExtendingModel.ecore.
Do you have containment references to them or non-containment
references? In the former case, I'd expect you to be able to create a
new child of the correct type. In the later case, you can use Load
Resource... in the context menu to open a resource that contains the
types of instances you need; those objects will be available in the
properties view
> How do I achieve this? Is there any good practice? Did I understand
> something wrong?
>
> I appreciate any help.
Re: Extended Model needs class/type instance of the referenced Base Model [message #885027 is a reply to message #885022] Tue, 12 June 2012 09:48 Go to previous messageGo to next message
Bugra Derre is currently offline Bugra DerreFriend
Messages: 5
Registered: June 2012
Junior Member
Hi Ed thanks for your answer. I think, I found my problem. I think I didn't configure the model editor properly. I'm trying to fix this. I thank you anyway.

Ed Merks wrote on Tue, 12 June 2012 05:28
Bugra,

Comments below.

On 12/06/2012 10:55 AM, Bugra Derre wrote:
> Hello,
>
> I'm new in the topic of the Eclipse Modeling Framework. Actually I
> have a BaseModel.ecore. In another EMF Project, I have a
> ExtendingModel.ecore which references BaseModel.ecore. The
> ExtendingModel.ecore needs an instance of a type in BaseModel.ecore.
>
> Starting the editor for the ExtendingModel.ecore shows only the
> modeling elements for the ExtendingModel.ecore but not the elements
> for BaseModel.ecore.
Show's it where? The properties view or the initial wizard?
>
> This is the current problem I have. I need an instance of a Class/Type
> in BaseModel.ecore for my ExtendingModel.ecore.
Do you have containment references to them or non-containment
references? In the former case, I'd expect you to be able to create a
new child of the correct type. In the later case, you can use Load
Resource... in the context menu to open a resource that contains the
types of instances you need; those objects will be available in the
properties view
> How do I achieve this? Is there any good practice? Did I understand
> something wrong?
>
> I appreciate any help.

Re: Extended Model needs class/type instance of the referenced Base Model [message #885652 is a reply to message #885027] Wed, 13 June 2012 12:01 Go to previous messageGo to next message
Bugra Derre is currently offline Bugra DerreFriend
Messages: 5
Registered: June 2012
Junior Member
After experiencing a little bit more with EMF, I found a link from Ed Merk in his Blog ed-merks.blogspot.de/2008/01/creating-children-you-didnt-know.html. Fortunately this describes the problem I have with my extending model. The extensions of my model should be displayed in the editor of my base editor. Unfortunately it doesn't work for me.

Has anyone the same experience and/or any hints?
Re: Extended Model needs class/type instance of the referenced Base Model [message #885671 is a reply to message #885652] Wed, 13 June 2012 12:17 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30631
Registered: July 2009
Senior Member
Bugra,

Did you delete the plugin.xmls and regenerate them?


On 13/06/2012 2:01 PM, Bugra Derre wrote:
> After experiencing a little bit more with EMF, I found a link from Ed
> Merk in his Blog
> ed-merks.blogspot.de/2008/01/creating-children-you-didnt-know.html.
> Fortunately this describes the problem I have with my extending model.
> The extensions of my model should be displayed in the editor of my
> base editor. Unfortunately it doesn't work for me.
>
> Has anyone the same experience and/or any hints?
Re: Extended Model needs class/type instance of the referenced Base Model [message #885687 is a reply to message #885671] Wed, 13 June 2012 12:42 Go to previous messageGo to next message
Bugra Derre is currently offline Bugra DerreFriend
Messages: 5
Registered: June 2012
Junior Member
Hi Ed. Yes, I did delete them all from my extended model / edit / editor project. Are there any other configurations I should set? Am I right that the changes should be seen in the base editor?

Greets
Re: Extended Model needs class/type instance of the referenced Base Model [message #885717 is a reply to message #885687] Wed, 13 June 2012 13:24 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30631
Registered: July 2009
Senior Member
Bugra,

That blog was pretty clear on what needed to be set in your GenModels; I
assume you did all those configurations already. Do you see the
additional registrations in your edit project's plugin.xml files?

Note that you've never been clear about what classes and what types of
references between them are involved and I can't begin to guess as such
things.

On 13/06/2012 2:42 PM, Bugra Derre wrote:
> Hi Ed. Yes, I did delete them all from my extended model / edit /
> editor project. Are there any other configurations I should set? Am I
> right that the changes should be seen in the base editor?
>
> Greets
Re: Extended Model needs class/type instance of the referenced Base Model [message #885741 is a reply to message #885717] Wed, 13 June 2012 14:14 Go to previous message
Bugra Derre is currently offline Bugra DerreFriend
Messages: 5
Registered: June 2012
Junior Member
Hi Ed,

solved the origin problem but experiencing another one. Origin problem was; I didn't check the 'Extensible Provider Factory' to true (Sorry). The types and classes are from the example in the blog Resource and Link. Now I see the elements of the extending model in the editor and can select them. But the other problem I have now is, that if I choose such an element in the context menu (New | File, Folder, Link) the element is not visible in the editor, but it is described in the *.resource - modelfile when I open it with the text editor. Did you experience any error like that before?
Previous Topic:[Teneo] Hibernate Auditing Support
Next Topic:[CDO/Teneo/Hibernate] Select query very large ....
Goto Forum:
  


Current Time: Thu Nov 14 18:51:04 GMT 2019

Powered by FUDForum. Page generated in 0.02464 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top