Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Test and Performance Tools Platform (TPTP) » TPTP Unusable on Linux x86_64
TPTP Unusable on Linux x86_64 [message #113550] Mon, 01 October 2007 09:25
Marco Maccaferri is currently offline Marco MaccaferriFriend
Messages: 138
Registered: July 2009
Senior Member
Hi All.

When TPTP 4.4 comes out I decided to give it a try, I found that it
wasn't working on 64bit Linux due to some issues in recognizing and
starting the Integrated Agent Controller, so I opened bugs 196341 and
197783 that were promptly fixed. Unfortunately these bugs didn't make it
to release so I had to install the 4.4.1 development, not a
problem it worked nicely.

Now I've updated Eclipse to 3.3.1 and installed TPTP, to my
surprise the fixes are still not present in this release. TPTP
still can't work on 64 bit Linux, this is very disappointing.

Ok, then, I'll download the latest TPTP 4.4.1 development, I know that
it works. Not! It doesn't work anymore, the IAC is started correctly but
the profiler refuses to connect to it, it keeps saying that the Agent
Controller is unavailable on port 10002. A quick look with netstat shows
that the Agent Controller is running and is waiting on port 10002, I
also see that something tried to connect to port 10002 so I think that
everything is setup correctly.

I found a bugzilla bug related to the dependency to openssl, I don't
think that this is the cause, the IAC is started correctly, I don't see
messages about unresolved dependencies anywere. I tried to enable
security, to explicitly add the permissions for the local host, without
any effect. I see a reference to a getting started document, but I can't
find it anywhere, does it have more informations on this issue ?

I'm sorry to complain like this, I see the value of TPTP, and I tried to
push its use to my co-workers over a commercial product, but these
issues are a show stopper. Now I'm forced to give up on TPTP and revert
back to this commercial product, I can't promote the use of TPTP when I
can't use it myself anymore.

Hope to see this fixed soon.

Previous Topic:profiling problem ?
Next Topic:[AGR] Obscure NullPointerException when playing back a test
Goto Forum:

Current Time: Thu Feb 20 11:00:30 GMT 2020

Powered by FUDForum. Page generated in 0.02128 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top