Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Report Error when generating(Report Error when generating)
Report Error when generating [message #856982] Thu, 26 April 2012 06:20 Go to next message
Mitchell Bevan is currently offline Mitchell BevanFriend
Messages: 6
Registered: April 2012
Junior Member
Hi,

Our developer has another reporting issue that I need solved as soon as possible. I have a report in BIRT 2.5 that will not run in the TIP. This is due to a JDBC error. I have done two things that may have caused this:

1) I have pointed the report designer "resources" at the following folder: <\\metisentrep\east\Troux Architect Files\BIRT\03 Report Resources and Report Libraries\>. (Window-->Preferences-->Report Design-->Resource). I have images and master pages ect stored in this folder that is used in generation of my report.
2) I have renamed the troux_core.library to troux_core_2_5.library and used this in the report. This is also stored within the above folder.

The report runs fine from BIRT. Obviously something in the report itself, or the TIP is not pointing to the correct resources, or my renaming the troux library has broken something.

I have a suspicion that because the TIP is in a lower lever network domain, its on a different server with different credentials, it can't authenicate to the production network domain where the report is being run from e.g. the metisentrep server is in the production domain.

Attached is the error message

Can you investigate?
Re: Report Error when generating [message #857646 is a reply to message #856982] Thu, 26 April 2012 18:36 Go to previous message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

The error does not look like it has anything to do with resource folder
but possibly not locating the jdbc driver in the drivers directory of
the jdbc plugin in your deployed env,

Jason

On 4/26/2012 2:20 AM, Mitchell Bevan wrote:
> Hi,
>
> Our developer has another reporting issue that I need solved as soon as possible. I have a report in BIRT 2.5 that will not run in the TIP. This is due to a JDBC error. I have done two things that may have caused this:
>
> 1) I have pointed the report designer "resources" at the following folder:<\\metisentrep\east\Troux Architect Files\BIRT\03 Report Resources and Report Libraries\>. (Window-->Preferences-->Report Design-->Resource). I have images and master pages ect stored in this folder that is used in generation of my report.
> 2) I have renamed the troux_core.library to troux_core_2_5.library and used this in the report. This is also stored within the above folder.
>
> The report runs fine from BIRT. Obviously something in the report itself, or the TIP is not pointing to the correct resources, or my renaming the troux library has broken something.
>
> I have a suspicion that because the TIP is in a lower lever network domain, its on a different server with different credentials, it can't authenicate to the production network domain where the report is being run from e.g. the metisentrep server is in the production domain.
>
> Attached is the error message
>
> Can you investigate?
>
Previous Topic:Problem with Birt Viewer 3.7.1 using Scripted data source
Next Topic:"cant re-generate content for MultiLineItem" exception with Dynamic Text elements
Goto Forum:
  


Current Time: Sun Feb 23 12:21:23 GMT 2020

Powered by FUDForum. Page generated in 0.01850 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top