Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Xtend 2.3 -> Guice Problems
Xtend 2.3 -> Guice Problems [message #854906] Tue, 24 April 2012 10:50 Go to next message
Soenke Brightside is currently offline Soenke BrightsideFriend
Messages: 41
Registered: January 2011
Member
Hi,

after upgrading Xtend to version 2.3 i get some Guice errors:

1) No implementation for org.eclipse.xtext.generator.IDerivedResourceMarkers was bound.
  while locating org.eclipse.xtext.generator.IDerivedResourceMarkers
    for field at org.eclipse.xtext.builder.BuilderParticipant.derivedResourceMarkers(Unknown Source)
  while locating xx.xx.ft.exchange.graphml.xtend.ui.action.GenerationAction

2) No implementation for org.eclipse.core.resources.IWorkspace was bound.
  while locating org.eclipse.core.resources.IWorkspace
    for field at org.eclipse.xtext.builder.EclipseResourceFileSystemAccess2.workspace(Unknown Source)
  while locating com.google.inject.Provider<org.eclipse.xtext.builder.EclipseResourceFileSystemAccess2>
    for field at org.eclipse.xtext.builder.BuilderParticipant.fileSystemAccessProvider(Unknown Source)
  while locating xx.xx.ft.exchange.graphml.xtend.ui.action.GenerationAction


I guess i have bind some stuff in my module?

Sönke
Re: Xtend 2.3 -&gt; Guice Problems [message #854934 is a reply to message #854906] Tue, 24 April 2012 11:20 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian ZarnekowFriend
Messages: 3108
Registered: July 2009
Senior Member
Hi Sönke,

did you regenerate your language? Have you compared your workflow with
the one that is generated for new languages?

Regards,
Sebastian
--
Need professional support for Eclipse Modeling?
Go visit: http://xtext.itemis.com

Am 24.04.12 12:50, schrieb Soenke Escher:
> Hi,
> after upgrading Xtend to version 2.3 i get some Guice errors:
>
>
> 1) No implementation for
> org.eclipse.xtext.generator.IDerivedResourceMarkers was bound.
> while locating org.eclipse.xtext.generator.IDerivedResourceMarkers
> for field at
> org.eclipse.xtext.builder.BuilderParticipant.derivedResourceMarkers(Unknown
> Source)
> while locating xx.xx.ft.exchange.graphml.xtend.ui.action.GenerationAction
>
> 2) No implementation for org.eclipse.core.resources.IWorkspace was bound.
> while locating org.eclipse.core.resources.IWorkspace
> for field at
> org.eclipse.xtext.builder.EclipseResourceFileSystemAccess2.workspace(Unknown
> Source)
> while locating
> com.google.inject.Provider<org.eclipse.xtext.builder.EclipseResourceFileSystemAccess2>
>
> for field at
> org.eclipse.xtext.builder.BuilderParticipant.fileSystemAccessProvider(Unknown
> Source)
> while locating xx.xx.ft.exchange.graphml.xtend.ui.action.GenerationAction
>
> I guess i have bind some stuff in my module?
> Sönke
Re: Xtend 2.3 -&gt; Guice Problems [message #854947 is a reply to message #854934] Tue, 24 April 2012 11:36 Go to previous messageGo to next message
Soenke Brightside is currently offline Soenke BrightsideFriend
Messages: 41
Registered: January 2011
Member
Hi Sebastian,

I have no "language". I only use xtend to generate some files from an ecore model. And yes, i regenerated the java file (from the .xtend file).

Sönke


Sebastian Zarnekow wrote on Tue, 24 April 2012 07:20
Hi Sönke,

did you regenerate your language? Have you compared your workflow with
the one that is generated for new languages?

Regards,
Sebastian

Re: Xtend 2.3 -&amp;gt; Guice Problems [message #854989 is a reply to message #854947] Tue, 24 April 2012 12:18 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian ZarnekowFriend
Messages: 3108
Registered: July 2009
Senior Member
Hi Sönke,

so you'll have to add some bindings, that's true. I'd assume that the
error messages by Guice will guide you in the right direction, e.g. bind
IDerivedResourceMarkers to DerivedResourceMarkers.

Regards,
Sebastian
--
Need professional support for Eclipse Modeling?
Go visit: http://xtext.itemis.com

Am 24.04.12 13:36, schrieb Soenke Escher:
> Hi Sebastian,
>
> I have no "language". I only use xtend to generate some files from an
> ecore model. And yes, i regenerated the java file (from the .xtend file).
>
> Sönke
>
>
> Sebastian Zarnekow wrote on Tue, 24 April 2012 07:20
>> Hi Sönke,
>>
>> did you regenerate your language? Have you compared your workflow with
>> the one that is generated for new languages?
>>
>> Regards,
>> Sebastian
>
>
Re: Xtend 2.3 -&amp;gt; Guice Problems [message #895861 is a reply to message #854989] Mon, 16 July 2012 10:52 Go to previous messageGo to next message
Matthias Cullmann is currently offline Matthias CullmannFriend
Messages: 1
Registered: July 2012
Junior Member
I had a similar problem and fixed it by adding the following code to <XY>RuntimeModule as decribed in the Xtext user guide.
  public Class<? extends IWorkspace> bindIWorkspace() {
    return Workspace.class;
  }

  public Class<? extends IStorage2UriMapper> bindIStorage2UriMapper() {
    return Storage2UriMapperImpl.class;
  }

(I also had to add Require-Bundle: org.eclipse.equinox.common, org.eclipse.xtext.ui to the MANIFEST.MF)
Re: Xtend 2.3 -&amp;amp;gt; Guice Problems [message #895869 is a reply to message #895861] Mon, 16 July 2012 11:54 Go to previous message
Sebastian Zarnekow is currently offline Sebastian ZarnekowFriend
Messages: 3108
Registered: July 2009
Senior Member
I won't recommend doing that. Having a dep to xtext.ui from your runtime
bundle sounds wrong, doesn't it?

Regards,
Sebastian
--
Need professional support for Eclipse Modeling?
Go visit: http://xtext.itemis.com

Am 16.07.12 12:52, schrieb Matthias Cullmann:
> I had a similar problem and fixed it by adding the following code to
> <XY>RuntimeModule
> http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse.xtext.doc/help/dependencyInjection.html.
>
>
> public Class<? extends IWorkspace> bindIWorkspace() {
> return Workspace.class;
> }
>
> public Class<? extends IStorage2UriMapper> bindIStorage2UriMapper() {
> return Storage2UriMapperImpl.class;
> }
>
> (I also had to add Require-Bundle: org.eclipse.equinox.common,
> org.eclipse.xtext.ui to the MANIFEST.MF)
Previous Topic:How to set value for a name attribute in a composite relationship?
Next Topic:Problem with the language name
Goto Forum:
  


Current Time: Sat Sep 26 05:12:18 GMT 2020

Powered by FUDForum. Page generated in 0.02103 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top