Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » How can I check feature assignment is ok?
How can I check feature assignment is ok? [message #843100] Thu, 12 April 2012 19:12 Go to next message
Cristiano Gavião is currently offline Cristiano GaviãoFriend
Messages: 279
Registered: July 2009
Senior Member
When I'm testing my DSL in another eclipse instance I can see at Outline View the elements being fulfilled. Each element o that view is named with the primary EString property/feature value.

But I want to see the values of other properties of the selected element to check if assignment is being ok. Properties view shows me nothing...

Is there any way to do that?

thanks

Cristiano
Re: How can I check feature assignment is ok? [message #843109 is a reply to message #843100] Thu, 12 April 2012 19:23 Go to previous messageGo to next message
Christian Dietrich is currently online Christian DietrichFriend
Messages: 13513
Registered: July 2009
Senior Member
Hi,

what about using the outline api as documented?

~Christian


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: How can I check feature assignment is ok? [message #843132 is a reply to message #843109] Thu, 12 April 2012 19:51 Go to previous messageGo to next message
Cristiano Gavião is currently offline Cristiano GaviãoFriend
Messages: 279
Registered: July 2009
Senior Member
Well, Smile
I can confess to you that I'm buzzy reading and rereading this one first http://www.eclipse.org/Xtext/documentation/2_1_0/020-grammar-language.php because I could not finish the grammar yet.. I'm bitten by some not nice ambiguous erros...

I never hear about such overview api, and probably won't have time for that so soon. I just thought that I could have same information that Properties View gives me using ecore editor when editing a ecore model...

regards,

Cristiano
Re: How can I check feature assignment is ok? [message #843136 is a reply to message #843132] Thu, 12 April 2012 19:56 Go to previous messageGo to next message
Christian Dietrich is currently online Christian DietrichFriend
Messages: 13513
Registered: July 2009
Senior Member
Hi,

am not quite sure what you are now talking about.
in your first post you were talking about the outline.
the outline shows the structure of the model.
of course you could change it so that it shows the whole model.
but therefore you have to customize the Outline as described here (especially "Influencing the Structure")
http://www.eclipse.org/Xtext/documentation/2_1_0/170-outline.php

~Christian


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: How can I check feature assignment is ok? [message #843144 is a reply to message #843136] Thu, 12 April 2012 20:07 Go to previous messageGo to next message
Christian Dietrich is currently online Christian DietrichFriend
Messages: 13513
Registered: July 2009
Senior Member
Btw did you try to open the .mydsl file with "sample (reflective) ecore model editor" - this might help you if you really want to "test" your grammar - id prefer a unit test in this case.

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: How can I check feature assignment is ok? [message #843153 is a reply to message #843136] Thu, 12 April 2012 20:15 Go to previous messageGo to next message
Cristiano Gavião is currently offline Cristiano GaviãoFriend
Messages: 279
Registered: July 2009
Senior Member
Well, sorry for not be that clear... english for me sometimes is not that easy to express...

I'll try to explain.
Supposed that I have a ecore model file and I have generated an Editor and Edit projects from it using genModel.
I use the generated editor to include some instances and there are an out-of-box properties view and outline view integration.
When editing the model, if I select one element instance in the outline view, I can see all its properties in the properties view.

When editing this same model using xtext, I can see the the overview elements, but can't see its properties.
got it now ?
Re: How can I check feature assignment is ok? [message #843158 is a reply to message #843144] Thu, 12 April 2012 20:21 Go to previous message
Cristiano Gavião is currently offline Cristiano GaviãoFriend
Messages: 279
Registered: July 2009
Senior Member
Christian Dietrich wrote on Thu, 12 April 2012 23:07
Btw did you try to open the .mydsl file with "sample (reflective) ecore model editor" - this might help you if you really want to "test" your grammar - id prefer a unit test in this case.


Humm, that will help a lot....

I will try to play with unit tests as soon I have my grammar working Smile

thanks

Cristiano
Previous Topic:Problem in parsing whitespace sensitive DSL
Next Topic:Launching rename operation in fix provider
Goto Forum:
  


Current Time: Tue Aug 04 12:01:48 GMT 2020

Powered by FUDForum. Page generated in 0.01908 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top