Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Package uses conflict error
Package uses conflict error [message #101851] Wed, 21 November 2007 17:48 Go to next message
Pedro Silva is currently offline Pedro SilvaFriend
Messages: 25
Registered: July 2009
Junior Member
Hi,

I'm getting this error in the console for a bundle that I'm loading.
This bunle imports this package from bundle 61 that is in active state.
I don't understand this message since the bundle 61 is exporting the
refered package...

osgi> diag 62
initial@reference:file:load/aircraft-1.0.0-SNAPSHOT.jar/ [62]
Package uses conflict: Import-Package:
com.xxxxxxxxxxxxxxxxxxxxxx.data.entity.log; version="0.0.0"
Missing imported package


Any help?

Thanks,
Pedro Silva
Re: Package uses conflict error [message #101870 is a reply to message #101851] Wed, 21 November 2007 20:07 Go to previous messageGo to next message
Simon Kaegi is currently offline Simon KaegiFriend
Messages: 381
Registered: July 2009
Senior Member
Hi Pedro,

Are you using "uses"?

This can occur when your bundle (62) imports the same package as the other
(61), but they are wired to different bundles.
For example, if both 61 and 62 imported javax.servlet:
1) Bundle 61 binds to the javax.servlet export from bundle A
2) Bundle 62 binds to the javax.servlet export from bundle B

If bundle 62 tries to import a package from 61 that "uses" javax.servlet
then there will be a conflict.

--
If this isn't it then it would probably be easiest if you just posted the
two manifests.

HTH
-Simon

"Pedro Silva" <psilva@dcc.online.pt> wrote in message
news:fi1r1c$eh3$1@build.eclipse.org...
> Hi,
>
> I'm getting this error in the console for a bundle that I'm loading. This
> bunle imports this package from bundle 61 that is in active state. I don't
> understand this message since the bundle 61 is exporting the refered
> package...
>
> osgi> diag 62
> initial@reference:file:load/aircraft-1.0.0-SNAPSHOT.jar/ [62]
> Package uses conflict: Import-Package:
> com.xxxxxxxxxxxxxxxxxxxxxx.data.entity.log; version="0.0.0"
> Missing imported package
>
>
> Any help?
>
> Thanks,
> Pedro Silva
Re: Package uses conflict error [message #101881 is a reply to message #101870] Thu, 22 November 2007 11:17 Go to previous messageGo to next message
Pedro Silva is currently offline Pedro SilvaFriend
Messages: 25
Registered: July 2009
Junior Member
I'm using maven plugin to build my MANIFEST files. I see that my
manifests have the uses keyword but I only have one bundle that exports
the package they are said to use.

Basically I have a bundle that exports some entities. and then I have
this bundle that exports some package that uses the exported package
with entities but this entities only exist in the first bundle, and are
only exported there.

Is there a way to see to which bundle they could be linking?

Thanks,
Pedro Silva

Simon Kaegi wrote:
> Hi Pedro,
>
> Are you using "uses"?
>
> This can occur when your bundle (62) imports the same package as the other
> (61), but they are wired to different bundles.
> For example, if both 61 and 62 imported javax.servlet:
> 1) Bundle 61 binds to the javax.servlet export from bundle A
> 2) Bundle 62 binds to the javax.servlet export from bundle B
>
> If bundle 62 tries to import a package from 61 that "uses" javax.servlet
> then there will be a conflict.
>
> --
> If this isn't it then it would probably be easiest if you just posted the
> two manifests.
>
> HTH
> -Simon
>
> "Pedro Silva" <psilva@dcc.online.pt> wrote in message
> news:fi1r1c$eh3$1@build.eclipse.org...
>> Hi,
>>
>> I'm getting this error in the console for a bundle that I'm loading. This
>> bunle imports this package from bundle 61 that is in active state. I don't
>> understand this message since the bundle 61 is exporting the refered
>> package...
>>
>> osgi> diag 62
>> initial@reference:file:load/aircraft-1.0.0-SNAPSHOT.jar/ [62]
>> Package uses conflict: Import-Package:
>> com.xxxxxxxxxxxxxxxxxxxxxx.data.entity.log; version="0.0.0"
>> Missing imported package
>>
>>
>> Any help?
>>
>> Thanks,
>> Pedro Silva
>
>
Re: Package uses conflict error [message #101906 is a reply to message #101881] Thu, 22 November 2007 15:33 Go to previous message
Simon Kaegi is currently offline Simon KaegiFriend
Messages: 381
Registered: July 2009
Senior Member
You can use the "bundle" or "b" command to track down the specifics on which
import is being used.
HTH
-Simon

"Pedro Silva" <psilva@dcc.online.pt> wrote in message
news:fi3og3$jpu$1@build.eclipse.org...
> I'm using maven plugin to build my MANIFEST files. I see that my manifests
> have the uses keyword but I only have one bundle that exports the package
> they are said to use.
>
> Basically I have a bundle that exports some entities. and then I have this
> bundle that exports some package that uses the exported package with
> entities but this entities only exist in the first bundle, and are only
> exported there.
>
> Is there a way to see to which bundle they could be linking?
>
> Thanks,
> Pedro Silva
>
> Simon Kaegi wrote:
>> Hi Pedro,
>>
>> Are you using "uses"?
>>
>> This can occur when your bundle (62) imports the same package as the
>> other (61), but they are wired to different bundles.
>> For example, if both 61 and 62 imported javax.servlet:
>> 1) Bundle 61 binds to the javax.servlet export from bundle A
>> 2) Bundle 62 binds to the javax.servlet export from bundle B
>>
>> If bundle 62 tries to import a package from 61 that "uses" javax.servlet
>> then there will be a conflict.
>>
>> --
>> If this isn't it then it would probably be easiest if you just posted the
>> two manifests.
>>
>> HTH
>> -Simon
>>
>> "Pedro Silva" <psilva@dcc.online.pt> wrote in message
>> news:fi1r1c$eh3$1@build.eclipse.org...
>>> Hi,
>>>
>>> I'm getting this error in the console for a bundle that I'm loading.
>>> This bunle imports this package from bundle 61 that is in active state.
>>> I don't understand this message since the bundle 61 is exporting the
>>> refered package...
>>>
>>> osgi> diag 62
>>> initial@reference:file:load/aircraft-1.0.0-SNAPSHOT.jar/ [62]
>>> Package uses conflict: Import-Package:
>>> com.xxxxxxxxxxxxxxxxxxxxxx.data.entity.log; version="0.0.0"
>>> Missing imported package
>>>
>>>
>>> Any help?
>>>
>>> Thanks,
>>> Pedro Silva
>>
Previous Topic:Re: Plugin.getBundle() == null!
Next Topic:Assing an import package to a bundle with maven
Goto Forum:
  


Current Time: Sun Dec 05 12:07:43 GMT 2021

Powered by FUDForum. Page generated in 0.01666 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top