Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » Clean EMF install: Project does not exist?
Clean EMF install: Project does not exist? [message #99107] Sun, 14 October 2007 13:35 Go to next message
Eclipse UserFriend
Originally posted by: mielzpost.gmail.com

Sorry for the crosspost but i posted it in modeling, so i better post it
here, my apologies.

Dear All,

I've 'installed' a copy of Eclipse 3.3.0, with EMF 2.3.0.v2 under Vista.
And as soon as i try to start a new project it gives me the following
error:

The project was not built due to "[PROJECTNAME HERE] does not exist". Fix
the problem, then try refreshing this project and building it since it may
be inconsistent

I've also tried to install OAW and but same results. It seems like i cant
build anything, while i've installed practically everything. Actually im a
c#/.net guru, but your EMF DSL tools kick so much ass i just had to
install it, too bad i cant get it too work. Who has any ideas?

Regards,

Emile Bosch
Re: Clean EMF install: Project does not exist? [message #99122 is a reply to message #99107] Sun, 14 October 2007 15:41 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: merks.ca.ibm.com

This is a multi-part message in MIME format.
--------------070002030401060506030706
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit

Emile,

Did you install using the zip files? Did you run eclipse.exe with
-clean? You're sure you're running with a JDK 5.0 or greater? Try
clearing the Error log view and starting Eclipse again with -clean
-debug and check that the Error log view doesn't contain messages about
plugins that are failing to activate. Is the error message really
complaining that project X which you created cannot be built because
project X doesn't exist? Can you create a basic Java project that
works? How exactly did you create the project?

Note Reinhold Bihler is working on a C# version of the EMF runtime. He
plans to create an EMFT component for it soon. You might be interested
in it:
<http://www.emf4net.org/>

http://www.emf4net.org/


Emile Bosch wrote:
> Sorry for the crosspost but i posted it in modeling, so i better post
> it here, my apologies.
>
> Dear All,
>
> I've 'installed' a copy of Eclipse 3.3.0, with EMF 2.3.0.v2 under
> Vista. And as soon as i try to start a new project it gives me the
> following error:
>
> The project was not built due to "[PROJECTNAME HERE] does not exist".
> Fix the problem, then try refreshing this project and building it
> since it may be inconsistent
> I've also tried to install OAW and but same results. It seems like i
> cant build anything, while i've installed practically everything.
> Actually im a c#/.net guru, but your EMF DSL tools kick so much ass i
> just had to install it, too bad i cant get it too work. Who has any
> ideas?
>
> Regards,
>
> Emile Bosch
>
>


--------------070002030401060506030706
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 8bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-15"
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Emile,<br>
<br>
Did you install using the zip files?
Re: Clean EMF install: Project does not exist? [message #99537 is a reply to message #99122] Wed, 17 October 2007 21:18 Go to previous message
Eclipse UserFriend
Originally posted by: mielzpost.gmail.com

Ed, thanks

I will try to create a new install,
I must say, Java modeling is sure looks superior to ms dsl solutions,

To the way the java community uses it looks fairly limited, for instance,
i would use a dsl for creating not only code, but also use it for manual
and procedure generation. Documenation. Configuring of CRM, AX, nav etc.

Keep up the good work! (Sometimes i wish i was a java dev myself)

Emile Bosch
Re: Clean EMF install: Project does not exist? [message #610004 is a reply to message #99107] Sun, 14 October 2007 15:41 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 33152
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------070002030401060506030706
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit

Emile,

Did you install using the zip files? Did you run eclipse.exe with
-clean? You're sure you're running with a JDK 5.0 or greater? Try
clearing the Error log view and starting Eclipse again with -clean
-debug and check that the Error log view doesn't contain messages about
plugins that are failing to activate. Is the error message really
complaining that project X which you created cannot be built because
project X doesn't exist? Can you create a basic Java project that
works? How exactly did you create the project?

Note Reinhold Bihler is working on a C# version of the EMF runtime. He
plans to create an EMFT component for it soon. You might be interested
in it:
<http://www.emf4net.org/>

http://www.emf4net.org/


Emile Bosch wrote:
> Sorry for the crosspost but i posted it in modeling, so i better post
> it here, my apologies.
>
> Dear All,
>
> I've 'installed' a copy of Eclipse 3.3.0, with EMF 2.3.0.v2 under
> Vista. And as soon as i try to start a new project it gives me the
> following error:
>
> The project was not built due to "[PROJECTNAME HERE] does not exist".
> Fix the problem, then try refreshing this project and building it
> since it may be inconsistent
> I've also tried to install OAW and but same results. It seems like i
> cant build anything, while i've installed practically everything.
> Actually im a c#/.net guru, but your EMF DSL tools kick so much ass i
> just had to install it, too bad i cant get it too work. Who has any
> ideas?
>
> Regards,
>
> Emile Bosch
>
>


--------------070002030401060506030706
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 8bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-15"
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Emile,<br>
<br>
Did you install using the zip files?


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Clean EMF install: Project does not exist? [message #610061 is a reply to message #99122] Wed, 17 October 2007 21:18 Go to previous message
Eclipse UserFriend
Originally posted by: mielzpost.gmail.com

Ed, thanks

I will try to create a new install,
I must say, Java modeling is sure looks superior to ms dsl solutions,

To the way the java community uses it looks fairly limited, for instance,
i would use a dsl for creating not only code, but also use it for manual
and procedure generation. Documenation. Configuring of CRM, AX, nav etc.

Keep up the good work! (Sometimes i wish i was a java dev myself)

Emile Bosch
Previous Topic:[Compare] extensibility
Next Topic:[Compare] extensibility
Goto Forum:
  


Current Time: Fri May 24 07:23:22 GMT 2024

Powered by FUDForum. Page generated in 0.04590 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top