Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RAP 1.5 M5 - invalid software site
RAP 1.5 M5 - invalid software site [message #791923] Mon, 06 February 2012 12:21 Go to next message
Sudesh Bulathsinhala is currently offline Sudesh BulathsinhalaFriend
Messages: 193
Registered: October 2010
Senior Member
Hello,

i'm trying to install the latest RAP 1.5M5 using the following URL. the version of eclipse is indigo(jee), which i downloaded recently and there's no previous version of RAP installed. so it's pretty much clean environment.


http://download.eclipse.org/rt/rap/1.5/tooling


however, when i try to install the RAP 1.5 using the above URL, i'm only given with the old version selections below :


Rich Ajax Platform (RAP) Tooling 1.5.0.20111107-1628
Rich Ajax Platform (RAP) Tooling 1.5.0.20110927-1701
Rich Ajax Platform (RAP) Tooling 1.5.0.20110816-0954


also i tried with nightly builds URL below :


http://download.eclipse.org/rt/rap/nightly/tooling/


while installing nightly build using above URL, i get the following error message :


Cannot complete the install because one or more required items could not be found.
Software being installed: Rich Ajax Platform (RAP) Tooling 1.5.0.20120206-0255 (org.eclipse.rap.tooling.feature.group 1.5.0.20120206-0255)
Missing requirement: RWT Launcher Plug-in 1.5.0.20120206-0255 (org.eclipse.rap.ui.launch.rwt 1.5.0.20120206-0255) requires 'bundle org.eclipse.jetty.continuation [8.1.0,9.0.0)' but it could not be found
Cannot satisfy dependency:
From: Rich Ajax Platform (RAP) Tooling 1.5.0.20120206-0255 (org.eclipse.rap.tooling.feature.group 1.5.0.20120206-0255)
To: org.eclipse.rap.ui.launch.rwt [1.5.0.20120206-0255]


none of the above two methods were successful.

1. latest stable build - http://download.eclipse.org/rt/rap/1.5/tooling
2. nightly build - http://download.eclipse.org/rt/rap/nightly/tooling/

kindly advise, if i'm not following the correct approach OR had i missed something.

Regards,
Sudesh
Re: RAP 1.5 M5 - invalid software site [message #791972 is a reply to message #791923] Mon, 06 February 2012 13:30 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Sudesh,
due to breaking changes in the Eclipse platform, the 1.5 tooling is no
longer working with Indigo. See the following bug for more details:
366614: [Tooling] Breaking changes in the latest org.eclipse.pde.core bundle
https://bugs.eclipse.org/bugs/show_bug.cgi?id=366614
If you want to use 1.5 runtime with Indigo, you could still do it by
installing the 1.4 tooling. In this case, you need to manually adjust
the auto-generated launch configuration (add new jetty bundles, apache
gogo bundles, osgi console bundle and rwt.osgi bundle). For 1.5 tooling
you need at least Eclipse 3.8M4 or 4.2M4.
HTH,
Ivan

On 2/6/2012 2:21 PM, Sudesh Bulathsinhala wrote:
> Hello,
>
> i'm trying to install the latest RAP 1.5M5 using the following URL.
> the version of eclipse is indigo(jee), which i downloaded recently and
> there's no previous version of RAP installed. so it's pretty much
> clean environment.
>
>
> http://download.eclipse.org/rt/rap/1.5/tooling
>
>
> however, when i try to install the RAP 1.5 using the above URL, i'm
> only given with the old version selections below :
>
>
> Rich Ajax Platform (RAP) Tooling 1.5.0.20111107-1628
> Rich Ajax Platform (RAP) Tooling 1.5.0.20110927-1701
> Rich Ajax Platform (RAP) Tooling 1.5.0.20110816-0954
>
>
> also i tried with nightly builds URL below :
>
>
> http://download.eclipse.org/rt/rap/nightly/tooling/
>
>
> while installing nightly build using above URL, i get the following
> error message :
>
>
> Cannot complete the install because one or more required items could
> not be found.
> Software being installed: Rich Ajax Platform (RAP) Tooling
> 1.5.0.20120206-0255 (org.eclipse.rap.tooling.feature.group
> 1.5.0.20120206-0255)
> Missing requirement: RWT Launcher Plug-in 1.5.0.20120206-0255
> (org.eclipse.rap.ui.launch.rwt 1.5.0.20120206-0255) requires 'bundle
> org.eclipse.jetty.continuation [8.1.0,9.0.0)' but it could not be found
> Cannot satisfy dependency:
> From: Rich Ajax Platform (RAP) Tooling 1.5.0.20120206-0255
> (org.eclipse.rap.tooling.feature.group 1.5.0.20120206-0255)
> To: org.eclipse.rap.ui.launch.rwt [1.5.0.20120206-0255]
>
>
> none of the above two methods were successful.
>
> 1. latest stable build - http://download.eclipse.org/rt/rap/1.5/tooling
> 2. nightly build -
> http://download.eclipse.org/rt/rap/nightly/tooling/
>
> kindly advise, if i'm not following the correct approach OR had i
> missed something.
>
> Regards,
> Sudesh
>
>

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: RAP 1.5 M5 - invalid software site [message #792007 is a reply to message #791972] Mon, 06 February 2012 14:02 Go to previous messageGo to next message
Sudesh Bulathsinhala is currently offline Sudesh BulathsinhalaFriend
Messages: 193
Registered: October 2010
Senior Member
Thanks,

let me give a try first, with 4.2M5.

Regards,
Sudesh
Re: RAP 1.5 M5 - invalid software site [message #792011 is a reply to message #791972] Mon, 06 February 2012 14:02 Go to previous messageGo to next message
Sudesh Bulathsinhala is currently offline Sudesh BulathsinhalaFriend
Messages: 193
Registered: October 2010
Senior Member
Thanks,

let me give a try first, with 4.2M5.

Regards,
Sudesh
Re: RAP 1.5 M5 - invalid software site [message #793906 is a reply to message #792007] Wed, 08 February 2012 18:34 Go to previous message
Sudesh Bulathsinhala is currently offline Sudesh BulathsinhalaFriend
Messages: 193
Registered: October 2010
Senior Member
Hello Ivan,

you're right,
I just setup juno-M5 and it works !!!

Thanks,
Sudesh
Re: RAP 1.5 M5 - invalid software site [message #793911 is a reply to message #792007] Wed, 08 February 2012 18:34 Go to previous message
Sudesh Bulathsinhala is currently offline Sudesh BulathsinhalaFriend
Messages: 193
Registered: October 2010
Senior Member
Hello Ivan,

you're right,
I just setup juno-M5 and it works !!!

Thanks,
Sudesh
Previous Topic:RAP 1.5 M5 - invalid software site
Next Topic:MessageBox too Small Using Chinese
Goto Forum:
  


Current Time: Fri Dec 03 06:35:46 GMT 2021

Powered by FUDForum. Page generated in 0.02496 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top