Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Hello World example error
Hello World example error [message #779037] Sat, 14 January 2012 13:43 Go to next message
Gabriel Voiculescu is currently offline Gabriel VoiculescuFriend
Messages: 2
Registered: January 2012
Junior Member
Hello ,

I just downloaded "Eclipse for RCP and RAP Developers" from downloads section on the site.

I extracted the files in a folder on my hard drive.
I opened Eclipse , the WELCOME page opened.
I clicked "Overview" and then clicked on "Rich Ajax Platform" then "Install Target Platform" and selected the last stable version.

After this i created a new project "File/New/Plug-in Project" with this default details :

name = HelloWorldExample
use default location = true
create source (src) and output folder (bin)
eclipse version = 3.7

NEXT

id , version , name
Execution Enviroment : JavaSE 1.7
Generate arhivator = true
This plugin will make contribution = true
FINISH


Now if i want to run the application by right-click on MANIFEST , run as RAP app i get this error :

org.osgi.framework.BundleException: The bundle "org.eclipse.rap.rwt.testfixture_1.5.0.20110926-1702 [37]" could not be resolved. Reason: Missing Constraint: Import-Package: javax.servlet; version="[3.0.0,4.0.0)"



Removed eclipse from the computer , new install .

Followed the same steps but this time before creating a project , i clicked INSTALL NEW SOFTWARE , and and installed RAP tooling something. It was already installed.


I searched the web for this problem and the only relevand thing i found is a bug that was resolved ( something with config.ini text ).

I have no ideea what to do.

Please help me.


Thank you ,

Gabriel Voiculescu
Re: Hello World example error [message #779708 is a reply to message #779037] Mon, 16 January 2012 11:12 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Gabriel,
did you select the "RAP Hello World" template page in the "New Project
Wizard" (click NEXT not FINISH in "Content" page to go to "Template" page)?
HTH,
Ivan

On 1/14/2012 3:43 PM, Gabriel Voiculescu wrote:
> Hello ,
>
> I just downloaded "Eclipse for RCP and RAP Developers" from downloads
> section on the site.
>
> I extracted the files in a folder on my hard drive.
> I opened Eclipse , the WELCOME page opened.
> I clicked "Overview" and then clicked on "Rich Ajax Platform" then
> "Install Target Platform" and selected the last stable version.
>
> After this i created a new project "File/New/Plug-in Project" with
> this default details :
>
> name = HelloWorldExample
> use default location = true
> create source (src) and output folder (bin)
> eclipse version = 3.7
>
> NEXT
> id , version , name
> Execution Enviroment : JavaSE 1.7
> Generate arhivator = true
> This plugin will make contribution = true
> FINISH
>
> Now if i want to run the application by right-click on MANIFEST , run
> as RAP app i get this error :
>
> org.osgi.framework.BundleException: The bundle
> "org.eclipse.rap.rwt.testfixture_1.5.0.20110926-1702 [37]" could not
> be resolved. Reason: Missing Constraint: Import-Package:
> javax.servlet; version="[3.0.0,4.0.0)"
>
>
> Removed eclipse from the computer , new install .
>
> Followed the same steps but this time before creating a project , i
> clicked INSTALL NEW SOFTWARE , and and installed RAP tooling
> something. It was already installed.
>
>
> I searched the web for this problem and the only relevand thing i
> found is a bug that was resolved ( something with config.ini text ).
>
> I have no ideea what to do.
>
> Please help me.
>
>
> Thank you ,
>
> Gabriel Voiculescu

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Hello World example error [message #780352 is a reply to message #779708] Tue, 17 January 2012 16:47 Go to previous messageGo to next message
Jochen Mades is currently offline Jochen MadesFriend
Messages: 7
Registered: July 2009
Junior Member
Unfortunately I have the same problem. Anyone an idea:

Took a new "Eclipse for RCP and RAP Developers" from http://www.eclipse.org/downloads/packages/eclipse-rcp-and-rap-developers/indigosr1

and installed the latest-stable Target-Plattform.

Re: Hello World example error [message #780356 is a reply to message #779708] Tue, 17 January 2012 16:47 Go to previous messageGo to next message
Jochen Mades is currently offline Jochen MadesFriend
Messages: 2
Registered: July 2009
Junior Member
Unfortunately I have the same problem. Anyone an idea:

Took a new "Eclipse for RCP and RAP Developers" from http://www.eclipse.org/downloads/packages/eclipse-rcp-and-rap-developers/indigosr1

and installed the latest-stable Target-Plattform.
Re: Hello World example error [message #780382 is a reply to message #780352] Tue, 17 January 2012 17:33 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Jochen,
just checked it. There is one bundle missing in the launch configuration
- org.eclipse.rap.rwt.osgi. Please add it manually. We added (needed)
this bundle in 1.5 target platform (latest stable), but the tooling
included in "Eclipse for RCP and RAP Developers" is based on 1.4.1 and
the generated launch config does not include it.
HTH,
Ivan

On 1/17/2012 6:47 PM, Jochen Mades wrote:
> Unfortunately I have the same problem. Anyone an idea:
>
> Took a new "Eclipse for RCP and RAP Developers" from
> http://www.eclipse.org/downloads/packages/eclipse-rcp-and-rap-developers/indigosr1
>
> and installed the latest-stable Target-Plattform.
>
>

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Hello World example error [message #780436 is a reply to message #780382] Tue, 17 January 2012 21:35 Go to previous messageGo to next message
Jochen Mades is currently offline Jochen MadesFriend
Messages: 7
Registered: July 2009
Junior Member
Hi Ivan,

thanks for the hint - it now works.

Anyway it was a little bit confusing on my machine, where I have played around with different RAP targets (runtimes) within the same workspace. Are there any good hints how to handle this correctly?

I'm at the moment also a little bit confused where the target bundles are stored (locally) when I fetch them with a download link in the PDE settings???

THX
Jochen
Re: Hello World example error [message #780756 is a reply to message #780436] Thu, 19 January 2012 10:07 Go to previous message
Ralf Sternberg is currently offline Ralf SternbergFriend
Messages: 1313
Registered: July 2009
Senior Member

Hi Jochen,

Normally, you never have to need to deal with the locally stored target
bundles.

When working with different targets, I can recommend using target
definition files instead the Properties dialog. I usually have a
dedicated project called targets in my workspace. This project contains
the target definitions files. Those can be created with (New > Target
Definition) and edited with the target editor. When pressing "Set as
Target" in this editor, the workspace target is switched.

HTH, Ralf


--
Ralf Sternberg

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Previous Topic:1.4 entrypoint not initialized with RAP 1.5
Next Topic:Hello World example error
Goto Forum:
  


Current Time: Mon Dec 06 12:40:01 GMT 2021

Powered by FUDForum. Page generated in 0.02045 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top