Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Browser Open Too Early(Problem accessing /rap.)
Browser Open Too Early [message #758368] Tue, 22 November 2011 21:47 Go to next message
Ronald So is currently offline Ronald SoFriend
Messages: 198
Registered: April 2011
Senior Member
I am using 3.7 Indigo with a RAP 1.4 target. When I launch the RAP application, it always gives me an error message that there is a problem accessing /rap. But then if I refresh the browser, the UI comes up without a problem. I did a search and saw the following RAP 1.3 bug.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=282756

Was this bug supposed to be fixed? How can I get around the issue?

Thanks,
Ronald
Re: Browser Open Too Early [message #758594 is a reply to message #758368] Wed, 23 November 2011 19:45 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Roland,
sorry, but we didn't find a reliable way to fix it and there is no
workaround. Keep an eye on this bug about the progress on this issue.
Best,
Ivan

On 11/22/2011 11:47 PM, Ronald So wrote:
> I am using 3.7 Indigo with a RAP 1.4 target. When I launch the RAP
> application, it always gives me an error message that there is a
> problem accessing /rap. But then if I refresh the browser, the UI
> comes up without a problem. I did a search and saw the following RAP
> 1.3 bug.
>
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=282756
>
> Was this bug supposed to be fixed? How can I get around the issue?
>
> Thanks,
> Ronald
>
Re: Browser Open Too Early [message #759427 is a reply to message #758594] Mon, 28 November 2011 16:09 Go to previous messageGo to next message
Ronald So is currently offline Ronald SoFriend
Messages: 198
Registered: April 2011
Senior Member
Ivan,

Thanks for writing back. Does this issue limit to the time when I launch the RAP application inside the Eclipse IDE? Say if I productize the application by deploying the WAR file into a container, I should not see this problem right?

Thanks,
Ronald
Re: Browser Open Too Early [message #759429 is a reply to message #758594] Mon, 28 November 2011 16:09 Go to previous messageGo to next message
Ronald So is currently offline Ronald SoFriend
Messages: 198
Registered: April 2011
Senior Member
Ivan,

Thanks for writing back. Does this issue limit to the time when I launch the RAP application inside the Eclipse IDE? Say if I productize the application by deploying the WAR file into a container, I should not see this problem right?

Thanks,
Ronald
Re: Browser Open Too Early [message #759436 is a reply to message #759429] Mon, 28 November 2011 16:28 Go to previous message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2359
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Roland,
yes... you are right. This only happens when the servlet container and
the browser start at the same time (running your application in Eclipse
IDE). Once the servlet container is up and running (production mode),
this is not an issue anymore.
Best,
Ivan

On 11/28/2011 6:09 PM, Ronald So wrote:
> Ivan,
>
> Thanks for writing back. Does this issue limit to the time when I
> launch the RAP application inside the Eclipse IDE? Say if I
> productize the application by deploying the WAR file into a container,
> I should not see this problem right?
>
> Thanks,
> Ronald
Previous Topic:JDPA availability in RAP
Next Topic:Browser Open Too Early
Goto Forum:
  


Current Time: Mon Dec 06 00:09:24 GMT 2021

Powered by FUDForum. Page generated in 0.02229 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top