Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] uml2 models transformation
[ATL] uml2 models transformation [message #81785] Wed, 21 May 2008 03:42 Go to next message
Geam Carlos is currently offline Geam CarlosFriend
Messages: 17
Registered: July 2009
Junior Member
Hi everybody,

I'm having a problem at the moment to assign the element namespace to
package element within the rule ATL, for example, set so the ATL rules
with uml1.4:
rule MergePackage {
from s : UML2!Package
to t : UML2!Package mapsTo s (
name <- s.name,
namespace <- s.namespace
)
}

But now the rules ATL with uml2 (version 1.0) can not assign.

Someone could help me, please?
[ATL] Re : uml2 models transformation [message #81801 is a reply to message #81785] Wed, 21 May 2008 06:25 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: frederic_thomas_fr.yahoo.fr

Hi Carlos,

ATL can't match the namespace<-s.namespace statement because in the UML
2.0 metamodel, the namespace feature is derived, hence you can only read
it and not write it.

If you want match the package namespace, you must use the
s.owningPackage feature which is a subset of the namespace set.

Best regards

Frédéric

Geam Carlos a écrit :
> Hi everybody,
>
> I'm having a problem at the moment to assign the element namespace to
> package element within the rule ATL, for example, set so the ATL rules
> with uml1.4:
> rule MergePackage {
> from s : UML2!Package
> to t : UML2!Package mapsTo s (
> name <- s.name,
> namespace <- s.namespace
> )
> }
>
> But now the rules ATL with uml2 (version 1.0) can not assign.
Re: [ATL] Re : uml2 models transformation [message #81914 is a reply to message #81801] Wed, 21 May 2008 12:16 Go to previous messageGo to next message
Geam Carlos is currently offline Geam CarlosFriend
Messages: 17
Registered: July 2009
Junior Member
Hello Frédéric, thank for your attention.

I changed to the feature owningPackage, but there was the error that does
not exist on UML2! Package.:
****** BEGIN Stack Trace
message: owningPackage feature does not exist on UML2! Package

I am using this API: eclipse-uml2-1.1.1.jar.

I have the same problem for other elements (Class, Property ,...), the
rules ATL have that to inform the namespace of each element, that is, who
owns the element.

Frédéric, you can help me! Very grateful.
[ATL] Re : uml2 models transformation [message #82151 is a reply to message #81801] Mon, 26 May 2008 07:13 Go to previous message
Eclipse UserFriend
Originally posted by: frederic_thomas_fr.yahoo.fr

Hi cralos,

I have not tried yet but if the "s.owningPackage" doesnot work, the
"s.nestingPackage" should (this is also a subset of the namespace feature).

To solve such problem by your own, you have just to look at the "package
" metaclass description in the UML2 superstructure.

Fred



Frédéric Thomas a écrit :
> Hi Carlos,
>
> ATL can't match the namespace<-s.namespace statement because in the UML
> 2.0 metamodel, the namespace feature is derived, hence you can only read
> it and not write it.
>
> If you want match the package namespace, you must use the
> s.owningPackage feature which is a subset of the namespace set.
>
> Best regards
>
> Frédéric
>
> Geam Carlos a écrit :
>> Hi everybody,
>>
>> I'm having a problem at the moment to assign the element namespace to
>> package element within the rule ATL, for example, set so the ATL rules
>> with uml1.4:
>> rule MergePackage {
>> from s : UML2!Package
>> to t : UML2!Package mapsTo s (
>> name <- s.name,
>> namespace <- s.namespace
>> )
>> }
>>
>> But now the rules ATL with uml2 (version 1.0) can not assign.
>
Previous Topic:[ATL] Re: Two metamodels into one
Next Topic:Problem with simple transformation
Goto Forum:
  


Current Time: Wed Aug 21 00:33:40 GMT 2019

Powered by FUDForum. Page generated in 0.01949 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top