Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » GMF(Callisto) 1.0.3: org.eclipse.emf.validation.ocl requires "org.eclipse.ocl.ecore" ????
GMF(Callisto) 1.0.3: org.eclipse.emf.validation.ocl requires "org.eclipse.ocl.ecore" ???? [message #79603] Thu, 12 April 2007 11:18 Go to next message
Michael Haeberlen is currently offline Michael HaeberlenFriend
Messages: 52
Registered: July 2009
Member
When I use callisto update site to get GMF 1.0.3, this includes feature org.eclipse.emf.validation.ocl version
1.1.0.v200702011853.

However, the bundle cannot be resolved since in the plugin's MANIFEST.MF it requires org.eclipse.ocl.ecore_[1.1.0,2.0.0)

Also it seems that org.eclipse.emf.validation.ocl_1.1.0.v200702011853 is not a release build as I would expect from a
callisto download.

Am I doing anything wrong?
Re: GMF(Callisto) 1.0.3: org.eclipse.emf.validation.ocl requires "org.eclipse.ocl.ecore" ? [message #79698 is a reply to message #79603] Thu, 12 April 2007 16:31 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: cdamus.ca.ibm.com

Hi, Michael,

It looks like, somehow, GMF has picked up the 1.1 versions of MDT OCL and
EMF-QTV components in its Callisto Maintenance build. From the
org.eclipse.gmf.callisto_1.0.3.v20070202-1200 feature.xml file:

<includes
id="org.eclipse.emf.ocl"
version="1.1.0.v200612211659"/>

<includes
id="org.eclipse.emf.query"
version="1.0.1.v200702011850"/>

<includes
id="org.eclipse.emf.query.ocl"
version="1.0.1.v200702011850"/>

<includes
id="org.eclipse.emf.transaction"
version="1.1.0.v200702011903"/>

<includes
id="org.eclipse.emf.validation"
version="1.1.0.v200702011853"/>

<includes
id="org.eclipse.emf.validation.ocl"
version="1.1.0.v200702011853"/>

<includes
id="org.eclipse.emf.workspace"
version="1.1.0.v200702011903"/>

GMF should stick to the 1.0.x versions of these features in the Callisto
maintenance.

Cheers,

Christian



Michael Haeberlen wrote:

> When I use callisto update site to get GMF 1.0.3, this includes feature
> org.eclipse.emf.validation.ocl version 1.1.0.v200702011853.
>
> However, the bundle cannot be resolved since in the plugin's MANIFEST.MF
> it requires org.eclipse.ocl.ecore_[1.1.0,2.0.0)
>
> Also it seems that org.eclipse.emf.validation.ocl_1.1.0.v200702011853 is
> not a release build as I would expect from a callisto download.
>
> Am I doing anything wrong?
Re: GMF(Callisto) 1.0.3: org.eclipse.emf.validation.ocl requires "org.eclipse.ocl.ecore"?? [message #79713 is a reply to message #79603] Thu, 12 April 2007 17:32 Go to previous messageGo to next message
Richard Gronback is currently offline Richard GronbackFriend
Messages: 605
Registered: July 2009
Senior Member
I'm not sure how this could have happened, looking at the config in the
maintenance branch. Can you please open a bug on this, assigned to the
releng component of GMF?

Thanks,
Rich


On 4/12/07 7:18 AM, in article evl4hb$8m5$1@build.eclipse.org, "Michael
Haeberlen" <haeber@de.ibm.com> wrote:

> When I use callisto update site to get GMF 1.0.3, this includes feature
> org.eclipse.emf.validation.ocl version
> 1.1.0.v200702011853.
>
> However, the bundle cannot be resolved since in the plugin's MANIFEST.MF it
> requires org.eclipse.ocl.ecore_[1.1.0,2.0.0)
>
> Also it seems that org.eclipse.emf.validation.ocl_1.1.0.v200702011853 is not a
> release build as I would expect from a
> callisto download.
>
> Am I doing anything wrong?
Re: GMF(Callisto) 1.0.3: org.eclipse.emf.validation.ocl requires "org.eclipse.ocl.ecore"?? [message #79728 is a reply to message #79713] Thu, 12 April 2007 19:03 Go to previous messageGo to next message
Michael Haeberlen is currently offline Michael HaeberlenFriend
Messages: 52
Registered: July 2009
Member
https://bugs.eclipse.org/bugs/show_bug.cgi?id=182199

I also described some other problems with update manager and gmf there.

Thanks for your help,
Michael

Richard Gronback wrote:
> I'm not sure how this could have happened, looking at the config in the
> maintenance branch. Can you please open a bug on this, assigned to the
> releng component of GMF?
>
> Thanks,
> Rich
>
>
> On 4/12/07 7:18 AM, in article evl4hb$8m5$1@build.eclipse.org, "Michael
> Haeberlen" <haeber@de.ibm.com> wrote:
>
>> When I use callisto update site to get GMF 1.0.3, this includes feature
>> org.eclipse.emf.validation.ocl version
>> 1.1.0.v200702011853.
>>
>> However, the bundle cannot be resolved since in the plugin's MANIFEST.MF it
>> requires org.eclipse.ocl.ecore_[1.1.0,2.0.0)
>>
>> Also it seems that org.eclipse.emf.validation.ocl_1.1.0.v200702011853 is not a
>> release build as I would expect from a
>> callisto download.
>>
>> Am I doing anything wrong?
>
Re: GMF(Callisto) 1.0.3: org.eclipse.emf.validation.ocl requires "org.eclipse.ocl.ecore"?? [message #80009 is a reply to message #79728] Tue, 17 April 2007 10:12 Go to previous message
Eclipse UserFriend
Originally posted by: snej_NO-SPAM_.esuark.de

Michael Haeberlen wrote:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=182199
>
> I also described some other problems with update manager and gmf there.

Is there any update for this bug available? I currently run into same
problem. The validation is disabled cause of the missing plugin ...

regards
Jens K.
Re: GMF(Callisto) 1.0.3: org.eclipse.emf.validation.ocl requires "org.eclipse.ocl.ecore" ? [message #604702 is a reply to message #79603] Thu, 12 April 2007 16:31 Go to previous message
Eclipse UserFriend
Originally posted by: cdamus.ca.ibm.com

Hi, Michael,

It looks like, somehow, GMF has picked up the 1.1 versions of MDT OCL and
EMF-QTV components in its Callisto Maintenance build. From the
org.eclipse.gmf.callisto_1.0.3.v20070202-1200 feature.xml file:

<includes
id="org.eclipse.emf.ocl"
version="1.1.0.v200612211659"/>

<includes
id="org.eclipse.emf.query"
version="1.0.1.v200702011850"/>

<includes
id="org.eclipse.emf.query.ocl"
version="1.0.1.v200702011850"/>

<includes
id="org.eclipse.emf.transaction"
version="1.1.0.v200702011903"/>

<includes
id="org.eclipse.emf.validation"
version="1.1.0.v200702011853"/>

<includes
id="org.eclipse.emf.validation.ocl"
version="1.1.0.v200702011853"/>

<includes
id="org.eclipse.emf.workspace"
version="1.1.0.v200702011903"/>

GMF should stick to the 1.0.x versions of these features in the Callisto
maintenance.

Cheers,

Christian



Michael Haeberlen wrote:

> When I use callisto update site to get GMF 1.0.3, this includes feature
> org.eclipse.emf.validation.ocl version 1.1.0.v200702011853.
>
> However, the bundle cannot be resolved since in the plugin's MANIFEST.MF
> it requires org.eclipse.ocl.ecore_[1.1.0,2.0.0)
>
> Also it seems that org.eclipse.emf.validation.ocl_1.1.0.v200702011853 is
> not a release build as I would expect from a callisto download.
>
> Am I doing anything wrong?
Re: GMF(Callisto) 1.0.3: org.eclipse.emf.validation.ocl requires "org.eclipse.ocl.ecore"?? [message #604705 is a reply to message #79603] Thu, 12 April 2007 17:32 Go to previous message
Richard Gronback is currently offline Richard GronbackFriend
Messages: 605
Registered: July 2009
Senior Member
I'm not sure how this could have happened, looking at the config in the
maintenance branch. Can you please open a bug on this, assigned to the
releng component of GMF?

Thanks,
Rich


On 4/12/07 7:18 AM, in article evl4hb$8m5$1@build.eclipse.org, "Michael
Haeberlen" <haeber@de.ibm.com> wrote:

> When I use callisto update site to get GMF 1.0.3, this includes feature
> org.eclipse.emf.validation.ocl version
> 1.1.0.v200702011853.
>
> However, the bundle cannot be resolved since in the plugin's MANIFEST.MF it
> requires org.eclipse.ocl.ecore_[1.1.0,2.0.0)
>
> Also it seems that org.eclipse.emf.validation.ocl_1.1.0.v200702011853 is not a
> release build as I would expect from a
> callisto download.
>
> Am I doing anything wrong?
Re: GMF(Callisto) 1.0.3: org.eclipse.emf.validation.ocl requires "org.eclipse.ocl.ecore"?? [message #604708 is a reply to message #79713] Thu, 12 April 2007 19:03 Go to previous message
Michael Haeberlen is currently offline Michael HaeberlenFriend
Messages: 52
Registered: July 2009
Member
https://bugs.eclipse.org/bugs/show_bug.cgi?id=182199

I also described some other problems with update manager and gmf there.

Thanks for your help,
Michael

Richard Gronback wrote:
> I'm not sure how this could have happened, looking at the config in the
> maintenance branch. Can you please open a bug on this, assigned to the
> releng component of GMF?
>
> Thanks,
> Rich
>
>
> On 4/12/07 7:18 AM, in article evl4hb$8m5$1@build.eclipse.org, "Michael
> Haeberlen" <haeber@de.ibm.com> wrote:
>
>> When I use callisto update site to get GMF 1.0.3, this includes feature
>> org.eclipse.emf.validation.ocl version
>> 1.1.0.v200702011853.
>>
>> However, the bundle cannot be resolved since in the plugin's MANIFEST.MF it
>> requires org.eclipse.ocl.ecore_[1.1.0,2.0.0)
>>
>> Also it seems that org.eclipse.emf.validation.ocl_1.1.0.v200702011853 is not a
>> release build as I would expect from a
>> callisto download.
>>
>> Am I doing anything wrong?
>
Re: GMF(Callisto) 1.0.3: org.eclipse.emf.validation.ocl requires "org.eclipse.ocl.ecore"?? [message #604780 is a reply to message #79728] Tue, 17 April 2007 10:12 Go to previous message
Jens Krause is currently offline Jens KrauseFriend
Messages: 3
Registered: July 2009
Junior Member
Michael Haeberlen wrote:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=182199
>
> I also described some other problems with update manager and gmf there.

Is there any update for this bug available? I currently run into same
problem. The validation is disabled cause of the missing plugin ...

regards
Jens K.
Previous Topic:[Teneo] Multivalued EAttributes of EDataTypes do not have the correct Hibernate mapping
Next Topic:ClassCastExeption with Elistwrapper
Goto Forum:
  


Current Time: Fri Nov 27 07:16:05 GMT 2020

Powered by FUDForum. Page generated in 0.01599 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top