Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » Problem with Inter-model reference
Problem with Inter-model reference [message #75153] Wed, 20 February 2008 10:45 Go to next message
Guillaume Hillairet is currently offline Guillaume HillairetFriend
Messages: 93
Registered: July 2009
Member
Hi all,


I am trying to make a transformation that takes as input two models Ma:MMa
and Mb:MMa conforms to the same metamodel. The result is one model. The
problem is that model Ma references elements from model Mb. Here is an
excerpt of this model:


<universe xsi:type="Individual" localName="Individual_1">
<type href="platform:/resource/Samples/ontology-OWL.ecore#//@universe.0 "/>
</universe>


I allow the inter-model reference in the configuration but it raises an
error when i'm trying to access referenced elements.
How to well configure this transformation ?


Regards.
Guillaume
Re: [ATL] Problem with Inter-model reference [message #75170 is a reply to message #75153] Thu, 21 February 2008 06:54 Go to previous messageGo to next message
Frédéric Jouault is currently offline Frédéric JouaultFriend
Messages: 572
Registered: July 2009
Senior Member
Hello,

Could you please remember to use the [ATL] prefix?

> I am trying to make a transformation that takes as input two models
> Ma:MMa and Mb:MMa conforms to the same metamodel. The result is one
> model. The problem is that model Ma references elements from model Mb.
> Here is an excerpt of this model:
>
>
> <universe xsi:type="Individual" localName="Individual_1">
> <type href="platform:/resource/Samples/ontology-OWL.ecore#//@universe.0 "/>
> </universe>
>
>
> I allow the inter-model reference in the configuration but it raises an
> error when i'm trying to access referenced elements.
> How to well configure this transformation ?

The "Allow inter-model references" option is only for target models. For
source models, inter-model references should directly work, provided
that you load all inter-linked resources.

Could you give more information (e.g., error message, stack trace) please?


Regards,

Frédéric Jouault
Re: [ATL] Problem with Inter-model reference [message #75204 is a reply to message #75170] Thu, 21 February 2008 10:57 Go to previous messageGo to next message
Guillaume Hillairet is currently offline Guillaume HillairetFriend
Messages: 93
Registered: July 2009
Member
Frédéric Jouault wrote:

> Hello,

> Could you please remember to use the [ATL] prefix?

>> I am trying to make a transformation that takes as input two models
>> Ma:MMa and Mb:MMa conforms to the same metamodel. The result is one
>> model. The problem is that model Ma references elements from model Mb.
>> Here is an excerpt of this model:
>>
>>
>> <universe xsi:type="Individual" localName="Individual_1">
>> <type href="platform:/resource/Samples/ontology-OWL.ecore#//@universe.0 "/>
>> </universe>
>>
>>
>> I allow the inter-model reference in the configuration but it raises an
>> error when i'm trying to access referenced elements.
>> How to well configure this transformation ?

> The "Allow inter-model references" option is only for target models. For
> source models, inter-model references should directly work, provided
> that you load all inter-linked resources.

> Could you give more information (e.g., error message, stack trace) please?


> Regards,

> Frédéric Jouault

Hello,

Sorry for having forgotten the prefix, i promise to not forget the next
time.

For my problem, it seems that everything is back in order. I surely have
done a bad transformation configuration. I've made all the tests and i
don't understand what was the error and where it comes from.

Regards
Guillaume
Re: [ATL] Problem with Inter-model reference [message #83369 is a reply to message #75170] Mon, 02 June 2008 10:05 Go to previous message
Eclipse UserFriend
Originally posted by: Stefan.Warwas.dfki.de

Hi,

I have a very similar problem. I want to use the refining mode to
transform Ma:MMa to Ma:MMa. Moreover, Ma contains references to a
"library" Mb:MMa. In my case, Mb contains standard interaction protocols
that can be referenced by Ma. During the refinement of Ma to Ma, I want
to generate a basic behavior template that implements/realizes the
referenced interaction protocol from Mb. The generated Ma should still
reference the interaction protocol in Mb, but the generated behavior
should be part of Ma.

The problem is that Ma can reference any number of libraries. You wrote:

> The "Allow inter-model references" option is only for target models. For
> source models, inter-model references should directly work, provided
> that you load all inter-linked resources.
>
> Could you give more information (e.g., error message, stack trace) please?

Does "provided that you load all inter-linked resources" mean I have to
explicitly declare all referenced models as inputs for the
transformation? This could be hard because Ma can reference any number
of libraries. Is there another way to realizes this? When I do not
explicitly declare Mb as input I always get an error message.

Regards,

Stefan
Previous Topic:[ATL] how to get the parent's name in UML
Next Topic:[ATL] UML stereotype problem
Goto Forum:
  


Current Time: Thu Nov 14 04:05:33 GMT 2019

Powered by FUDForum. Page generated in 0.02368 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top