Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » org.eclipse.emf.teneo.hibernate jars signing
org.eclipse.emf.teneo.hibernate jars signing [message #677027] Tue, 07 June 2011 11:08 Go to next message
Nicolas NGUYEN is currently offline Nicolas NGUYENFriend
Messages: 2
Registered: June 2011
Junior Member
Hello,

We are running an RCP based application using org.eclipse.emf.teneo.hibernate (1.1.2).
When times to come for deployment, we are using Java Web Start which implies signing all the plugins.

The fact is that the org.eclipse.emf.teneo.hibernate plugin use an eclipse.inf where it is written : jarprocessor.exclude.sign = true. Therefore the jar is not signed when building my jnlp distribution and the application will not start because of that.

We have changed the jarprocessor.exclude.sign flag, but is it okay ? We think this flag is there for a reason.

Thanks for you help !!

++Nicolas.
Re: org.eclipse.emf.teneo.hibernate jars signing [message #687150 is a reply to message #677027] Tue, 07 June 2011 11:49 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi,
Hmm yes before I got security exceptions when signing this jar related to building of proxies by Hibernate. But I think
this is now solved because I use a different interface for that. Currently teneo builds are not signed anymore because I
have not yet got the signing infrastructure to work.

So afaics your change should work.

gr. Martin

On 06/07/2011 01:08 PM, Nicolas NGUYEN wrote:
> Hello,
>
> We are running an RCP based application using org.eclipse.emf.teneo.hibernate (1.1.2).
> When times to come for deployment, we are using Java Web Start which implies signing all the plugins.
> The fact is that the org.eclipse.emf.teneo.hibernate plugin use an eclipse.inf where it is written :
> jarprocessor.exclude.sign = true. Therefore the jar is not signed when building my jnlp distribution and the application
> will not start because of that.
>
> We have changed the jarprocessor.exclude.sign flag, but is it okay ? We think this flag is there for a reason.
>
> Thanks for you help !!
>
> ++Nicolas.


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@springsite.com - mtaal@elver.org
Web: www.springsite.com - www.elver.org
Previous Topic:cdo remove delta
Next Topic:(no subject)
Goto Forum:
  


Current Time: Sun Oct 20 15:20:50 GMT 2019

Powered by FUDForum. Page generated in 0.01753 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top