Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Pushing Repository to Github(Push Ref Specifications Error)
Pushing Repository to Github [message #652507] Fri, 04 February 2011 10:24 Go to next message
PNS is currently offline PNSFriend
Messages: 2
Registered: February 2011
Junior Member

I can't find how to actually push a new local repository to a remote one, using Eclipse Helios and EGit 0.10.1.

As far as I understand (if otherwise, please advise), if you have a local Java project in Eclipse and want to copy everything to Github via EGit on Eclipse, you create a local repository and then use the "Push" option for the corresponding project.

So, as per the manual (and the Github tutorial), after installing Git on my machine, I configured EGit with the necessary user name information, in Eclipse, via
Window > Preferences > Team > Git > Configuration

Then, for my simple Java project, in Eclipse, I right-clicked on the project name and selected
Team > Share Project > Git > Create Repository
and then

All worked OK.

Then I created a remote repository on my account (say, with username "user"). I named the Github repository (say, "test") and got the HTTPS URI, which would be
https://user @

Then, as per the instructions on ositories (but for HTTPS, not SSH), I right-clicked on the project name in Eclipse and selected
Team > Push...

Following the above steps, the "Push To Another Repository" window pops up, where I supply the HTTPS URI and the other information (username, password), click on the "Next" button and, after successful authentication, get to the "Push Ref Specifications" dialog box.

This is the point where I get stuck!

The dialog box on my screen, after following the instructions, looks like llbranches.png

However, the "Next >" and "Finish" buttons are grayed out and I cannot get beyond that point.

In the Source ref list (at the top left of the dialog box) there is only 1 option, HEAD, which, if I select, a red "x" appears and hovering the mouse pointer over it an error message pops up: "HEAD is not a valid ref in local repository."

Could someone please advise as to what I should do from here on?


[Updated on: Fri, 04 February 2011 11:42]

Report message to a moderator

Re: Pushing Repository to Github [message #652657 is a reply to message #652507] Fri, 04 February 2011 21:33 Go to previous message
PNS is currently offline PNSFriend
Messages: 2
Registered: February 2011
Junior Member
I am still getting numerous weird errors from EGit at times, but the issue I described in my previous post seems to be a side-effect of not having committed the project at all, so no references were created.

So, after committing the project for the first time, problem solved!
Previous Topic:"Index file is in use"
Next Topic:JGit - What are all these entries in DirCache?
Goto Forum:

Current Time: Mon Nov 28 10:50:13 GMT 2022

Powered by FUDForum. Page generated in 0.02802 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top