Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » headless pdebuild removing Export-Package
headless pdebuild removing Export-Package [message #65457] Wed, 24 June 2009 12:53 Go to next message
xavier fabre is currently offline xavier fabreFriend
Messages: 4
Registered: July 2009
Junior Member
Hello,

I'm migrating a working headless pdebuild from 331 to 342.
For one of my plugins the Export-Package 'statement' is removed from the
MANIFEST.MF file during the compilation phase.
As a result, the compiled feature does not work.
If I add a Require-Bundle: org.eclipse.core.runtime in the MANIFEST.MF,
then the Export-Package 'statement' is no more removed.

Does anybody have the same problem? Am I missing something?

Thanks.
Xavier
Re: headless pdebuild removing Export-Package [message #65478 is a reply to message #65457] Wed, 24 June 2009 14:34 Go to previous message
Andrew Niefer is currently offline Andrew NieferFriend
Messages: 990
Registered: July 2009
Senior Member
Xavier,
You may be hitting something like this:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=256787

There is a bug in Sun's java.util.jar.Manifest class which causes it to
lose the last attribute if the file has a very particular format
(related to whether or not there is a space at an offset based on the
size of the buffer used to read the manifest).

A workaround was to add an extra \n at the end of the file. PDE\Build
started doing this automatically in 3.5

xavier fabre wrote:
> Hello,
>
> I'm migrating a working headless pdebuild from 331 to 342.
> For one of my plugins the Export-Package 'statement' is removed from the
> MANIFEST.MF file during the compilation phase.
> As a result, the compiled feature does not work.
> If I add a Require-Bundle: org.eclipse.core.runtime in the MANIFEST.MF,
> then the Export-Package 'statement' is no more removed.
>
> Does anybody have the same problem? Am I missing something?
>
> Thanks.
> Xavier
Re: headless pdebuild removing Export-Package [message #598533 is a reply to message #65457] Wed, 24 June 2009 14:34 Go to previous message
Andrew Niefer is currently offline Andrew NieferFriend
Messages: 990
Registered: July 2009
Senior Member
Xavier,
You may be hitting something like this:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=256787

There is a bug in Sun's java.util.jar.Manifest class which causes it to
lose the last attribute if the file has a very particular format
(related to whether or not there is a space at an offset based on the
size of the buffer used to read the manifest).

A workaround was to add an extra \n at the end of the file. PDE\Build
started doing this automatically in 3.5

xavier fabre wrote:
> Hello,
>
> I'm migrating a working headless pdebuild from 331 to 342.
> For one of my plugins the Export-Package 'statement' is removed from the
> MANIFEST.MF file during the compilation phase.
> As a result, the compiled feature does not work.
> If I add a Require-Bundle: org.eclipse.core.runtime in the MANIFEST.MF,
> then the Export-Package 'statement' is no more removed.
>
> Does anybody have the same problem? Am I missing something?
>
> Thanks.
> Xavier
Previous Topic:headless pdebuild removing Export-Package
Next Topic:View source for plugins not in target platform
Goto Forum:
  


Current Time: Wed Aug 04 11:27:56 GMT 2021

Powered by FUDForum. Page generated in 0.02060 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top