Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » White page after redirection
White page after redirection [message #645386] Thu, 16 December 2010 22:46
Henzler Peter is currently offline Henzler PeterFriend
Messages: 19
Registered: July 2009
Junior Member
Hi

On startup RAP only displays a white page although the full source is there.

I have encountered this problem on two occations so far:

The first time when I did secure the url of to the rap application behind sping security filter.
In that case Spring takes me to the login form and after successfull authentication Spring takes me to the originally entered webaddress of my rap application. But instead the rap application I see the white page.

The second time was when I installed a proxy servlet that handled all calls to <ipaddress>:80/rap/examples and gave back the contents it got from calling <ipaddress>:8081/rap/example .
We wanted to do this because of the cross site scripting problem.
In this case I get a white page too.

As far as I understand RAP is sending an initial page to the client to find out if it is capable of displaying RAP and initiating the data communication with the RAP server.

This seems only to work with the original request to display RAP. It seems not to work, if there is some processing between.

Can anyone tell me what's the actual problem here and if there is a work around to overcome this problem?

Thank you.

Best regards
Peter Henzler
Previous Topic:missing something in my RAP/JAAS testing site
Next Topic:[ANN] RAP 1.4 M4 is available
Goto Forum:
  


Current Time: Sat Nov 27 03:38:10 GMT 2021

Powered by FUDForum. Page generated in 0.01561 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top