Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Buckminster » Help required for MDT/OCL bucky build.
Help required for MDT/OCL bucky build. [message #645359] Thu, 16 December 2010 18:12 Go to next message
Adolfo Sanchez-Barbudo Herrera is currently offline Adolfo Sanchez-Barbudo HerreraFriend
Messages: 260
Registered: July 2009
Senior Member
Hello bucky team.

I'm the release engineer of the Eclipse's MDT/OCL project, who has tried to adopt buckminster for our builds.

Since Indigo's M3 I've been producing and publishing bucky builds Smile However, I still need to sort some bits out concerning them.

For instance, I have recerently received the following bugzilla:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=332546

The bug itself is nearly solved, since I've managed to include both lpg.runtime.java and lpg.runtime.java.source bundles in the correspondent supplied zip.... excepting the Update.zip one which only differs from the others that it's a p2 repository.

Any clue based on your experience to discover what I'm missing, will be very welcome.

More info:
- hudson job: https://hudson.eclipse.org/hudson/job/buckminster-mdt-ocl-co re-3.1-nightly/

- releng location: /cvsroot/modeling/org.eclipse.mdt/org.eclipse.ocl/releng

- note that lpg.runtime.java is a bundle which it's materialized in the target platform and it's provided by Orbit's p2 repository.

P.S: If you require more info, please let me know it.

Regards,
Adolfo.
Re: Help required for MDT/OCL bucky build. [message #645853 is a reply to message #645359] Mon, 20 December 2010 19:30 Go to previous message
Adolfo Sanchez-Barbudo Herrera is currently offline Adolfo Sanchez-Barbudo HerreraFriend
Messages: 260
Registered: July 2009
Senior Member
To clarify:

The original problem (https://bugs.eclipse.org/bugs/show_bug.cgi?id=332546) was not including lpg.runtime.java bundle into the distributed zips.

Now, the bundle is included in the distributed zips. Besides I'm also distributing the lpg.runtime.java.source bundle in each zip which is supposed to include said source bundle. However, the mdt-ocl-Update.zip which corresponds to MDT/OCL p2 repository, doesn't include this lpg.runtime.java.source bundle.

I believe that it's problem of my buckminster-based build, because the athena's based one managed to include it (for instance the MDT/OCL Indigo's M2 included the lpg.runtime.java.source bundle -> http://www.eclipse.org/downloads/download.php?file=/modeling /mdt/ocl/downloads/drops/3.1.0/S201009291415/mdt-ocl-Update- 3.1.0M2a.zip).

The WORST problem around this issue is that our Modeling EPP distribution doesn't contain the lpg.runtime.java.source bundle, which it's very bad (for instance the Modeling EPP M4 -> http://www.eclipse.org/downloads/packages/node/449 )

I've been trying to figure out which is the reason of this problem, so that I tryed to at least make the aforementioned source bundle be available in the MDT/OCL p2 repo without any luck (for instance our last N-build p2 repository zip http://www.eclipse.org/downloads/download.php?file=/modeling /mdt/ocl/downloads/drops/3.1.0/N201012200300/mdt-ocl-Update- N201012200300.zip). So my questions are:

- Do you have any idea about how to make this happen ?
- Do you think that after fixing this issue, the lpg.runtime.java.source bundle will finally be available in our Modeling distribution ?

P.S: Again, if you need any other information/clarification, please let me know it.

Best Regards,
Adolfo.
Previous Topic:No class files in jar
Next Topic:Adding director parameters during site.p2
Goto Forum:
  


Current Time: Thu Dec 02 08:17:31 GMT 2021

Powered by FUDForum. Page generated in 0.02301 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top