Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Project Explorer vs. Navigator problems
Project Explorer vs. Navigator problems [message #601767] Mon, 21 September 2009 23:38 Go to next message
Robert Lewis is currently offline Robert LewisFriend
Messages: 24
Registered: July 2009
Junior Member
I have a problem with both views:

1) Navigator does not show problem marker decorations created on IFiles, however Project Explorer does.

2) Project Explorer does not show my custom 'New Custom Project' and 'New Custom File' extension points when i right click on the project in the Project Explorer, however the Navigator does.

Also which view should i be using if i am creating a custom IDE for a proprietary language?

If more information is needed, let me know what information you need and i will provide the details.

Thanks,
-Rob
Re: Project Explorer vs. Navigator problems [message #601804 is a reply to message #601767] Tue, 22 September 2009 15:32 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
On 9/21/09 7:38 PM, Robert Lewis wrote:
> I have a problem with both views:
>
> 1) Navigator does not show problem marker decorations created on IFiles,
> however Project Explorer does.
>
> 2) Project Explorer does not show my custom 'New Custom Project' and
> 'New Custom File' extension points when i right click on the project in
> the Project Explorer, however the Navigator does.

Problem 2 is likely because you have not attached the "New..." actions
to the right kind of object or context. Can you post the extension XML
that you're using to register your New Custom... wizard?

Eric
Re: Project Explorer vs. Navigator problems [message #602814 is a reply to message #601767] Thu, 22 October 2009 22:32 Go to previous messageGo to next message
Sushma  is currently offline Sushma Friend
Messages: 2
Registered: October 2009
Junior Member
Hi Robert,

I am facing a similar situation with problem markers not appearing in the navigator. They show up in the problems view but not on the IFile in the navigator. When I refresh the file manually, then they appear. Please let me know if you had any luck in solving this issue.

Thanks,
Sushma
Re: Project Explorer vs. Navigator problems [message #603021 is a reply to message #602814] Thu, 29 October 2009 20:10 Go to previous message
Robert Lewis is currently offline Robert LewisFriend
Messages: 24
Registered: July 2009
Junior Member
I have not solved this problem yet ...
Previous Topic:Project Explorer vs. Navigator problems
Next Topic:Building org.eclipse.epp.package.java
Goto Forum:
  


Current Time: Sun Sep 27 07:47:20 GMT 2020

Powered by FUDForum. Page generated in 0.01822 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top