Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Jar contents not exported
Jar contents not exported [message #584409] Thu, 06 November 2008 10:51
Jochen Mader is currently offline Jochen MaderFriend
Messages: 24
Registered: July 2009
Junior Member
Since we upgraded to 3.4 we have some weird problems with plugins in
eclipse.
The worst one is that contents of jars don't get reexported from inside a
plugin.
I wanted to know if somebody has the same problems or if we are doing
something deriously wrong.
Here is the scenario that leads to our problem:
1. Create a simple java project with testclass in it, export as jar
2. Create a simple plugin. Import the jar and reexport its contents.
3. Export plugin.
4. Delete plugin from workspace (the source folders, important because if
you don't do that eclipse will pick the plugin from your workspace and
everythign will work)
5. Close eclipse, put plugin int dropins folder, start eclipse again.
6. Create another plugin, add dependency to the plugin in the dropins
folder.
7. Try to use the class that is reexported by the plugin
=> Class is not available

Any suggestions? Can someone reproduce this?
Thanks
Jochen
Previous Topic:Jar contents not exported
Next Topic:How to add Wizards to WizardCategory programmatically
Goto Forum:
  


Current Time: Sun Sep 19 20:34:59 GMT 2021

Powered by FUDForum. Page generated in 0.01345 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top