Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Nebula » Invalid thread access
Invalid thread access [message #581097] Wed, 25 April 2007 06:34
Swetha is currently offline SwethaFriend
Messages: 68
Registered: July 2009
Member
Hi,

I am developing a Gallery View using nebula gallery widget,
the createPartControl method is,

public void createPartControl(Composite parent)
{

gallery = new Gallery(parent, SWT.V_SCROLL);
);
noGroupRenderer = new NoGroupRenderer();
defaultGalleryItemRenderer = new DefaultGalleryItemRenderer();

(some other code)---------
------
-----------

}

the error is coming at the line
defaultGalleryItemRenderer = new DefaultGalleryItemRenderer();

in DefaultGalleryItemRenderer class the error is at the line,
foregroundColor =
Display.getDefault().getSystemColor(SWT.COLOR_LIST_FOREGROUN D);

public DefaultGalleryItemRenderer() {
foregroundColor =
Display.getDefault().getSystemColor(SWT.COLOR_LIST_FOREGROUN D);
backgroundColor =
Display.getDefault().getSystemColor(SWT.COLOR_LIST_BACKGROUN D);
selectionForegroundColor = foregroundColor;
selectionBackgroundColor =
Display.getDefault().getSystemColor(SWT.COLOR_LIST_SELECTION );

// Create drop shadows
createColors();
}


The error is,

org.eclipse.swt.SWTException: Invalid thread access
at org.eclipse.swt.SWT.error(SWT.java:3374)
at org.eclipse.swt.SWT.error(SWT.java:3297)
at org.eclipse.swt.SWT.error(SWT.java:3268)
at org.eclipse.swt.widgets.Display.error(Display.java:978)
at org.eclipse.swt.widgets.Display.checkDevice(Display.java:638 )
at org.eclipse.swt.widgets.Display.getSystemColor(Display.java: 1931)
at
org.eclipse.nebula.widgets.gallery.DefaultGalleryItemRendere r. <init>(DefaultGalleryItemRenderer.java:63)
at
com.sequenom.everest.ui.project.GalleryView.createPartContro l(GalleryView.java:335)
at
org.eclipse.ui.internal.ViewReference.createPartHelper(ViewR eference.java:332)
at org.eclipse.ui.internal.ViewReference.createPart(ViewReferen ce.java:197)
at
org.eclipse.ui.internal.WorkbenchPartReference.getPart(Workb enchPartReference.java:566)
at
org.eclipse.ui.internal.WorkbenchPage$ActivationList.setActi ve(WorkbenchPage.java:3915)
at
org.eclipse.ui.internal.WorkbenchPage.restoreState(Workbench Page.java:2929)
at
org.eclipse.ui.internal.WorkbenchWindow.restoreState(Workben chWindow.java:1936)
at org.eclipse.ui.internal.Workbench.doRestoreState(Workbench.j ava:2857)
at org.eclipse.ui.internal.Workbench.restoreState(Workbench.jav a:1665)
at org.eclipse.ui.internal.Workbench.access$12(Workbench.java:1 650)
at org.eclipse.ui.internal.Workbench$17.run(Workbench.java:1529 )
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.ui.internal.Workbench.restoreState(Workbench.jav a:1473)
at
org.eclipse.ui.internal.WorkbenchConfigurer.restoreState(Wor kbenchConfigur


Please help me in this,

Thanks in advance,
Swetha
Previous Topic:[CompositeTable] Bug - CompositeTableSnippet6 Crash
Next Topic:Invalid thread access
Goto Forum:
  


Current Time: Sun Oct 25 11:59:16 GMT 2020

Powered by FUDForum. Page generated in 0.01841 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top