Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » AM3 » [AM3] AM3-Injector "xml to ecore" doesn't work!
[AM3] AM3-Injector "xml to ecore" doesn't work! [message #579950] Thu, 24 June 2010 13:20 Go to next message
Alexey is currently offline AlexeyFriend
Messages: 61
Registered: January 2010

Here is my problem:

I have 2 files - one MM (metamodel) as xsd and its M (model) as xml. My purpose is to make ecore files from both MM and M.

1. MM.xsd to MM.ecore -> With EMF-genmodel extraction I could get MM.ecore from MM.xsd

2. M.xml to M.ecore.
This transformation didn't succeed.
I used for xml2ecore transformation the am3-injector (Eclipse 3.4.2+EMF2.4.0+ ATL.2.0 +AM3_0.2.0)
And As I tried the injection to ecore, I got these errors:

Fehler 1: org.eclipse.emf.ecore.xmi.PackageNotFoundException: Package with uri 'XML' not found.
Fehler 2: org.eclipse.emf.ecore.xmi.ClassNotFoundException: Class 'Root' not found.

I also tried to inject some other xml-files always the same 2 errors (see above).

I read then in the ATL-forum that someone faced the same problem.
He solved it then, after installing the "OLD VERSION OF AM3" and after having used the AM3-Injector then.
Here is the link to the forum-entry: mp;start=0&

So, I tried to install this "oldAM3" and found the link with howto:

So, I had to install Eclipse 3.42, then EMF2.4.0, then ATL 2.0 and then at last the old AM3 from sources as described in link "How Install AM3 From SVN".

3.4.2+EMF2.4.0 (core) was ok.

But then I started to look for ATL2.0 and found ONLY ATL2.0 TOGETHER WITH AM3: /m2m/atl/bundle/

No ATL2.0 WITHOUT AM3 was found! And the AM3-version going together with ATL 2.0 is (I suppose) the NEW one, not the OLD one, which (the old one) I need to perform the injection right.


1. Where can I find the ATL 2.0 PURE, without AM3?
2. Is there any other possibility to solve the problem with AM3 - xml2ecore - injection-Errors?

Thanks a lot
Re: [AM3] AM3-Injector "xml to ecore" doesn't work! [message #580010 is a reply to message #579950] Thu, 24 June 2010 15:33 Go to previous messageGo to next message
Hugo Bruneliere is currently offline Hugo BruneliereFriend
Messages: 674
Registered: July 2009
Senior Member
Hi Alexey,

You can find from a bundle including compatible versions of ATL2.x and AM3.
I just re-tested it and the XML injection is properly working.

Best regards,

Hugo Bruneliere - R&D Engineer
AtlanMod research team (INRIA & EMN)
Ecole des Mines de Nantes
Nantes - France

Hugo Bruneliere, PhD
NaoMod team (IMT Atlantique & LS2N-CNRS)
Nantes - France
Re: [AM3] AM3-Injector "xml to ecore" doesn't work! [message #1037367 is a reply to message #580010] Tue, 09 April 2013 13:18 Go to previous messageGo to next message
samar sousou is currently offline samar sousouFriend
Messages: 63
Registered: March 2013
I want the opposite.
There's a solution to convert an xmi to an xml!

thank you.
Re: [AM3] AM3-Injector "xml to ecore" doesn't work! [message #1037418 is a reply to message #1037367] Tue, 09 April 2013 14:29 Go to previous message
Guillaume Doux is currently offline Guillaume DouxFriend
Messages: 56
Registered: July 2009
Please don't cross-post.

Previous Topic:Comment installer un AM3 !
Next Topic:convert XMI to XML
Goto Forum:

Current Time: Sat Nov 27 00:43:43 GMT 2021

Powered by FUDForum. Page generated in 0.02259 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top