Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » rap deploy problem
rap deploy problem [message #551135] Thu, 05 August 2010 11:26 Go to next message
Jing-Chun Shang is currently offline Jing-Chun ShangFriend
Messages: 2
Registered: August 2010
Junior Member
I deploy rap demos to tomcat,but i can't visit.

The demo is http://rap.eclipsesource.com/rapdemo/examples.

why the plugs can't be actived?

the console show:
20 ACTIVE org.eclipse.osgi.services_3.2.100.v20100108
21 ACTIVE org.eclipse.help_3.5.0.v20100304
22 INSTALLED org.eclipse.rap.demo_1.3.0.20100513-1758
23 INSTALLED org.eclipse.rap.design.example_1.3.0.20100513-1758
24 INSTALLED org.eclipse.rap.examples_1.0.0
25 INSTALLED org.eclipse.rap.examples.pages_1.0.0
26 INSTALLED org.eclipse.rap.jface.databinding_1.3.0.20100513-1758
27 INSTALLED org.eclipse.rap.jface.nl1_1.0.0
28 INSTALLED org.eclipse.rap.jface_1.3.0.20100513-1758
29 INSTALLED org.eclipse.rap.pde.runtime.nl1_1.0.0
30 INSTALLED org.eclipse.rap.pde.runtime_3.3.0.v20070608-1300
31 ACTIVE org.eclipse.rap.rms.data_1.0.0
32 INSTALLED org.eclipse.rap.rms.ui_1.0.0
33 INSTALLED org.eclipse.rap.rwt.nl1_1.0.0
34 INSTALLED org.eclipse.rap.rwt.q07_1.3.0.20100513-1758
35 INSTALLED org.eclipse.rap.rwt_1.3.0.20100513-1758
36 INSTALLED org.eclipse.rap.ui.forms.nl1_1.0.0
37 INSTALLED org.eclipse.rap.ui.forms_1.3.0.20100513-1758
38 INSTALLED org.eclipse.rap.ui.nl1_1.0.0
39 INSTALLED org.eclipse.rap.ui_1.3.0.20100513-1758
40 INSTALLED org.eclipse.rap.ui.views.nl1_1.0.0
41 INSTALLED org.eclipse.rap.ui.views_1.3.0.20100513-1758
42 INSTALLED org.eclipse.rap.ui.workbench.nl1_1.0.0
43 INSTALLED org.eclipse.rap.ui.workbench_1.3.0.20100513-1758
Re: rap deploy problem [message #551150 is a reply to message #551135] Thu, 05 August 2010 12:42 Go to previous messageGo to next message
Holger Staudacher is currently offline Holger StaudacherFriend
Messages: 166
Registered: July 2009
Senior Member
Did you read our troubleshouting section on our wiki? Maybe this will
help. You can find the troubleshooting here:
http://wiki.eclipse.org/RAP/FAQ#Deployment

If this will not help please post the content of your config.ini file
and what bundles do you have in your plugins folder.

Regards Holger

On 2010-08-05 13:26:53 +0200, Jing-Chun Shang <jy01020932@163.com> said:

> I deploy rap demos to tomcat,but i can't visit.
>
> The demo is http://rap.eclipsesource.com/rapdemo/examples
>
> why the plugs can't be actived?
>
> the console show:
> 20 ACTIVE org.eclipse.osgi.services_3.2.100.v20100108
> 21 ACTIVE org.eclipse.help_3.5.0.v20100304
> 22 INSTALLED org.eclipse.rap.demo_1.3.0.20100513-1758
> 23 INSTALLED org.eclipse.rap.design.example_1.3.0.20100513-1758
> 24 INSTALLED org.eclipse.rap.examples_1.0.0
> 25 INSTALLED org.eclipse.rap.examples.pages_1.0.0
> 26 INSTALLED org.eclipse.rap.jface.databinding_1.3.0.20100513-1758
> 27 INSTALLED org.eclipse.rap.jface.nl1_1.0.0
> 28 INSTALLED org.eclipse.rap.jface_1.3.0.20100513-1758
> 29 INSTALLED org.eclipse.rap.pde.runtime.nl1_1.0.0
> 30 INSTALLED org.eclipse.rap.pde.runtime_3.3.0.v20070608-1300
> 31 ACTIVE org.eclipse.rap.rms.data_1.0.0
> 32 INSTALLED org.eclipse.rap.rms.ui_1.0.0
> 33 INSTALLED org.eclipse.rap.rwt.nl1_1.0.0
> 34 INSTALLED org.eclipse.rap.rwt.q07_1.3.0.20100513-1758
> 35 INSTALLED org.eclipse.rap.rwt_1.3.0.20100513-1758
> 36 INSTALLED org.eclipse.rap.ui.forms.nl1_1.0.0
> 37 INSTALLED org.eclipse.rap.ui.forms_1.3.0.20100513-1758
> 38 INSTALLED org.eclipse.rap.ui.nl1_1.0.0
> 39 INSTALLED org.eclipse.rap.ui_1.3.0.20100513-1758
> 40 INSTALLED org.eclipse.rap.ui.views.nl1_1.0.0
> 41 INSTALLED org.eclipse.rap.ui.views_1.3.0.20100513-1758
> 42 INSTALLED org.eclipse.rap.ui.workbench.nl1_1.0.0
> 43 INSTALLED org.eclipse.rap.ui.workbench_1.3.0.20100513-1758


--
--
Holger Staudacher | EclipseSource Karlsruhe

Need professional support for RAP and RCP?
Go to: http://eclipsesource.com/support
Twitter : @hstaudacher
Blog : http://eclipsesource.com/blogs/tag/rap/
Re: rap deploy problem [message #551326 is a reply to message #551135] Fri, 06 August 2010 02:37 Go to previous message
Jing-Chun Shang is currently offline Jing-Chun ShangFriend
Messages: 2
Registered: August 2010
Junior Member
hi Holger, thanks for you help.

I have found the reason why I can't visit.

because I use tomcat 7.0 ,the servlet-api.jar in the tomcat7.0 is 3.0 version,the rapdemo need servlet-api.jar 2.3~2.5.

I have deployed successful. thanks.

Regards Jing-Chun
Previous Topic:build.xml not found when export feature
Next Topic:VM options
Goto Forum:
  


Current Time: Thu Apr 25 06:00:53 GMT 2024

Powered by FUDForum. Page generated in 0.03195 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top