Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Buckminster » site.p2 for product configuration always creates and includes source feature
site.p2 for product configuration always creates and includes source feature [message #541737] Tue, 22 June 2010 12:02 Go to next message
Frank Hoellering is currently offline Frank HoelleringFriend
Messages: 10
Registered: June 2010
Junior Member
Hi!

Following the examples from
http:// wiki.eclipse.org/Building_an_RCP_application_with_hudson_%28 Buckminster%29
http://www.ralfebert.de/blog/eclipsercp/rcp_builds/
and the BuckyBook I was able to successfully build my product configuration with Buckminster on Helios RC4 (doing directly from eclipse, not on a Hudson built server).

Though I realized that the created update site always contains an item "Source for Productname feature ". This only gets visible if you point the eclipse installer to the created site.p2 directory and uncheck the "Group items by category" option.
Following the tutorial I get the same effect, so it seems to be either a common setting in the examples and my configuration or a buckminster bug.

For the records, my properties file already contains the
cbi.include.source=false

setting.

There has been a similar bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=292968. Maybe the problem is alike?

Can someone give me a hint for a configuration setting to prevent the source feature from being created or at least not being included in the update site? Or at least indicate that this is an unwanted behavior worth opening a bugreport.

Best regards,
Frank
Re: site.p2 for product configuration always creates and includes source feature [message #541834 is a reply to message #541737] Tue, 22 June 2010 16:35 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas HallgrenFriend
Messages: 3240
Registered: July 2009
Senior Member
Hi Frank,

If you have this behavior with our 3.6 version, then this sounds like a regression of some sort. It's worth a bug report.

Regards,
Thomas Hallgren


On 06/22/2010 02:02 PM, Frank Hoellering wrote:
> Hi!
>
> Following the examples from
> http://wiki.eclipse.org/Building_an_RCP_application_with_hud son_%28Buckminster%29
>
> http://www.ralfebert.de/blog/eclipsercp/rcp_builds/
> and the BuckyBook I was able to successfully build my product
> configuration with Buckminster on Helios RC4 (doing directly from
> eclipse, not on a Hudson built server).
>
> Though I realized that the created update site always contains an item
> "Source for Productname feature ". This only gets visible if you point
> the eclipse installer to the created site.p2 directory and uncheck the
> "Group items by category" option.
> Following the tutorial I get the same effect, so it seems to be either a
> common setting in the examples and my configuration or a buckminster bug.
>
> For the records, my properties file already contains the
> cbi.include.source=false
> setting.
>
> There has been a similar bug
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=292968 Maybe the problem
> is alike?
>
> Can someone give me a hint for a configuration setting to prevent the
> source feature from being created or at least not being included in the
> update site? Or at least indicate that this is an unwanted behavior
> worth opening a bugreport.
>
> Best regards,
> Frank
Re: site.p2 for product configuration always creates and includes source feature [message #541964 is a reply to message #541737] Wed, 23 June 2010 12:02 Go to previous messageGo to next message
Frank Hoellering is currently offline Frank HoelleringFriend
Messages: 10
Registered: June 2010
Junior Member
Hi Thomas!

Thank you for your reply.

I'll test again with the final version of Helios (just to make sure) and open a bug report afterwards.

Regards,
Frank
Re: site.p2 for product configuration always creates and includes source feature [message #542027 is a reply to message #541737] Wed, 23 June 2010 14:55 Go to previous message
Frank Hoellering is currently offline Frank HoelleringFriend
Messages: 10
Registered: June 2010
Junior Member
reproducible in 3.6 final

https://bugs.eclipse.org/bugs/show_bug.cgi?id=317709

Regards,
Frank
Previous Topic:The way fragments are treated
Next Topic:importtargetdefinition errors silently ignored
Goto Forum:
  


Current Time: Tue Sep 28 04:47:43 GMT 2021

Powered by FUDForum. Page generated in 0.02117 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top