Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » DSDP - Mobile Tools for Java (MTJ) » Corrupt JAR, error while reading: midlet/MIDlet.class
Corrupt JAR, error while reading: midlet/MIDlet.class [message #535326] Sat, 22 May 2010 10:32 Go to next message
Erik  is currently offline Erik Friend
Messages: 4
Registered: May 2010
Junior Member
Hi everyone,

I finally managed to get around the compile errors, now its running the apps that is the problem. After SVN checkout it works fine, but after some code changes it just says

Installing suite from:

*** Error ***
A problem occured during deploying application from
Corrupt JAR, error while reading: midlet/MIDlet.class

I've tried with many different J2ME projects that I have on my SVN repository, and most of them work after a clean checkout, sometimes i even have to remove my workspace to get it to work again. What Im i doing wrong? The the class is there, and everything in the build path is set up correctly. Im using J2ME SDK 3.0 with the latest version of Eclipse with MTJ on OSX (Snow Leopard)

I tried to google this, but no one seem to have a explanation of whats going wrong.

Please help me out here, I thought the switch from Ubuntu (where things like this never happened) to OS X would be easy.

Thanks in advance.
Re: Corrupt JAR, error while reading: midlet/MIDlet.class [message #537128 is a reply to message #535326] Tue, 01 June 2010 12:26 Go to previous messageGo to next message
Gustavo de Paula is currently offline Gustavo de PaulaFriend
Messages: 42
Registered: January 2010
just to double check. as far as i remember there was no WTK 3.0 for Mac (there is only support for vista and XP). is that the SDK that you are trying to use on Mac? on mac you can use the motorola sdk or some java based sdk such as microemu or mpowerplay

Re: Corrupt JAR, error while reading: midlet/MIDlet.class [message #671917 is a reply to message #535326] Thu, 19 May 2011 10:56 Go to previous message
Eclipse User is currently offline Eclipse UserFriend
Messages: 2
Registered: May 2011
Junior Member

I ve got the same problem in the same environment. Have you managed to find the solution?

Previous Topic:canot start wtk emulator within eclipse
Next Topic:Problem during packaging: empty jar in \.mtj.tmp\emulation
Goto Forum:

Current Time: Mon Jul 22 11:48:56 GMT 2024

Powered by FUDForum. Page generated in 0.04169 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top