Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » paletteProviders not used?
paletteProviders not used? [message #512560] Fri, 05 February 2010 13:55
Aurélien Pupier is currently offline Aurélien PupierFriend
Messages: 637
Registered: July 2009
Location: Grenoble, FRANCE
Senior Member

Hi,

I'm trying to use org.eclipse.gmf.runtime.diagram.ui.paletteProviders without success.

I want to define my own factoryClass so here is my extension point :
<extension
         point="org.eclipse.gmf.runtime.diagram.ui.paletteProviders">
      <paletteProvider
            class="org.eclipse.gmf.runtime.diagram.ui.providers.DefaultPaletteProvider">
         <Priority
               name="Highest">
         </Priority>
         <contribution
               factoryClass="org.bonitasoft.studio.diagram.form.custom.MyOwnFactoryClass">
         </contribution>
      </paletteProvider>
   </extension>


But teh factory class is never used...

I looked into my XXXDiagramEditor and see that it calls explicitly the generated factoryClass :
/**
	 * @generated
	 */
	protected PaletteRoot createPaletteRoot(PaletteRoot existingPaletteRoot) {
		PaletteRoot root = super.createPaletteRoot(existingPaletteRoot);
		new ProcessPaletteFactory().fillPalette(root);
		return root;
	}


So it seems that it doesn't care about the extension point.

Is it really don't care about it?
How to use the extension points to provides our own factory class? isn't it for that?

Regards,

NB : I'm using GMF 2.2.1


Aurélien Pupier - Red Hat
Senior Software Engineer in Fuse Tooling team
Previous Topic:Different mappings for the same generated code
Next Topic:How to use EReferences as label?
Goto Forum:
  


Current Time: Fri May 14 22:50:30 GMT 2021

Powered by FUDForum. Page generated in 0.02005 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top