Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] The simpliest ATL-Sample doesnt launch(The simpliest ATL-Sample doesnt launch)
icon9.gif  [ATL] The simpliest ATL-Sample doesnt launch [message #510522] Wed, 27 January 2010 17:22 Go to next message
Alexey is currently offline AlexeyFriend
Messages: 61
Registered: January 2010
Member
Hello!

I tryed to perform a simple M2M-Transformation with ATL.
I took this sample: http://www.eclipse.org/m2m/atl/doc/ATLUseCase_Families2Perso ns.pdf

from the ATL page: http://www.eclipse.org/m2m/atl/basicExamples_Patterns/ .

I downloaded the files, set up an ATL project, set up the run configuration according the PDF and then run the transformation.

Ive got then this error:

Error loading platform:/resource/Families2Persons/Families.km3: org.xml.sax.SAXParseException: Content is not allowed in prolog.

What could it be?

Thank You!

ps. I use the newest Eclipse version (downloaded for a couple of weeks)

[Updated on: Wed, 27 January 2010 17:37]

Report message to a moderator

[ATL] Re: The simpliest ATL-Sample doesnt launch [message #510971 is a reply to message #510522] Fri, 29 January 2010 11:19 Go to previous messageGo to next message
William Piers is currently offline William PiersFriend
Messages: 297
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------010509000500040601050000
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 8bit

Hello,

All basic examples source code are now up to date.

Best regards,

William

Alexey a écrit :
> Hello!
>
> I tryed to perform a simple M2M-Transformation with ATL.
> I took this sample:
> http://www.eclipse.org/m2m/atl/doc/ATLUseCase_Families2Perso ns.pdf
>
> from the ATL page: http://www.eclipse.org/m2m/atl/basicExamples_Patterns/ .
>
> I downloaded the files, set up an ATL project, set up the run
> configuration according the PDF and then run the transformation.
>
> Ive got then this error:
> Error loading platform:/resource/Families2Persons/Families.km3:
> org.xml.sax.SAXParseException: Content is not allowed in prolog.
>
> What could it be?
>
> Thank You!
>
> ps. I use the newest Eclipse version (downloaded for a couple of weeks)
>
>

--
Ne manquez pas notre prochaine formation ATL inter entreprises:
ATL - Paris - du 2 au 3 Décembre 2009
Pour plus de dates et pour le détail de cette formation:
http://www.obeo.fr/pages/formations/fr

Don't forget our next ATL training:
ATL - Paris - 2009 December from 2th to 3th
More dates and training program on:
http://www.obeo.fr/pages/formations/fr

--------------010509000500040601050000
Content-Type: text/x-vcard; charset=utf-8;
name="william_piers.vcf"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
filename="william_piers.vcf"

YmVnaW46dmNhcmQNCmZuOldpbGxpYW0gUGllcnMNCm46UGllcnM7V2lsbGlh bQ0Kb3JnOk9i
ZW8NCmFkcjoyIHJ1ZSBSb2JlcnQgU2NodW1hbm47O2xvdCAyNDtOQU5URVM7 OzQ0NDA4O0Zy
YW5jZQ0KZW1haWw7aW50ZXJuZXQ6d2lsbGlhbS5waWVyc0BvYmVvLmZyDQp0 aXRsZTpNREEg
Q29uc3VsdGFudA0KdGVsO3dvcms6KzMzICgwKTIgNTEgMTMgNTAgNTMNCnVy bDpodHRwOi8v
d3d3Lm9iZW8uZnINCnZlcnNpb246Mi4xDQplbmQ6dmNhcmQNCg0K
--------------010509000500040601050000--
Re: [ATL] Re: The simpliest ATL-Sample doesnt launch [message #516954 is a reply to message #510971] Thu, 25 February 2010 15:26 Go to previous message
Alexey is currently offline AlexeyFriend
Messages: 61
Registered: January 2010
Member
Thank you very much, William!
Previous Topic:[ATL] How to Clone/Copy source elements to multiple target elements
Next Topic:[QVTo] 'null' as a result object
Goto Forum:
  


Current Time: Fri Nov 15 16:05:24 GMT 2019

Powered by FUDForum. Page generated in 0.02076 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top