Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » MJT or EclipseME won't uninstall
MJT or EclipseME won't uninstall [message #492987] Thu, 22 October 2009 15:28 Go to next message
Garrett Hynes is currently offline Garrett HynesFriend
Messages: 4
Registered: October 2009
Junior Member

I am working with eclipse 3.4 on a Vista machine and I have been looking at different tools for writing a J2ME application for college.

I initially installed EclipseME using the "Help"->"Software Update...". However, I had problems running any kind of MIDlet with the emulator (even HelloWorld!). I then discovered that EclipseME had moved to MTJ and thought I would uninstall EclipseME and install MTJ instead. I uninstalled EclipseMe through "Help"->"Software Updates...", restarted eclipse and installed MTJ, again through "Help"->"Software Update..." using the URL

However, once I restarted eclipse, it looked like EclipseMe hadn't uninstalled correctly. For example, I have now entries under windows preferences for J2ME and JaveME and under "Run Configurations" I have 2 Wireless Toolkit Emulator entries.

I checked the eclipse/plugin and eclipse/features directories and the eclipseme directories are gone but when they are present in the <workspace>/.metadata/.plugin directory. I have deleted them from here but everytime I go back into eclipse they reappear.

I then tried to uninstall MTJ (through "Help"->"Software Update") but now the exact same thing has happened. The plugins appear to be gone but the functionality is still present in eclipse. I have gone through all brute force removal steps and started eclipse using "eclipse - clean" from the command line, but still MTJ and EclipseME are present.

I have even tried eclipse's "Revert Configuration" functionality but still no difference.

Both are no longer in the "Installed Software" list so I can no longer use this to try and the uninstall process again.

What is going on and how do I remove them?

Kind regards,
Re: MJT or EclipseME won't uninstall [message #493001 is a reply to message #492987] Thu, 22 October 2009 16:18 Go to previous message
Garrett Hynes is currently offline Garrett HynesFriend
Messages: 4
Registered: October 2009
Junior Member
It's ok, I finally figured it out. It's all Vista's UAC fault!

The plugins were installed in my User's directory under the eclipse/org.eclipse.platform_3.4.0_... directory. I deleted them from here and J2ME and EclipseME are finally gone.
Previous Topic:Custom symbol set definitions in a team environment
Next Topic:MJT or EclipseME won't uninstall
Goto Forum:

Current Time: Tue Apr 20 07:33:32 GMT 2021

Powered by FUDForum. Page generated in 0.02074 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top