Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » FormEditor
FormEditor [message #47400] Mon, 17 September 2007 22:51 Go to next message
Markus Wolf is currently offline Markus WolfFriend
Messages: 153
Registered: July 2009
Senior Member
Hi,

I've tried to create a simple form editor with one page and one part on the
page.
But my call to openEditor(...) fails with an exception saying that the
editor id I've given is not found. But I added my editor to the extension
point.

Is this a known problem with the current forms implementation?

Thanks for you input.
Markus Wolf
--
> emedia-solutions wolf web: http://www.emedia-solutions-wolf.de
> Eimsbüttler Straße 115 mail: markus@emedia-solutions-wolf.de
> 22769 Hamburg pgp: http://wwwkeys.de.pgp.net
> +49 40 432 635 83 taxid: 57 / 126 / 16123
Re: FormEditor [message #47431 is a reply to message #47400] Tue, 18 September 2007 06:52 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: fappel.innoopract.com

Hi,

I just created a FormEditor by myself this weekend and it worked without a
problem. Are you sure that the plug-in that contains your editor was added
to the launch configuration?


Ciao
Frank


"Markus Wolf" <markus@emedia-solutions-wolf.de> schrieb im Newsbeitrag
news:fcn0ec$gcv$1@build.eclipse.org...
> Hi,
>
> I've tried to create a simple form editor with one page and one part on
> the
> page.
> But my call to openEditor(...) fails with an exception saying that the
> editor id I've given is not found. But I added my editor to the extension
> point.
>
> Is this a known problem with the current forms implementation?
>
> Thanks for you input.
> Markus Wolf
> --
>> emedia-solutions wolf web: http://www.emedia-solutions-wolf.de
>> Eimsb
Re: FormEditor [message #47643 is a reply to message #47431] Tue, 18 September 2007 18:36 Go to previous messageGo to next message
Markus Wolf is currently offline Markus WolfFriend
Messages: 153
Registered: July 2009
Senior Member
Hi Frank,

> I just created a FormEditor by myself this weekend and it worked without a
> problem. Are you sure that the plug-in that contains your editor was added
> to the launch configuration?
>
yes I'm sure. In the plugin containing the editor is also a wizard which
does work as expected.
Any other idea?

>
> Ciao
> Frank
>
>
> "Markus Wolf" <markus@emedia-solutions-wolf.de> schrieb im Newsbeitrag
> news:fcn0ec$gcv$1@build.eclipse.org...
>> Hi,
>>
>> I've tried to create a simple form editor with one page and one part on
>> the
>> page.
>> But my call to openEditor(...) fails with an exception saying that the
>> editor id I've given is not found. But I added my editor to the extension
>> point.
>>
>> Is this a known problem with the current forms implementation?
>>
>> Thanks for you input.
>> Markus Wolf
>> --
>>> emedia-solutions wolf web: http://www.emedia-solutions-wolf.de
>>> Eimsbüttler Straße 115 mail: markus@emedia-solutions-wolf.de
>>> 22769 Hamburg pgp: http://wwwkeys.de.pgp.net
>>> +49 40 432 635 83 taxid: 57 / 126 / 16123
>
>


--
> emedia-solutions wolf web: http://www.emedia-solutions-wolf.de
> Eimsbüttler Straße 115 mail: markus@emedia-solutions-wolf.de
> 22769 Hamburg pgp: http://wwwkeys.de.pgp.net
> +49 40 432 635 83 taxid: 57 / 126 / 16123
Re: FormEditor [message #47673 is a reply to message #47643] Tue, 18 September 2007 20:02 Go to previous messageGo to next message
Markus Wolf is currently offline Markus WolfFriend
Messages: 153
Registered: July 2009
Senior Member
Ok, I've got it solved.
The editor icon is required, even if it is not marked as required in the
extension point. :(
I'll file this in bugzilla.

Thanks
Markus Wolf
--
> emedia-solutions wolf web: http://www.emedia-solutions-wolf.de
> Eimsbüttler Straße 115 mail: markus@emedia-solutions-wolf.de
> 22769 Hamburg pgp: http://wwwkeys.de.pgp.net
> +49 40 432 635 83 taxid: 57 / 126 / 16123
Re: FormEditor [message #47733 is a reply to message #47673] Tue, 18 September 2007 21:20 Go to previous message
Benjamin Muskalla is currently offline Benjamin MuskallaFriend
Messages: 237
Registered: July 2009
Senior Member
Hi Markus,

this is an issue of the Platform team with a long discussion. To make
the long bug report short: there are some cases where you won't need an
icon for an editor and thus it cannot be marked as required.

See https://bugs.eclipse.org/bugs/show_bug.cgi?id=65731

Greets
Benny

Markus Wolf wrote:
> Ok, I've got it solved.
> The editor icon is required, even if it is not marked as required in the
> extension point. :(
> I'll file this in bugzilla.
>
> Thanks
> Markus Wolf
Previous Topic:Session Issues
Next Topic:dynamic loading of views
Goto Forum:
  


Current Time: Mon Jul 15 16:47:44 GMT 2024

Powered by FUDForum. Page generated in 0.03832 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top