Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Problem running Snippet174 - OpenGL
Problem running Snippet174 - OpenGL [message #465457] Wed, 14 December 2005 09:51 Go to next message
hortiz Mising name is currently offline hortiz Mising nameFriend
Messages: 96
Registered: July 2009
Member
Hi,

I'm trying to run Snippet174 ("draw a rectangle using the
org.eclipse.opengl OpenGL binding") on Linux with Eclipse 3.2. I've got
the following error:

Exception in thread "main" java.lang.UnsatisfiedLinkError: glViewport
at org.eclipse.swt.opengl.GL.glViewport(Native Method)
at org.eclipse.swt.snippets.Snippet174.resize(Snippet174.java:8 5)
at org.eclipse.swt.snippets.Snippet174.init(Snippet174.java:60)
at org.eclipse.swt.snippets.Snippet174.main(Snippet174.java:42)

I use:

boot.jar
opengl.jar
runtime.jar
swt.jar

and:
libswt-atk-gtk-3212.so
libswt-gtk-3212.so
libswt-glx-gtk-3212.so
libswt-pi-gtk-3212.so


Thanks for your help
Helene
Re: Problem running Snippet174 - OpenGL [message #465472 is a reply to message #465457] Wed, 14 December 2005 16:05 Go to previous messageGo to next message
Billy Biggs is currently offline Billy BiggsFriend
Messages: 94
Registered: July 2009
Member
hortiz wrote:
> I'm trying to run Snippet174 ("draw a rectangle using the
> org.eclipse.opengl OpenGL binding") on Linux with Eclipse 3.2. I've got
> the following error:
>
> Exception in thread "main" java.lang.UnsatisfiedLinkError: glViewport
> at org.eclipse.swt.opengl.GL.glViewport(Native Method)
> at org.eclipse.swt.snippets.Snippet174.resize(Snippet174.java:8 5)
> at org.eclipse.swt.snippets.Snippet174.init(Snippet174.java:60)
> at org.eclipse.swt.snippets.Snippet174.main(Snippet174.java:42)

I think you must have an old version of either the snippet or the
opengl binding for SWT. It's org.eclipse.opengl.GL.glViewport, there
is no SWT in the package name anymore.

Please see this link and get eclipse-opengl-0.5.0-x.zip fo your
platform:

http://www.eclipse.org/swt/opengl/

I'd also recommend you use a more complete binding, such as LWJGL or
JOGL.

-Billy
Re: Problem running Snippet174 - OpenGL [message #465562 is a reply to message #465472] Thu, 15 December 2005 13:11 Go to previous message
hortiz Mising name is currently offline hortiz Mising nameFriend
Messages: 96
Registered: July 2009
Member
Hi Billy,
Thanks for you help, it works fine now.
Hélène



Billy Biggs wrote:

> hortiz wrote:
>> I'm trying to run Snippet174 ("draw a rectangle using the
>> org.eclipse.opengl OpenGL binding") on Linux with Eclipse 3.2. I've got
>> the following error:
>>
>> Exception in thread "main" java.lang.UnsatisfiedLinkError: glViewport
>> at org.eclipse.swt.opengl.GL.glViewport(Native Method)
>> at org.eclipse.swt.snippets.Snippet174.resize(Snippet174.java:8 5)
>> at org.eclipse.swt.snippets.Snippet174.init(Snippet174.java:60)
>> at org.eclipse.swt.snippets.Snippet174.main(Snippet174.java:42)

> I think you must have an old version of either the snippet or the
> opengl binding for SWT. It's org.eclipse.opengl.GL.glViewport, there
> is no SWT in the package name anymore.

> Please see this link and get eclipse-opengl-0.5.0-x.zip fo your
> platform:

> http://www.eclipse.org/swt/opengl/

> I'd also recommend you use a more complete binding, such as LWJGL or
> JOGL.

> -Billy
Previous Topic:Gradient Fills in SWT
Next Topic:problems in using SWT browser
Goto Forum:
  


Current Time: Sun Sep 15 18:33:27 GMT 2019

Powered by FUDForum. Page generated in 0.01814 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top