Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Wizard dispalay problem
Wizard dispalay problem [message #452370] Fri, 18 March 2005 13:14 Go to next message
Michael Pellaton is currently offline Michael PellatonFriend
Messages: 289
Registered: July 2009
Senior Member
Hi

I am writing a wizard to change the password of a user. Everyting works
quite good, but I have a problem using the method serErrorMessage(). As
soon as I replace the Message with an error Message, a part of the back-
ground of the title area turns gray instead of white. When I reset the
error messge to null, everything looks fine again.

The code where I set the error message:
if (usernameText.getText().equals("")) {
setMessage(null);
setErrorMessage("A username must be specified");
return;
}

A screen shot of the wizard can be seen on:
http://www.pellaton.li/setErrorMessage.jpg

Am I doing something wrong or is this behaviour normal (I don't think so
because the "new project wizard" of Eclipse does not have the problem)?

Thanks in advance

Michael
Re: Wizard dispalay problem [message #452373 is a reply to message #452370] Fri, 18 March 2005 14:03 Go to previous message
Tiberiu Caprita is currently offline Tiberiu CapritaFriend
Messages: 68
Registered: July 2009
Member
That's a feature of jface TitleDialogArea (I think since 3.0); you can
take a look there for seErrorMesage() code.
Also New Project Wizard has same behaviour (enter an existing Project Name
to see that...).
If you dislike it, take a look of
public void setMessage(String newMessage, int newType)
JavaDoc.

Regards,
Tiberiu


Michael Pellaton wrote:

> Hi

> I am writing a wizard to change the password of a user. Everyting works
> quite good, but I have a problem using the method serErrorMessage(). As
> soon as I replace the Message with an error Message, a part of the back-
> ground of the title area turns gray instead of white. When I reset the
> error messge to null, everything looks fine again.

> The code where I set the error message:
> if (usernameText.getText().equals("")) {
> setMessage(null);
> setErrorMessage("A username must be specified");
> return;
> }

> A screen shot of the wizard can be seen on:
> http://www.pellaton.li/setErrorMessage.jpg

> Am I doing something wrong or is this behaviour normal (I don't think so
> because the "new project wizard" of Eclipse does not have the problem)?

> Thanks in advance

> Michael
Previous Topic:Editable combo box
Next Topic:Problem with adding more than two pages to a Wizard
Goto Forum:
  


Current Time: Wed Aug 21 02:59:47 GMT 2019

Powered by FUDForum. Page generated in 0.01641 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top