Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » StringFieldEditor and ToolTip - whats wrong
StringFieldEditor and ToolTip - whats wrong [message #449754] Fri, 28 January 2005 20:02 Go to next message
Eclipse UserFriend
Originally posted by: ekkehardREMOVE_NO_SPAM.gentz-software.de

hi,
I'm developing a FieldEditorPreferencePage with some different
FieldEditors - all works great using a ScopedPreferenceStore.

now I wanted to add tooltips, but it doesn't work.

this runs:

protected void createFieldEditors() {
{
final StringFieldEditor meinTextStringFieldEditor = new
StringFieldEditor(PreferenceConstants.P_TEXT, "MeinTextLabel",
getFieldEditorParent());

}
}

and this causes an error:
Could not Accept Changes
"The currently displayed page contains invalid values"
hitting OK shows the page but without the default value from
PreferenceStore, without the ToolTip and without the buttons
"Accept" and "Get Defaults".

here's the code:


protected void createFieldEditors() {
{
final StringFieldEditor meinTextStringFieldEditor = new
StringFieldEditor(PreferenceConstants.P_TEXT, "MeinTextLabel",
getFieldEditorParent());
final Text meinText =
meinTextStringFieldEditor.getTextControl(getFieldEditorParen t());
meinText.setToolTipText("mein Tip");
addField(meinTextStringFieldEditor);
}
}

whats wrong with this code ?

thanks for help

ekkehard
(BTW: eclipse 3.1.M4)
Re: StringFieldEditor and ToolTip - whats wrong [message #1831447 is a reply to message #449754] Thu, 20 August 2020 02:59 Go to previous message
seongtai, myeong is currently offline seongtai, myeongFriend
Messages: 1
Registered: July 2009
Junior Member
The wrong code you told me above worked. Was it a version problem at the time?

My Environment
---------------------------------
Eclipse Standard/SDK

Version: Luna Release (4.4.0)
Build id: 20140612-0600
Previous Topic:Modular swt.jar?
Next Topic:100% CPU performance issue when using the SWT Glib implementation and loading a native library
Goto Forum:
  


Current Time: Mon Oct 26 08:24:14 GMT 2020

Powered by FUDForum. Page generated in 0.01301 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top