Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » Ecore + XMI
Ecore + XMI [message #412912] Wed, 12 September 2007 08:00 Go to next message
Youmm P. is currently offline Youmm P.Friend
Messages: 140
Registered: July 2009
Senior Member
Hello,

I feel stupid but I can't find the XMIResourceImpl class but I installed
all EMF plugin from Europa.

I tried "import org.eclipse.emf.ecore.xmi.impl.XMIResourceImpl" but
org.eclipse.emf.ecore.xmi can't be resolved.

Any ideas ?
Re: Ecore + XMI [message #412914 is a reply to message #412912] Wed, 12 September 2007 09:40 Go to previous messageGo to next message
Felix Dorner is currently offline Felix DornerFriend
Messages: 676
Registered: July 2009
Senior Member
Youmm P. wrote:
> Hello,
>
> I feel stupid but I can't find the XMIResourceImpl class but I installed
> all EMF plugin from Europa.
>
> I tried "import org.eclipse.emf.ecore.xmi.impl.XMIResourceImpl" but
> org.eclipse.emf.ecore.xmi can't be resolved.
>
> Any ideas ?

Did you add org.eclipse.emf.ecore.xmi_2.x.x.x.jar (from your emf plugin
installation folder) to the classpath?


Felix
Re: Ecore + XMI [message #412915 is a reply to message #412914] Wed, 12 September 2007 10:17 Go to previous messageGo to next message
Youmm P. is currently offline Youmm P.Friend
Messages: 140
Registered: July 2009
Senior Member
> Did you add org.eclipse.emf.ecore.xmi_2.x.x.x.jar (from your emf plugin
> installation folder) to the classpath?

OK. Problem solved by specifying the update site of EMF, not the one of
Europa, otherwise I didn't have such a file.

Why Eclipse can't automaticaly handle the import for
org.eclipse.emf.ecore.xmi while it works for org.eclipse.ecore.resource ?
Re: Ecore + XMI [message #412924 is a reply to message #412915] Wed, 12 September 2007 11:57 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32066
Registered: July 2009
Senior Member
Youmm,

Normally only the plugins you add via the Dependencies tab of the
MANIFEST.MF editor will have their classes available for import.


Youmm P. wrote:
>
>> Did you add org.eclipse.emf.ecore.xmi_2.x.x.x.jar (from your emf plugin
>> installation folder) to the classpath?
>
> OK. Problem solved by specifying the update site of EMF, not the one
> of Europa, otherwise I didn't have such a file.
>
> Why Eclipse can't automaticaly handle the import for
> org.eclipse.emf.ecore.xmi while it works for org.eclipse.ecore.resource ?


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Ecore + XMI [message #1838711 is a reply to message #412914] Thu, 04 March 2021 01:23 Go to previous message
N Rao Bommela is currently offline N Rao BommelaFriend
Messages: 1
Registered: March 2021
Junior Member
Hi,
If any one still experiencing issue with this problem try creating dependencies to your plug in file.
Step 1:
open your plug-in file [usually u find it at bottome of your project files]
Step 2: select dependencies option
step 3: Select Add option and add
org.eclipse.emf.ecore
step 4: step 3: Select Add option and add
org.eclipse.emf.ecore.xmi

now check your program. I guess your problem is solved.

Thank you
ITS BNR
Previous Topic:[CDO] Oracle DB Adapter for CDO server
Next Topic:Ecore - inherited derived attributes
Goto Forum:
  


Current Time: Sat Oct 16 07:01:19 GMT 2021

Powered by FUDForum. Page generated in 0.02189 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top