Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » namespace for extension points
namespace for extension points [message #39760] Thu, 19 July 2007 12:17 Go to next message
Eclipse UserFriend
Originally posted by: gschmoe.salomon.at

Hi!

I have a problem with extension points. Since my latest update from CVS
(M5) my perspective extension is not working anymore. I debugged the ext.
initialization in rap.ui.workbench plug-in and noticed that the extensions
for "org.eclipse.ui.perspectives" are not found.

To check the ext. point mechanism, I tried to run the demo. However, this
now does not compile (error in plugin.xml) because the extension point
"org.eclipse.rap.swt.themes" cannot be found.
Now, when I try to add a new themes extension in demo plug-in, I can only
select the ext.point
"org.eclipse.rap.ui.workbench.org.eclipse.rap.swt.themes". A similar
situation is with the perspective ext. point - there are two - one with
this prefix and one without...
Any idea what the problem could be?


Thanks and regards,
Gernot
Re: namespace for extension points [message #40042 is a reply to message #39760] Mon, 23 July 2007 08:55 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: fappel.innoopract.com

Hi,

I just checked my available extension points and everything seems to be
fine. Only the correct ones (that without the prefix) are found. I wonder
whether you may have installed an old M3 and/or your target points to the
plug-in directory of your eclipse installation. As theming was not available
in M3 and the namespace switch wasn't done, this could at least explain your
problems.

Ciao
Frank


"Gernot Sch." <gschmoe@salomon.at> schrieb im Newsbeitrag
news:175a757b3dabb5f7494e93077502fe4a$1@www.eclipse.org...
> Hi!
>
> I have a problem with extension points. Since my latest update from CVS
> (M5) my perspective extension is not working anymore. I debugged the ext.
> initialization in rap.ui.workbench plug-in and noticed that the extensions
> for "org.eclipse.ui.perspectives" are not found.
>
> To check the ext. point mechanism, I tried to run the demo. However, this
> now does not compile (error in plugin.xml) because the extension point
> "org.eclipse.rap.swt.themes" cannot be found.
> Now, when I try to add a new themes extension in demo plug-in, I can only
> select the ext.point
> "org.eclipse.rap.ui.workbench.org.eclipse.rap.swt.themes". A similar
> situation is with the perspective ext. point - there are two - one with
> this prefix and one without...
> Any idea what the problem could be?
>
>
> Thanks and regards,
> Gernot
>
Re: namespace for extension points [message #40275 is a reply to message #40042] Tue, 24 July 2007 07:28 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: gschmoe.salomon.at

Hi Frank,

It seems that my extension point might be solved. Although I had checked
out the latest code in the workbench (thus not installed old version), I
had both kind of extension points (with and without prefix). Now I updated
to Eclipse 3.3 and I guess it works.

However, this causes a new problem:
With Eclipse 3.3 I get an exception when opening the workbench. It seems
that for the thread the corresponding display is not found. But, I don't
start a specific thread for this purpose...??

Here is my stack trace:
-------------------------------------

java.lang.NullPointerException
at
org.eclipse.ui.internal.handlers.WidgetMethodHandler.getMeth odToExecute(WidgetMethodHandler.java:193)
at
org.eclipse.ui.internal.handlers.WidgetMethodHandler.isEnabl ed(WidgetMethodHandler.java:184)
at
org.eclipse.ui.internal.handlers.HandlerProxy.isEnabled(Hand lerProxy.java:263)
at org.eclipse.core.commands.Command.isEnabled(Command.java:831 )
at org.eclipse.core.commands.Command.setHandler(Command.java:96 9)
at
org.eclipse.ui.internal.handlers.HandlerAuthority.updateComm and(HandlerAuthority.java:521)
at
org.eclipse.ui.internal.handlers.HandlerAuthority.activateHa ndler(HandlerAuthority.java:169)
at
org.eclipse.ui.internal.handlers.HandlerService.activateHand ler(HandlerService.java:108)
at
org.eclipse.ui.internal.handlers.HandlerService.activateHand ler(HandlerService.java:100)
at
org.eclipse.ui.internal.handlers.HandlerService.activateHand ler(HandlerService.java:95)
at
org.eclipse.ui.internal.handlers.HandlerPersistence.readDefa ultHandlersFromRegistry(HandlerPersistence.java:228)
at
org.eclipse.ui.internal.handlers.HandlerPersistence.read(Han dlerPersistence.java:182)
at
org.eclipse.ui.internal.handlers.HandlerService.readRegistry (HandlerService.java:173)
at
org.eclipse.ui.internal.Workbench.initializeDefaultServices( Workbench.java:1510)
at org.eclipse.ui.internal.Workbench.init(Workbench.java:1243)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2243)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:381)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:153)
at com.wamas.ui.core.WamasApplication$2.run(WamasApplication.ja va:177)
at
org.eclipse.swt.internal.lifecycle.UICallBackManager$SyncRun nable.run(UICallBackManager.java:47)
at
org.eclipse.swt.internal.lifecycle.UICallBackManager.process RunnablesInUIThread(UICallBackManager.java:146)
at
org.eclipse.swt.internal.lifecycle.RWTLifeCycle.afterPhaseEx ecution(RWTLifeCycle.java:154)
at
org.eclipse.swt.internal.lifecycle.RWTLifeCycle.execute(RWTL ifeCycle.java:83)
at com.w4t.engine.W4TModel$ServiceAdapter.execute(W4TModel.java :45)
at
com.w4t.engine.service.FormRequestServiceHandler.service(For mRequestServiceHandler.java:65)
at
com.w4t.engine.service.ServiceManager$HandlerDispatcher.serv ice(ServiceManager.java:104)
at com.w4t.engine.W4TDelegate.doPost(W4TDelegate.java:81)
at
org.eclipse.ui.internal.servlet.RequestHandler.service(Reque stHandler.java:41)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
at
org.eclipse.equinox.http.registry.internal.ServletManager$Se rvletWrapper.service(ServletManager.java:180)
at
org.eclipse.equinox.http.servlet.internal.ServletRegistratio n.handleRequest(ServletRegistration.java:90)
at
org.eclipse.equinox.http.servlet.internal.ProxyServlet.proce ssAlias(ProxyServlet.java:109)
at
org.eclipse.equinox.http.servlet.internal.ProxyServlet.servi ce(ProxyServlet.java:59)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
at
org.eclipse.equinox.http.jetty.internal.HttpServerManager$In ternalHttpServiceServlet.service(HttpServerManager.java:280)
at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder .java:428)
at
org.mortbay.jetty.servlet.ServletHandler.dispatch(ServletHan dler.java:677)
at
org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandl er.java:568)
at org.mortbay.http.HttpContext.handle(HttpContext.java:1530)
at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)
at org.mortbay.http.HttpServer.service(HttpServer.java:909)
at org.mortbay.http.HttpConnection.service(HttpConnection.java: 820)
at org.mortbay.http.HttpConnection.handleNext(HttpConnection.ja va:986)
at org.mortbay.http.HttpConnection.handle(HttpConnection.java:8 37)
at
org.mortbay.http.SocketListener.handleConnection(SocketListe ner.java:245)
at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:3 57)
at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:5 34)
Re: namespace for extension points [message #41021 is a reply to message #40275] Thu, 26 July 2007 10:42 Go to previous message
Eclipse UserFriend
Originally posted by: gschmoe.salomon.at

Hello,

The reason for my problem was an implicit dependency (A->B->C) to
org.eclipse.ui. Since this is often difficult to detect, using the RAP
Integration build as Eclipse Target Platform is a good approach to avoid
such errors...

Just download the latest I-build, extract it to a local directory and set
the Target Platform Location (Window->Preferences->Target Platform) to
this directory! Then it cannot happen to unintentionally include an SWT
plug-in in the run-configuration.

Ciao,
Gernot


Gernot Sch. wrote:

> However, this causes a new problem:
> With Eclipse 3.3 I get an exception when opening the workbench. It seems
> that for the thread the corresponding display is not found. But, I don't
> start a specific thread for this purpose...??

> Here is my stack trace:
> -------------------------------------

> java.lang.NullPointerException
> at
>
org.eclipse.ui.internal.handlers.WidgetMethodHandler.getMeth odToExecute(WidgetMethodHandler.java:193)
Previous Topic:ScrollBar and SelectionListener + a general question
Next Topic:tomcat deployment problem
Goto Forum:
  


Current Time: Mon Oct 02 12:50:43 GMT 2023

Powered by FUDForum. Page generated in 0.02111 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top