Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » SashForm not really visible
SashForm not really visible [message #375237] Mon, 06 October 2003 17:52 Go to next message
Eclipse UserFriend
Originally posted by: Chris.TheFreyers.net

I'm working with a SashForm control, and it looks flat, not raised. I see
a plain grey line where I though I would see a raised bar. Does the
raised appearance happen because the surrounding controls use SWT.BORDER,
or do I need to do something in particular.

Note: I started with the snippet at
http://dev.eclipse.org/viewcvs/index.cgi/~checkout~/platform -swt-home/dev.html

Thanks--
Chris
Re: SashForm not really visible [message #375254 is a reply to message #375237] Tue, 07 October 2003 14:05 Go to previous messageGo to next message
Veronika Irvine is currently offline Veronika IrvineFriend
Messages: 1272
Registered: July 2009
Senior Member
Two things appear to be happening:

1) SashForm creates the Sash widgets without the style SWT.BORDER
2) SashForm has a default width of 3 pixels - on Windows XP, at this width
no border is drawn (event if the SWT.BORDER is applied to the Sashes). A
minimum width of 4 is required.

I entered the following bug report to track this:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=44301

"Chris Freyer" <Chris@TheFreyers.net> wrote in message
news:blsa53$dcc$1@eclipse.org...
> I'm working with a SashForm control, and it looks flat, not raised. I see
> a plain grey line where I though I would see a raised bar. Does the
> raised appearance happen because the surrounding controls use SWT.BORDER,
> or do I need to do something in particular.
>
> Note: I started with the snippet at
>
http://dev.eclipse.org/viewcvs/index.cgi/~checkout~/platform -swt-home/dev.html
>
> Thanks--
> Chris
>
Re: SashForm not really visible [message #375327 is a reply to message #375254] Fri, 10 October 2003 01:04 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: Chris.TheFreyers.net

Thanks Veronika, but the problem still happens when I set the width to a
larger number. In order for the sash to appear raised, all my widgets
need to be placed on a composite, and it goes on into the SashForm.

Thanks--
Chris


Veronika Irvine wrote:

> Two things appear to be happening:

> 1) SashForm creates the Sash widgets without the style SWT.BORDER
> 2) SashForm has a default width of 3 pixels - on Windows XP, at this width
> no border is drawn (event if the SWT.BORDER is applied to the Sashes). A
> minimum width of 4 is required.

> I entered the following bug report to track this:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=44301

> "Chris Freyer" <Chris@TheFreyers.net> wrote in message
> news:blsa53$dcc$1@eclipse.org...
> > I'm working with a SashForm control, and it looks flat, not raised. I see
> > a plain grey line where I though I would see a raised bar. Does the
> > raised appearance happen because the surrounding controls use SWT.BORDER,
> > or do I need to do something in particular.
> >
> > Note: I started with the snippet at
> >
>
http://dev.eclipse.org/viewcvs/index.cgi/~checkout~/platform -swt-home/dev.html
> >
> > Thanks--
> > Chris
> >
Re: SashForm not really visible [message #375337 is a reply to message #375327] Fri, 10 October 2003 13:31 Go to previous message
Veronika Irvine is currently offline Veronika IrvineFriend
Messages: 1272
Registered: July 2009
Senior Member
That is because of point 1 in my reply - the Border style is not being
applied to the Sash objects created.

"Chris Freyer" <Chris@TheFreyers.net> wrote in message
news:bm50ia$lts$1@eclipse.org...
> Thanks Veronika, but the problem still happens when I set the width to a
> larger number. In order for the sash to appear raised, all my widgets
> need to be placed on a composite, and it goes on into the SashForm.
>
> Thanks--
> Chris
>
>
> Veronika Irvine wrote:
>
> > Two things appear to be happening:
>
> > 1) SashForm creates the Sash widgets without the style SWT.BORDER
> > 2) SashForm has a default width of 3 pixels - on Windows XP, at this
width
> > no border is drawn (event if the SWT.BORDER is applied to the Sashes).
A
> > minimum width of 4 is required.
>
> > I entered the following bug report to track this:
> > https://bugs.eclipse.org/bugs/show_bug.cgi?id=44301
>
> > "Chris Freyer" <Chris@TheFreyers.net> wrote in message
> > news:blsa53$dcc$1@eclipse.org...
> > > I'm working with a SashForm control, and it looks flat, not raised. I
see
> > > a plain grey line where I though I would see a raised bar. Does the
> > > raised appearance happen because the surrounding controls use
SWT.BORDER,
> > > or do I need to do something in particular.
> > >
> > > Note: I started with the snippet at
> > >
> >
>
http://dev.eclipse.org/viewcvs/index.cgi/~checkout~/platform -swt-home/dev.html
> > >
> > > Thanks--
> > > Chris
> > >
>
>
Previous Topic:integration with outlook
Next Topic:How to add pluses near the TreeItem even it have not children
Goto Forum:
  


Current Time: Sat Jul 20 15:45:08 GMT 2019

Powered by FUDForum. Page generated in 0.01467 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top