Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Unresolved Requirements
Unresolved Requirements [message #1859094] Thu, 11 May 2023 10:44 Go to next message
Lukas-Angelo Meier is currently offline Lukas-Angelo MeierFriend
Messages: 8
Registered: May 2023
Junior Member
Hi All,

I have been working on a project with GMF and GMF Tooling, but a while ago it broke due to some update and i couldn't generate code anymore.

The version I found that still works is GMF Tooling 3.2.1.
Now i can generate code, however i am getting this error when running the application:
Bundle was not resolved because of a uses constraint violation.
  org.apache.felix.resolver.reason.ReasonException: Uses constraint violation. Unable to resolve resource org.eclipse.gmf.runtime.diagram.ui.render [osgi.identity; osgi.identity="org.eclipse.gmf.runtime.diagram.ui.render"; type="osgi.bundle"; version:Version="1.7.2.202211041032"; singleton:="true"] because it is exposed to package 'org.w3c.dom.events' from resources org.eclipse.osgi [osgi.identity; osgi.identity="org.eclipse.osgi"; type="osgi.bundle"; version:Version="3.18.300.v20230220-1352"; singleton:="true"] and org.w3c.dom.events [osgi.identity; osgi.identity="org.w3c.dom.events"; type="osgi.bundle"; version:Version="3.0.0.draft20060413_v201105210656"] via two dependency chains.

Chain 1:
  org.eclipse.gmf.runtime.diagram.ui.render [osgi.identity; osgi.identity="org.eclipse.gmf.runtime.diagram.ui.render"; type="osgi.bundle"; version:Version="1.7.2.202211041032"; singleton:="true"]
    require: (&(osgi.wiring.bundle=org.eclipse.core.runtime)(&(bundle-version>=3.5.0)(!(bundle-version>=4.0.0))))
     |
    provide: osgi.wiring.bundle: org.eclipse.core.runtime
  org.eclipse.osgi [osgi.identity; osgi.identity="org.eclipse.osgi"; type="osgi.bundle"; version:Version="3.18.300.v20230220-1352"; singleton:="true"]

Chain 2:
  org.eclipse.gmf.runtime.diagram.ui.render [osgi.identity; osgi.identity="org.eclipse.gmf.runtime.diagram.ui.render"; type="osgi.bundle"; version:Version="1.7.2.202211041032"; singleton:="true"]
    require: (&(osgi.wiring.bundle=org.eclipse.gmf.runtime.draw2d.ui.render.awt)(&(bundle-version>=1.2.0)(!(bundle-version>=2.0.0))))
     |
    provide: osgi.wiring.bundle; bundle-version:Version="1.10.0.202211041032"; osgi.wiring.bundle="org.eclipse.gmf.runtime.draw2d.ui.render.awt"; singleton:="true"
  org.apache.batik.transcoder [osgi.identity; osgi.identity="org.apache.batik.transcoder"; type="osgi.bundle"; version:Version="1.16.0.v20221027-0840"]
    import: (&(osgi.wiring.package=org.apache.batik.bridge)(&(version>=1.16.0)(!(version>=2.0.0))))
     |
    export: osgi.wiring.package=org.apache.batik.bridge; uses:=org.w3c.dom.events
  org.apache.batik.bridge [osgi.identity; osgi.identity="org.apache.batik.bridge"; type="osgi.bundle"; version:Version="1.16.0.v20221027-0840"]
    import: (osgi.wiring.package=org.w3c.dom.events)
     |
    export: osgi.wiring.package: org.w3c.dom.events
  org.w3c.dom.events [osgi.identity; osgi.identity="org.w3c.dom.events"; type="osgi.bundle"; version:Version="3.0.0.draft20060413_v201105210656"]
	at org.eclipse.osgi.container.Module.start(Module.java:463)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1852)
	at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1845)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1786)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1750)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1672)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)


I suppose it has to do with the org.apache.batik version required by GMF Tooling beeing outdated, however I do not know how to fix this issue.
Currently there are two org.apache.batik versions installed, 1.6.0 and 1.16.0.

Any help on how to tackle this issue is appreciated.

Thank You
  • Attachment: error.log
    (Size: 442.42KB, Downloaded 36 times)
Re: Unresolved Requirements [message #1859761 is a reply to message #1859094] Mon, 26 June 2023 07:36 Go to previous message
Kabiru Usman is currently offline Kabiru UsmanFriend
Messages: 42
Registered: April 2023
Member
The error seems to indicate that the 'org.eclipse.gmf.runtime.diagram.ui.render' bundle is exposed to the 'org.w3c.dom.events' package from two different sources, causing a uses constraint violation.

One way to potentially resolve this issue is to try to isolate your environment so that there's only one version of each package. You can try uninstalling one of the versions of 'org.apache.batik' to see if that resolves the conflict.

Also, check your target platform and make sure it contains the correct and consistent set of plugins. This is often a reason for such issues.

If the issue persists, you may need to manually resolve the dependencies, which can be time-consuming and complex, but usually works.
Previous Topic:Parent-child layout problem
Next Topic:org.w3c.dom.events dependency issue with eclipse 2023-06
Goto Forum:
  


Current Time: Sat Apr 20 04:34:29 GMT 2024

Powered by FUDForum. Page generated in 0.02568 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top