Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Error during building eclipse 4.26(Error during building eclipse 4.26)
Error during building eclipse 4.26 [message #1856832] Thu, 05 January 2023 04:39 Go to next message
Virag Purnam is currently offline Virag PurnamFriend
Messages: 142
Registered: June 2014
Senior Member
I am trying to build Eclipse 4.26 from source code. I get the below mentioned error.

[ERROR] Internal error: java.lang.RuntimeException: Failed to load p2 repository with ID 'eclipse' from location https://download.eclipse.org/eclipse/updates/R-4.26-202211231800: Unable to read repository at https://download.eclipse.org/eclipse/updates/R-4.26-202211231800. ConnectException: ClosedChannelException -> [Help 1]
org.apache.maven.InternalErrorException: Internal error: java.lang.RuntimeException: Failed to load p2 repository with ID 'eclipse' from location https://download.eclipse.org/eclipse/updates/R-4.26-202211231800

Re: Error during building eclipse 4.26 [message #1856835 is a reply to message #1856832] Thu, 05 January 2023 07:25 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 33163
Registered: July 2009
Senior Member
I think the location should be https://download.eclipse.org/eclipse/updates/4.26/R-4.26-202211231800

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Error during building eclipse 4.26 [message #1856836 is a reply to message #1856835] Thu, 05 January 2023 08:18 Go to previous messageGo to next message
Virag Purnam is currently offline Virag PurnamFriend
Messages: 142
Registered: June 2014
Senior Member
That's true. I have changed that. But Branch R4_26_maintenance has this bug.
Re: Error during building eclipse 4.26 [message #1856838 is a reply to message #1856836] Thu, 05 January 2023 09:10 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 33163
Registered: July 2009
Senior Member
You could contribute a pull request to fix it. I'm not sure where (in which repository) that needs to be changed:

https://github.com/eclipse-platform/


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Disable Dark theme on macOS for eclipse products
Next Topic:Azure signing in error
Goto Forum:
  


Current Time: Sun Jun 16 00:32:19 GMT 2024

Powered by FUDForum. Page generated in 0.02998 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top