Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » RCP Testing Tool » Upgrade to Eclipse 2022-06-java17 breaks RCPTT(ClassNotFound Window$AjcClosure1 with IDE, NoSuchFieldException: messageCount in maven runner)
Upgrade to Eclipse 2022-06-java17 breaks RCPTT [message #1854239] Mon, 08 August 2022 17:57 Go to next message
Niklaus Giger is currently offline Niklaus GigerFriend
Messages: 30
Registered: August 2011
Member
For running via maven the rcppt test in my project
https://srv.elexis.info/jenkins/view/UITest/job/elexis-uitest-h2/1415/
I add the patched rcptt.launching.ext-jar from https://bugs.eclipse.org/bugs/show_bug.cgi?id=580261 to my AUT.

Now the AUT starts and works. But I get tons of errors "java.lang.NoSuchFieldException: messageCount" flood my log.

I was unable to launch the same AUT from the RCPTT-IDE as I got the error
java.lang.ClassNotFoundException: org.eclipse.jface.window.Window$AjcClosure1
over and over again.

I would really appreciate if somebody could give a hint on how to avoid these problems.

Best regards and thanks for your work on RCPTT!
Re: Upgrade to Eclipse 2022-06-java17 breaks RCPTT [message #1855159 is a reply to message #1854239] Fri, 30 September 2022 03:10 Go to previous messageGo to next message
Vasili Gulevich is currently offline Vasili GulevichFriend
Messages: 28
Registered: July 2009
Junior Member
Niklaus, I'm unable to find your AUT on the Jenkins. Could you please give me a download link to test RCPTT on? If the AUT is private, a link can be sent to vasili.gulevich@xored.com
Re: Upgrade to Eclipse 2022-06-java17 breaks RCPTT [message #1855291 is a reply to message #1854239] Thu, 06 October 2022 12:16 Go to previous messageGo to next message
Enrico Bragante is currently offline Enrico BraganteFriend
Messages: 1
Registered: April 2019
Junior Member
I post my experience with the hope it could help others.
We are migrating to Eclipse 2022-06 / java 17, and we faced both issues Niklaus were mentioning.

"messageCount" flood error
For this, we just migrated our RCPTT environment to the latest nightly, which includes a patch which solves this issue. I took both runner and RCPTT IDE from here

java.lang.ClassNotFoundException: org.eclipse.jface.window.Window$AjcClosure1
If you scroll the error log to the bottom, you notice another type of exception, which looks like this: "warning define generated class failed -- (InaccessibleObjectException) Unable to make protected final java.lang.Class java.lang.ClassLoader.defineClass ... etc etc ". The row below explains the reals issue : "module java.base does not "opens java.lang" to unnamed module".
This is a feature of java 17, which doesn't allow indiscriminate reflection anymore by any class in the workspace.
You can instruct RCPTT to launch the AUT adding the following VM argument: --add-opens=java.base/java.lang=ALL-UNNAMED

This solved my problems (the error java.lang.ClassNotFoundException: org.eclipse.jface.window.Window$AjcClosure1 also disappeards).

Best Regards,
Enrico
Re: Upgrade to Eclipse 2022-06-java17 breaks RCPTT [message #1855513 is a reply to message #1855291] Wed, 19 October 2022 06:43 Go to previous message
Niklaus Giger is currently offline Niklaus GigerFriend
Messages: 30
Registered: August 2011
Member
Upgrading to RCPTT 2.5.4 fixed my problem.
We also updated our app to Eclipse 2022-09. I do not know whether this contribution was necessary to solve the problem.
I asked xored to fix this problem and they fixed it for a reasonable price. Thanks a lot!
Previous Topic:Where is the download page of RCP Testing Tool
Next Topic:Homepage eclipse.org/rcptt lost a lot of information
Goto Forum:
  


Current Time: Tue Apr 23 02:54:59 GMT 2024

Powered by FUDForum. Page generated in 0.03838 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top