Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Deployment problem (javax.servlet)
Deployment problem (javax.servlet) [message #34489] Fri, 22 June 2007 11:39 Go to next message
Magnus Konze is currently offline Magnus KonzeFriend
Messages: 35
Registered: July 2009
Member
Hi!
I'm trying to deploy the demo application to a Jetty server.
First i copied the bridge.war to the webapps directory
(http://localhost:8080/bridge/sp_test works). After that i used the
tutorial in the org.eclipse.rap.help-plugin to create the WAR of the
application.
But if i start the application, i get a 404 error. Here is the first part
of the logfile:

!SESSION 2007-06-22 13:29:37.328
-----------------------------------------------
eclipse.buildId=unknown
java.version=1.5.0_11
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
Command-line arguments: -console

!ENTRY org.eclipse.equinox.http.registry 4 0 2007-06-22 13:29:37.328
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Import-Package: javax.servlet; version="2.3.0"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)

The javax.servlet plugin is nowhere in the rapdemo directory, so this
should be the problem. I tried to copy it to different folders (plugin
folders, jetty/lib...) but without success.
Can anybody help me?

Thanks in advance!
Magnus
Re: Deployment problem (javax.servlet) [message #34523 is a reply to message #34489] Fri, 22 June 2007 12:20 Go to previous messageGo to next message
Roberto Sanchez is currently offline Roberto SanchezFriend
Messages: 82
Registered: July 2009
Member
Hi Magnus, Have you included in MANIFEST.MF these lines ?

Import-Package: javax.servlet;version="[2.3.0,2.5.0)",
javax.servlet.http;version="[2.3.0,2.5.0)"

Regards.
Roberto.

Magnus K escribió:
> Hi!
> I'm trying to deploy the demo application to a Jetty server.
> First i copied the bridge.war to the webapps directory
> (http://localhost:8080/bridge/sp_test works). After that i used the
> tutorial in the org.eclipse.rap.help-plugin to create the WAR of the
> application.
> But if i start the application, i get a 404 error. Here is the first
> part of the logfile:
>
> !SESSION 2007-06-22 13:29:37.328
> -----------------------------------------------
> eclipse.buildId=unknown
> java.version=1.5.0_11
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
> Command-line arguments: -console
>
> !ENTRY org.eclipse.equinox.http.registry 4 0 2007-06-22 13:29:37.328
> !MESSAGE FrameworkEvent.ERROR
> !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Import-Package: javax.servlet; version="2.3.0"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
>
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
>
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
>
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
>
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
>
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
>
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
>
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
>
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)
>
>
> The javax.servlet plugin is nowhere in the rapdemo directory, so this
> should be the problem. I tried to copy it to different folders (plugin
> folders, jetty/lib...) but without success.
> Can anybody help me?
>
> Thanks in advance!
> Magnus
>
Re: Deployment problem (javax.servlet) [message #36915 is a reply to message #34523] Fri, 06 July 2007 13:18 Go to previous messageGo to next message
Magnus Konze is currently offline Magnus KonzeFriend
Messages: 35
Registered: July 2009
Member
Hi Roberto!
These lines are in the MANIFEST.MF of the org.eclipse.rap.demo plugin. Is
there another plugin, where i have to add them?
Regards
Magnus


Roberto Sá‡nchez wrote:

> Hi Magnus, Have you included in MANIFEST.MF these lines ?

> Import-Package: javax.servlet;version="[2.3.0,2.5.0)",
> javax.servlet.http;version="[2.3.0,2.5.0)"

> Regards.
> Roberto.

> Magnus K escribió:
>> Hi!
>> I'm trying to deploy the demo application to a Jetty server.
>> First i copied the bridge.war to the webapps directory
>> (http://localhost:8080/bridge/sp_test works). After that i used the
>> tutorial in the org.eclipse.rap.help-plugin to create the WAR of the
>> application.
>> But if i start the application, i get a 404 error. Here is the first
>> part of the logfile:
>>
>> !SESSION 2007-06-22 13:29:37.328
>> -----------------------------------------------
>> eclipse.buildId=unknown
>> java.version=1.5.0_11
>> java.vendor=Sun Microsystems Inc.
>> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
>> Command-line arguments: -console
>>
>> !ENTRY org.eclipse.equinox.http.registry 4 0 2007-06-22 13:29:37.328
>> !MESSAGE FrameworkEvent.ERROR
>> !STACK 0
>> org.osgi.framework.BundleException: The bundle could not be resolved.
>> Reason: Missing Constraint: Import-Package: javax.servlet; version="2.3.0"
>> at
>>
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
>>
>> at
>>
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
>>
>> at
>>
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
>>
>> at
>>
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
>>
>> at
>>
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
>>
>> at
>>
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
>>
>> at
>>
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
>>
>> at
>>
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
>>
>> at
>>
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)
>>
>>
>> The javax.servlet plugin is nowhere in the rapdemo directory, so this
>> should be the problem. I tried to copy it to different folders (plugin
>> folders, jetty/lib...) but without success.
>> Can anybody help me?
>>
>> Thanks in advance!
>> Magnus
>>
Re: Deployment problem (javax.servlet) [message #37016 is a reply to message #34489] Mon, 09 July 2007 05:50 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: fappel.innoopract.com

Hi,

I don' t think that the servlet bundle is the problem, I think the message
is misleading. The servlet classes and interfaces are provided by the
servlet container. The servlet-bridge creates a special bundle fragment at
startup that handle this. Are there more messages in the log?

Ciao
Frank

"Magnus K" <bodomchild@web.de> schrieb im Newsbeitrag
news:fccd520686e55fdcf6b211882291f87e$1@www.eclipse.org...
> Hi!
> I'm trying to deploy the demo application to a Jetty server.
> First i copied the bridge.war to the webapps directory
> (http://localhost:8080/bridge/sp_test works). After that i used the
> tutorial in the org.eclipse.rap.help-plugin to create the WAR of the
> application.
> But if i start the application, i get a 404 error. Here is the first part
> of the logfile:
>
> !SESSION 2007-06-22
> 13:29:37.328 -----------------------------------------------
> eclipse.buildId=unknown
> java.version=1.5.0_11
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
> Command-line arguments: -console
>
> !ENTRY org.eclipse.equinox.http.registry 4 0 2007-06-22 13:29:37.328
> !MESSAGE FrameworkEvent.ERROR
> !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Import-Package: javax.servlet; version="2.3.0"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)
>
> The javax.servlet plugin is nowhere in the rapdemo directory, so this
> should be the problem. I tried to copy it to different folders (plugin
> folders, jetty/lib...) but without success.
> Can anybody help me?
>
> Thanks in advance!
> Magnus
>
Re: Deployment problem (javax.servlet) [message #37082 is a reply to message #37016] Tue, 10 July 2007 09:05 Go to previous messageGo to next message
Magnus Konze is currently offline Magnus KonzeFriend
Messages: 35
Registered: July 2009
Member
Hi, i try to describe my complete approach:

1) I used the team project set file
(http://www.eclipse.org/rap/resources/rap.psf) to import the RAP projects.
The demo works fine.
2) I downloaded the servlet bridge bundles with this project set:
org.eclipse.rap.help/help/html/getting-started/servletbridge -anon.psf
3) I checked out org.eclipse.rap.demo.feature from
dev.eclipse.org:/cvsroot/technology/org.eclipse.rap
4) I created the WAR using the tutorial in org.eclipse.rap.help and copied
it to the Jetty webapps directory.

If i try to access the application (http://localhost:8080/rapdemo/) i get
the following error:

HTTP ERROR: 404
ProxyServlet: /rapdemo/
RequestURI=/rapdemo/


I found out, that the rap plugins are not active. Here is the output of
the short status command:

ss

Framework is launched.

id State Bundle
0 ACTIVE system.bundle_3.2.0.v20060601
Fragments=30
1 ACTIVE org.eclipse.core.commands_3.2.0.I20060605-1400
2 ACTIVE org.eclipse.core.contenttype_3.2.0.v20060603
3 ACTIVE org.eclipse.core.expressions_3.2.0.v20060605-1400
4 ACTIVE org.eclipse.core.jobs_3.2.0.v20060603
5 ACTIVE org.eclipse.core.runtime_3.2.0.v20060603
6 ACTIVE org.eclipse.equinox.common_3.2.0.v20060603
7 ACTIVE org.eclipse.equinox.http.registry_1.0.0.200707101003
8 ACTIVE
org.eclipse.equinox.http.servletbridge_1.0.0.200707101003
9 ACTIVE org.eclipse.equinox.http.servlet_1.0.0.200707101003
10 ACTIVE org.eclipse.equinox.preferences_3.2.0.v20060601
11 ACTIVE org.eclipse.equinox.registry_3.2.0.v20060601
12 ACTIVE org.eclipse.osgi.services_3.1.100.v20060601
13 INSTALLED org.eclipse.rap.demo_1.0.0.200707101003
14 INSTALLED org.eclipse.rap.jface_1.0.0.200707101003
15 INSTALLED org.eclipse.rap.rwt_1.0.0.200707101003
16 INSTALLED org.eclipse.rap.ui.workbench_1.0.0.200707101003
17 INSTALLED org.eclipse.rap.w4t_1.0.0.200707101003
18 ACTIVE org.eclipse.update.configurator_3.2.0.v20060605
30 RESOLVED org.eclipse.equinox.servletbridge.extensionbundle_1.0.0
Master=0


And at last, here is the complete logfile from the eclipse/configuration
directory:


!SESSION 2007-07-10 10:41:11.054
-----------------------------------------------
eclipse.buildId=unknown
java.version=1.5.0_11
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
Command-line arguments: -console

!ENTRY org.eclipse.equinox.http.registry 4 0 2007-07-10 10:41:11.054
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Import-Package: javax.servlet; version="2.3.0"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)

!ENTRY org.eclipse.equinox.http.servletbridge 4 0 2007-07-10 10:41:11.070
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Import-Package: javax.servlet; version="2.3.0"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)

!ENTRY org.eclipse.equinox.http.servlet 4 0 2007-07-10 10:41:11.085
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Import-Package: javax.servlet; version="2.3.0"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)

!ENTRY org.eclipse.rap.demo 4 0 2007-07-10 10:41:11.085
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.ui.workbench;
bundle-version="0.0.0"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)

!ENTRY org.eclipse.rap.jface 4 0 2007-07-10 10:41:11.085
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.rwt;
bundle-version="1.0.0"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)

!ENTRY org.eclipse.rap.rwt 4 0 2007-07-10 10:41:11.101
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.w4t;
bundle-version="0.0.0"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)

!ENTRY org.eclipse.rap.ui.workbench 4 0 2007-07-10 10:41:11.101
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Require-Bundle:
org.eclipse.equinox.http.registry; bundle-version="0.0.0"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)

!ENTRY org.eclipse.rap.w4t 4 0 2007-07-10 10:41:11.117
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Import-Package: javax.servlet;
version="[2.3.0,2.5.0)"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)

!ENTRY org.eclipse.osgi 4 0 2007-07-10 10:41:11.398
!MESSAGE Bundle
initial@reference :file:../../../../../../DOKUME~1/konze/LOKALE~1/Temp/Jetty_0 _0_0_0_8080_rapdemo__rapdemo__-n8uacz/eclipse/plugins/org.ec lipse.rap.demo_1.0.0.200707101003.jar/
was not resolved.

!ENTRY org.eclipse.osgi 4 0 2007-07-10 10:41:11.398
!MESSAGE Bundle
initial@reference :file:../../../../../../DOKUME~1/konze/LOKALE~1/Temp/Jetty_0 _0_0_0_8080_rapdemo__rapdemo__-n8uacz/eclipse/plugins/org.ec lipse.rap.jface_1.0.0.200707101003.jar/
was not resolved.

!ENTRY org.eclipse.osgi 4 0 2007-07-10 10:41:11.413
!MESSAGE Bundle
initial@reference :file:../../../../../../DOKUME~1/konze/LOKALE~1/Temp/Jetty_0 _0_0_0_8080_rapdemo__rapdemo__-n8uacz/eclipse/plugins/org.ec lipse.rap.rwt_1.0.0.200707101003.jar/
was not resolved.

!ENTRY org.eclipse.osgi 4 0 2007-07-10 10:41:11.413
!MESSAGE Bundle
initial@reference :file:../../../../../../DOKUME~1/konze/LOKALE~1/Temp/Jetty_0 _0_0_0_8080_rapdemo__rapdemo__-n8uacz/eclipse/plugins/org.ec lipse.rap.ui.workbench_1.0.0.200707101003.jar/
was not resolved.

!ENTRY org.eclipse.osgi 4 0 2007-07-10 10:41:11.413
!MESSAGE Bundle
initial@reference :file:../../../../../../DOKUME~1/konze/LOKALE~1/Temp/Jetty_0 _0_0_0_8080_rapdemo__rapdemo__-n8uacz/eclipse/plugins/org.ec lipse.rap.w4t_1.0.0.200707101003.jar/
was not resolved.



Regards
Magnus

Frank Appel wrote:

> Hi,

> I don' t think that the servlet bundle is the problem, I think the message
> is misleading. The servlet classes and interfaces are provided by the
> servlet container. The servlet-bridge creates a special bundle fragment at
> startup that handle this. Are there more messages in the log?

> Ciao
> Frank
Re: Deployment problem (javax.servlet) [message #37565 is a reply to message #37082] Mon, 16 July 2007 07:22 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: fappel.innoopract.com

Hi,

strange indeed. From the OSGi trace I assume that you use a 3.2 target with
Java 5 at runtime. Which Java Version do you use at build time? I only
encountered once a similar problem using the 1.4 VM with a 3.2 Eclipse for
building the stuff. Changing to Java 1.5 solved the problem - but don't ask
me why. Did you try to deploy against the 3.3 target and did the same
problem occur? Something that strikes me is that your system bundle version
(and also some of the core bundles) seems to be relatively old (the example
in the documentation uses 3.2.1, your versions are 3.2.0) - maybe you should
try the latest target of the M5 build.

Ciao
Frank


"Magnus K" <bodomchild@web.de> schrieb im Newsbeitrag
news:ef08a8edbc329ba21acbdf827d029339$1@www.eclipse.org...
> Hi, i try to describe my complete approach:
>
> 1) I used the team project set file
> (http://www.eclipse.org/rap/resources/rap.psf) to import the RAP projects.
> The demo works fine.
> 2) I downloaded the servlet bridge bundles with this project set:
> org.eclipse.rap.help/help/html/getting-started/servletbridge -anon.psf
> 3) I checked out org.eclipse.rap.demo.feature from
> dev.eclipse.org:/cvsroot/technology/org.eclipse.rap
> 4) I created the WAR using the tutorial in org.eclipse.rap.help and copied
> it to the Jetty webapps directory.
>
> If i try to access the application (http://localhost:8080/rapdemo/) i get
> the following error:
>
> HTTP ERROR: 404
> ProxyServlet: /rapdemo/
> RequestURI=/rapdemo/
>
>
> I found out, that the rap plugins are not active. Here is the output of
> the short status command:
>
> ss
>
> Framework is launched.
>
> id State Bundle
> 0 ACTIVE system.bundle_3.2.0.v20060601
> Fragments=30
> 1 ACTIVE org.eclipse.core.commands_3.2.0.I20060605-1400
> 2 ACTIVE org.eclipse.core.contenttype_3.2.0.v20060603
> 3 ACTIVE org.eclipse.core.expressions_3.2.0.v20060605-1400
> 4 ACTIVE org.eclipse.core.jobs_3.2.0.v20060603
> 5 ACTIVE org.eclipse.core.runtime_3.2.0.v20060603
> 6 ACTIVE org.eclipse.equinox.common_3.2.0.v20060603
> 7 ACTIVE org.eclipse.equinox.http.registry_1.0.0.200707101003
> 8 ACTIVE
> org.eclipse.equinox.http.servletbridge_1.0.0.200707101003
> 9 ACTIVE org.eclipse.equinox.http.servlet_1.0.0.200707101003
> 10 ACTIVE org.eclipse.equinox.preferences_3.2.0.v20060601
> 11 ACTIVE org.eclipse.equinox.registry_3.2.0.v20060601
> 12 ACTIVE org.eclipse.osgi.services_3.1.100.v20060601
> 13 INSTALLED org.eclipse.rap.demo_1.0.0.200707101003
> 14 INSTALLED org.eclipse.rap.jface_1.0.0.200707101003
> 15 INSTALLED org.eclipse.rap.rwt_1.0.0.200707101003
> 16 INSTALLED org.eclipse.rap.ui.workbench_1.0.0.200707101003
> 17 INSTALLED org.eclipse.rap.w4t_1.0.0.200707101003
> 18 ACTIVE org.eclipse.update.configurator_3.2.0.v20060605
> 30 RESOLVED
> org.eclipse.equinox.servletbridge.extensionbundle_1.0.0
> Master=0
>
>
> And at last, here is the complete logfile from the eclipse/configuration
> directory:
>
>
> !SESSION 2007-07-10
> 10:41:11.054 -----------------------------------------------
> eclipse.buildId=unknown
> java.version=1.5.0_11
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
> Command-line arguments: -console
>
> !ENTRY org.eclipse.equinox.http.registry 4 0 2007-07-10 10:41:11.054
> !MESSAGE FrameworkEvent.ERROR
> !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Import-Package: javax.servlet; version="2.3.0"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)
>
> !ENTRY org.eclipse.equinox.http.servletbridge 4 0 2007-07-10 10:41:11.070
> !MESSAGE FrameworkEvent.ERROR
> !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Import-Package: javax.servlet; version="2.3.0"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)
>
> !ENTRY org.eclipse.equinox.http.servlet 4 0 2007-07-10 10:41:11.085
> !MESSAGE FrameworkEvent.ERROR
> !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Import-Package: javax.servlet; version="2.3.0"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)
>
> !ENTRY org.eclipse.rap.demo 4 0 2007-07-10 10:41:11.085
> !MESSAGE FrameworkEvent.ERROR
> !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.ui.workbench;
> bundle-version="0.0.0"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)
>
> !ENTRY org.eclipse.rap.jface 4 0 2007-07-10 10:41:11.085
> !MESSAGE FrameworkEvent.ERROR
> !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.rwt;
> bundle-version="1.0.0"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)
>
> !ENTRY org.eclipse.rap.rwt 4 0 2007-07-10 10:41:11.101
> !MESSAGE FrameworkEvent.ERROR
> !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.w4t;
> bundle-version="0.0.0"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)
>
> !ENTRY org.eclipse.rap.ui.workbench 4 0 2007-07-10 10:41:11.101
> !MESSAGE FrameworkEvent.ERROR
> !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Require-Bundle:
> org.eclipse.equinox.http.registry; bundle-version="0.0.0"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)
>
> !ENTRY org.eclipse.rap.w4t 4 0 2007-07-10 10:41:11.117
> !MESSAGE FrameworkEvent.ERROR
> !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Import-Package: javax.servlet;
> version="[2.3.0,2.5.0)"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:294)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:329)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1037)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:573)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:495)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:275)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:455)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:189)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:291)
>
> !ENTRY org.eclipse.osgi 4 0 2007-07-10 10:41:11.398
> !MESSAGE Bundle
> initial@reference :file:../../../../../../DOKUME~1/konze/LOKALE~1/Temp/Jetty_0 _0_0_0_8080_rapdemo__rapdemo__-n8uacz/eclipse/plugins/org.ec lipse.rap.demo_1.0.0.200707101003.jar/
> was not resolved.
>
> !ENTRY org.eclipse.osgi 4 0 2007-07-10 10:41:11.398
> !MESSAGE Bundle
> initial@reference :file:../../../../../../DOKUME~1/konze/LOKALE~1/Temp/Jetty_0 _0_0_0_8080_rapdemo__rapdemo__-n8uacz/eclipse/plugins/org.ec lipse.rap.jface_1.0.0.200707101003.jar/
> was not resolved.
>
> !ENTRY org.eclipse.osgi 4 0 2007-07-10 10:41:11.413
> !MESSAGE Bundle
> initial@reference :file:../../../../../../DOKUME~1/konze/LOKALE~1/Temp/Jetty_0 _0_0_0_8080_rapdemo__rapdemo__-n8uacz/eclipse/plugins/org.ec lipse.rap.rwt_1.0.0.200707101003.jar/
> was not resolved.
>
> !ENTRY org.eclipse.osgi 4 0 2007-07-10 10:41:11.413
> !MESSAGE Bundle
> initial@reference :file:../../../../../../DOKUME~1/konze/LOKALE~1/Temp/Jetty_0 _0_0_0_8080_rapdemo__rapdemo__-n8uacz/eclipse/plugins/org.ec lipse.rap.ui.workbench_1.0.0.200707101003.jar/
> was not resolved.
>
> !ENTRY org.eclipse.osgi 4 0 2007-07-10 10:41:11.413
> !MESSAGE Bundle
> initial@reference :file:../../../../../../DOKUME~1/konze/LOKALE~1/Temp/Jetty_0 _0_0_0_8080_rapdemo__rapdemo__-n8uacz/eclipse/plugins/org.ec lipse.rap.w4t_1.0.0.200707101003.jar/
> was not resolved.
>
>
>
> Regards
> Magnus
>
> Frank Appel wrote:
>
>> Hi,
>
>> I don' t think that the servlet bundle is the problem, I think the
>> message is misleading. The servlet classes and interfaces are provided by
>> the servlet container. The servlet-bridge creates a special bundle
>> fragment at startup that handle this. Are there more messages in the log?
>
>> Ciao
>> Frank
>
Re: Deployment problem (javax.servlet) [message #37858 is a reply to message #37565] Mon, 16 July 2007 12:23 Go to previous messageGo to next message
Magnus Konze is currently offline Magnus KonzeFriend
Messages: 35
Registered: July 2009
Member
Hi!
Yes, i still used eclipse 3.2.0 with Java 1.5 and played around with RAP
since M2 in the same workspace. So now i started from zero with a fresh
eclipse 3.3.0, Java 1.5.0_11 and Jetty 6.1.4, unfortunately with a similar
result, but at first a question:

If i use the project set file to import the RAP projects, do i still have
to change the Target Platform (like described here:
http://www.eclipse.org/rap/downloads.php). I didn't do it, because the
demo application immediately worked (and also because i didn't have an
idea to which path i should change it).

Here are the short status and the logfile of my new attempt:


ss

Framework is launched.

id State Bundle
0 ACTIVE org.eclipse.osgi_3.3.0.v20070530
Fragments=30
1 ACTIVE org.eclipse.core.commands_3.3.0.I20070605-0010
2 ACTIVE org.eclipse.core.contenttype_3.2.100.v20070319
3 INSTALLED org.eclipse.core.expressions_3.3.0.v20070606-0010
4 ACTIVE org.eclipse.core.jobs_3.3.0.v20070423
5 INSTALLED org.eclipse.core.runtime_3.3.100.v20070530
6 ACTIVE org.eclipse.equinox.common_3.3.0.v20070426
7 ACTIVE org.eclipse.equinox.http.registry_1.0.0.200707161321
8 ACTIVE
org.eclipse.equinox.http.servletbridge_1.0.0.200707161321
9 ACTIVE org.eclipse.equinox.http.servlet_1.0.0.200707161321
10 ACTIVE org.eclipse.equinox.preferences_3.2.100.v20070522
11 ACTIVE org.eclipse.equinox.registry_3.3.0.v20070522
12 ACTIVE org.eclipse.osgi.services_3.1.200.v20070605
13 INSTALLED org.eclipse.rap.demo_1.0.0.200707161321
14 INSTALLED org.eclipse.rap.jface_1.0.0.200707161321
15 INSTALLED org.eclipse.rap.rwt_1.0.0.200707161321
16 INSTALLED org.eclipse.rap.ui.workbench_1.0.0.200707161321
17 INSTALLED org.eclipse.rap.w4t_1.0.0.200707161321
18 ACTIVE org.eclipse.update.configurator_3.2.100.v20070615
30 RESOLVED org.eclipse.equinox.servletbridge.extensionbundle_1.0.0
Master=0


The logfile:

!SESSION 2007-07-16 14:07:56.578
-----------------------------------------------
eclipse.buildId=unknown
java.version=1.5.0_11
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
Command-line arguments: -console

!ENTRY org.eclipse.core.expressions 4 0 2007-07-16 14:07:56.578
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Require-Bundle: org.eclipse.core.runtime;
bundle-version="[3.1.0,4.0.0)"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)

!ENTRY org.eclipse.core.runtime 4 0 2007-07-16 14:07:56.625
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Require-Bundle: org.eclipse.equinox.app;
bundle-version="[1.0.0,2.0.0)"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)

!ENTRY org.eclipse.equinox.http.registry 4 0 2007-07-16 14:07:56.625
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Import-Package: javax.servlet; version="2.3.0"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)

!ENTRY org.eclipse.equinox.http.servletbridge 4 0 2007-07-16 14:07:56.625
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Import-Package: javax.servlet; version="2.3.0"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)

!ENTRY org.eclipse.equinox.http.servlet 4 0 2007-07-16 14:07:56.640
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Import-Package: javax.servlet; version="2.3.0"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)

!ENTRY org.eclipse.rap.demo 4 0 2007-07-16 14:07:56.640
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.ui.workbench;
bundle-version="0.0.0"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)

!ENTRY org.eclipse.rap.jface 4 0 2007-07-16 14:07:56.656
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.rwt;
bundle-version="1.0.0"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)

!ENTRY org.eclipse.rap.rwt 4 0 2007-07-16 14:07:56.656
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.w4t;
bundle-version="0.0.0"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)

!ENTRY org.eclipse.rap.ui.workbench 4 0 2007-07-16 14:07:56.671
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Require-Bundle: org.eclipse.core.runtime;
bundle-version="0.0.0"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)

!ENTRY org.eclipse.rap.w4t 4 0 2007-07-16 14:07:56.671
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved.
Reason: Missing Constraint: Import-Package: javax.servlet;
version="[2.3.0,2.5.0)"
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
at
org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
at
org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
at
org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)

!ENTRY org.eclipse.osgi 4 0 2007-07-16 14:07:56.906
!MESSAGE Bundle
initial@reference :file:plugins/org.eclipse.core.expressions_3.3.0.v20070606-0 010.jar/
was not resolved.

!ENTRY org.eclipse.osgi 4 0 2007-07-16 14:07:56.906
!MESSAGE Bundle
initial@reference :file:plugins/org.eclipse.core.runtime_3.3.100.v20070530.jar /
was not resolved.

!ENTRY org.eclipse.osgi 4 0 2007-07-16 14:07:56.906
!MESSAGE Bundle
initial@reference:file:plugins/org.eclipse.rap.demo_1.0.0.200707161321.jar/
was not resolved.

!ENTRY org.eclipse.osgi 4 0 2007-07-16 14:07:56.921
!MESSAGE Bundle
initial@reference:file:plugins/org.eclipse.rap.jface_1.0.0.200707161321.jar/
was not resolved.

!ENTRY org.eclipse.osgi 4 0 2007-07-16 14:07:56.921
!MESSAGE Bundle
initial@reference:file:plugins/org.eclipse.rap.rwt_1.0.0.200707161321.jar/
was not resolved.

!ENTRY org.eclipse.osgi 4 0 2007-07-16 14:07:56.921
!MESSAGE Bundle
initial@reference :file:plugins/org.eclipse.rap.ui.workbench_1.0.0.20070716132 1.jar/
was not resolved.

!ENTRY org.eclipse.osgi 4 0 2007-07-16 14:07:56.921
!MESSAGE Bundle
initial@reference:file:plugins/org.eclipse.rap.w4t_1.0.0.200707161321.jar/
was not resolved.



Frank Appel wrote:

> Hi,

> strange indeed. From the OSGi trace I assume that you use a 3.2 target with
> Java 5 at runtime. Which Java Version do you use at build time? I only
> encountered once a similar problem using the 1.4 VM with a 3.2 Eclipse for
> building the stuff. Changing to Java 1.5 solved the problem - but don't ask
> me why. Did you try to deploy against the 3.3 target and did the same
> problem occur? Something that strikes me is that your system bundle version
> (and also some of the core bundles) seems to be relatively old (the example
> in the documentation uses 3.2.1, your versions are 3.2.0) - maybe you should
> try the latest target of the M5 build.

> Ciao
> Frank
Re: Deployment problem (different approach) [message #37960 is a reply to message #37565] Mon, 16 July 2007 13:08 Go to previous messageGo to next message
Magnus Konze is currently offline Magnus KonzeFriend
Messages: 35
Registered: July 2009
Member
Hi!
This is my other approach to deploy the demo application:
I didn't use the project set file, instead i downladed the target platform
M5
( http://www.eclipse.org/downloads/download.php?file=/technolo gy/rap/rap-1.0-M5-incubation-target-3.3-20070713-1906.zip)
and changed the target platform location in the Plug-in Developement
preferences.
Then i checked out org.eclipse.rap.demo and used this project set file
( http://www.eclipse.org/equinox/server/downloads/servletbridg e-anon.psf)
to download the servletbridge.
Now there are only 7 projects in the package explorer (6 from the
servletbridge bundle and org.eclipse.rap.demo.feature).
If i run the ant script (webappBuilder.xml) the plug-ins aren't exported
to the application build.
Any ideas what's wrong with this approach?
Regards Magnus
Re: Deployment problem (javax.servlet) [message #38332 is a reply to message #37858] Tue, 17 July 2007 05:00 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: fappel.innoopract.com

Hi again,

if you use the project set file it should not be absolutely necessary to
switch the target platform, but I encountered problems with the RCP
namespaces on serveral occasions with this approach. So I recommend to use a
different target than the eclipse installation.

Back to the deployment problem. Your current deployment misses the
org.eclipse.equinox.app bundle as you switched to 3.3. Hopefully that
helps...

Ciao
Frank


"Magnus Konze" <bodomchild@web.de> schrieb im Newsbeitrag
news:4b1f4feb8a7c72e2377a5253a79535f7$1@www.eclipse.org...
> Hi!
> Yes, i still used eclipse 3.2.0 with Java 1.5 and played around with RAP
> since M2 in the same workspace. So now i started from zero with a fresh
> eclipse 3.3.0, Java 1.5.0_11 and Jetty 6.1.4, unfortunately with a similar
> result, but at first a question:
>
> If i use the project set file to import the RAP projects, do i still have
> to change the Target Platform (like described here: ). I didn't do it,
> because the demo application immediately worked (and also because i didn't
> have an idea to which path i should change it).
>
> Here are the short status and the logfile of my new attempt:
>
>
> ss
>
> Framework is launched.
>
> id State Bundle
> 0 ACTIVE org.eclipse.osgi_3.3.0.v20070530
> Fragments=30
> 1 ACTIVE org.eclipse.core.commands_3.3.0.I20070605-0010
> 2 ACTIVE org.eclipse.core.contenttype_3.2.100.v20070319
> 3 INSTALLED org.eclipse.core.expressions_3.3.0.v20070606-0010
> 4 ACTIVE org.eclipse.core.jobs_3.3.0.v20070423
> 5 INSTALLED org.eclipse.core.runtime_3.3.100.v20070530
> 6 ACTIVE org.eclipse.equinox.common_3.3.0.v20070426
> 7 ACTIVE org.eclipse.equinox.http.registry_1.0.0.200707161321
> 8 ACTIVE
> org.eclipse.equinox.http.servletbridge_1.0.0.200707161321
> 9 ACTIVE org.eclipse.equinox.http.servlet_1.0.0.200707161321
> 10 ACTIVE org.eclipse.equinox.preferences_3.2.100.v20070522
> 11 ACTIVE org.eclipse.equinox.registry_3.3.0.v20070522
> 12 ACTIVE org.eclipse.osgi.services_3.1.200.v20070605
> 13 INSTALLED org.eclipse.rap.demo_1.0.0.200707161321
> 14 INSTALLED org.eclipse.rap.jface_1.0.0.200707161321
> 15 INSTALLED org.eclipse.rap.rwt_1.0.0.200707161321
> 16 INSTALLED org.eclipse.rap.ui.workbench_1.0.0.200707161321
> 17 INSTALLED org.eclipse.rap.w4t_1.0.0.200707161321
> 18 ACTIVE org.eclipse.update.configurator_3.2.100.v20070615
> 30 RESOLVED
> org.eclipse.equinox.servletbridge.extensionbundle_1.0.0
> Master=0
>
>
> The logfile:
>
> !SESSION 2007-07-16
> 14:07:56.578 -----------------------------------------------
> eclipse.buildId=unknown
> java.version=1.5.0_11
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
> Command-line arguments: -console
>
> !ENTRY org.eclipse.core.expressions 4 0 2007-07-16 14:07:56.578
> !MESSAGE !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Require-Bundle: org.eclipse.core.runtime;
> bundle-version="[3.1.0,4.0.0)"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)
>
> !ENTRY org.eclipse.core.runtime 4 0 2007-07-16 14:07:56.625
> !MESSAGE !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Require-Bundle: org.eclipse.equinox.app;
> bundle-version="[1.0.0,2.0.0)"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)
>
> !ENTRY org.eclipse.equinox.http.registry 4 0 2007-07-16 14:07:56.625
> !MESSAGE !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Import-Package: javax.servlet; version="2.3.0"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)
>
> !ENTRY org.eclipse.equinox.http.servletbridge 4 0 2007-07-16 14:07:56.625
> !MESSAGE !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Import-Package: javax.servlet; version="2.3.0"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)
>
> !ENTRY org.eclipse.equinox.http.servlet 4 0 2007-07-16 14:07:56.640
> !MESSAGE !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Import-Package: javax.servlet; version="2.3.0"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)
>
> !ENTRY org.eclipse.rap.demo 4 0 2007-07-16 14:07:56.640
> !MESSAGE !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.ui.workbench;
> bundle-version="0.0.0"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)
>
> !ENTRY org.eclipse.rap.jface 4 0 2007-07-16 14:07:56.656
> !MESSAGE !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.rwt;
> bundle-version="1.0.0"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)
>
> !ENTRY org.eclipse.rap.rwt 4 0 2007-07-16 14:07:56.656
> !MESSAGE !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Require-Bundle: org.eclipse.rap.w4t;
> bundle-version="0.0.0"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)
>
> !ENTRY org.eclipse.rap.ui.workbench 4 0 2007-07-16 14:07:56.671
> !MESSAGE !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Require-Bundle: org.eclipse.core.runtime;
> bundle-version="0.0.0"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)
>
> !ENTRY org.eclipse.rap.w4t 4 0 2007-07-16 14:07:56.671
> !MESSAGE !STACK 0
> org.osgi.framework.BundleException: The bundle could not be resolved.
> Reason: Missing Constraint: Import-Package: javax.servlet;
> version="[2.3.0,2.5.0)"
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWor ker(BundleHost.java:305)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resu me(AbstractBundle.java:350)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBun dle(Framework.java:1118)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.r esumeBundles(StartLevelManager.java:634)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.i ncFWSL(StartLevelManager.java:508)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d oSetStartLevel(StartLevelManager.java:282)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.d ispatchEvent(StartLevelManager.java:468)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEve nt(EventManager.java:195)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread .run(EventManager.java:297)
>
> !ENTRY org.eclipse.osgi 4 0 2007-07-16 14:07:56.906
> !MESSAGE Bundle
> initial@reference :file:plugins/org.eclipse.core.expressions_3.3.0.v20070606-0 010.jar/
> was not resolved.
>
> !ENTRY org.eclipse.osgi 4 0 2007-07-16 14:07:56.906
> !MESSAGE Bundle
> initial@reference :file:plugins/org.eclipse.core.runtime_3.3.100.v20070530.jar /
> was not resolved.
>
> !ENTRY org.eclipse.osgi 4 0 2007-07-16 14:07:56.906
> !MESSAGE Bundle
> initial@reference:file:plugins/org.eclipse.rap.demo_1.0.0.200707161321.jar/
> was not resolved.
>
> !ENTRY org.eclipse.osgi 4 0 2007-07-16 14:07:56.921
> !MESSAGE Bundle
> initial@reference:file:plugins/org.eclipse.rap.jface_1.0.0.200707161321.jar/
> was not resolved.
>
> !ENTRY org.eclipse.osgi 4 0 2007-07-16 14:07:56.921
> !MESSAGE Bundle
> initial@reference:file:plugins/org.eclipse.rap.rwt_1.0.0.200707161321.jar/
> was not resolved.
>
> !ENTRY org.eclipse.osgi 4 0 2007-07-16 14:07:56.921
> !MESSAGE Bundle
> initial@reference :file:plugins/org.eclipse.rap.ui.workbench_1.0.0.20070716132 1.jar/
> was not resolved.
>
> !ENTRY org.eclipse.osgi 4 0 2007-07-16 14:07:56.921
> !MESSAGE Bundle
> initial@reference:file:plugins/org.eclipse.rap.w4t_1.0.0.200707161321.jar/
> was not resolved.
>
>
>
> Frank Appel wrote:
>
>> Hi,
>
>> strange indeed. From the OSGi trace I assume that you use a 3.2 target
>> with Java 5 at runtime. Which Java Version do you use at build time? I
>> only encountered once a similar problem using the 1.4 VM with a 3.2
>> Eclipse for building the stuff. Changing to Java 1.5 solved the problem -
>> but don't ask me why. Did you try to deploy against the 3.3 target and
>> did the same problem occur? Something that strikes me is that your system
>> bundle version (and also some of the core bundles) seems to be relatively
>> old (the example in the documentation uses 3.2.1, your versions are
>> 3.2.0) - maybe you should try the latest target of the M5 build.
>
>> Ciao
>> Frank
>
Re: Deployment problem (javax.servlet) [message #38700 is a reply to message #38332] Tue, 17 July 2007 09:40 Go to previous messageGo to next message
Magnus Konze is currently offline Magnus KonzeFriend
Messages: 35
Registered: July 2009
Member
Hi!
Thanks again for the quick help.
I simply copied the org.eclipse.equinox.app bundle to the plugin directory
of the WAR (is this correct?). The result looks a little bit better, but
it's still not working.

osgi> ss

Framework is launched.

id State Bundle
0 ACTIVE org.eclipse.osgi_3.3.0.v20070530
Fragments=31
1 ACTIVE org.eclipse.core.commands_3.3.0.I20070605-0010
2 ACTIVE org.eclipse.core.contenttype_3.2.100.v20070319
3 ACTIVE org.eclipse.core.expressions_3.3.0.v20070606-0010
4 ACTIVE org.eclipse.core.jobs_3.3.0.v20070423
5 ACTIVE org.eclipse.core.runtime_3.3.100.v20070530
6 ACTIVE org.eclipse.equinox.common_3.3.0.v20070426
7 ACTIVE org.eclipse.equinox.http.registry_1.0.0.200707171051
8 ACTIVE
org.eclipse.equinox.http.servletbridge_1.0.0.200707171051
9 ACTIVE org.eclipse.equinox.http.servlet_1.0.0.200707171051
10 ACTIVE org.eclipse.equinox.preferences_3.2.100.v20070522
11 ACTIVE org.eclipse.equinox.registry_3.3.0.v20070522
12 ACTIVE org.eclipse.osgi.services_3.1.200.v20070605
13 INSTALLED org.eclipse.rap.demo_1.0.0.200707171051
14 INSTALLED org.eclipse.rap.jface_1.0.0.200707171051
15 INSTALLED org.eclipse.rap.rwt_1.0.0.200707171051
16 INSTALLED org.eclipse.rap.ui.workbench_1.0.0.200707171051
17 INSTALLED org.eclipse.rap.w4t_1.0.0.200707171051
18 ACTIVE org.eclipse.update.configurator_3.2.100.v20070615
24 ACTIVE org.eclipse.equinox.app_1.0.0.v20070606
31 RESOLVED org.eclipse.equinox.servletbridge.extensionbundle_1.0.0
Master=0

If i try to start org.eclipse.rap.w4t, i get a BundleException saying,
that javax.servlet could not be resolved.
I'm using the Jetty default configuration (etc/jetty.xml), could this be
the problem?
The other 4 NON-ACTIVE bundles depend on org.eclipse.rap.w4t.


I also tried switching the target platform to the RAP M5 platform. I got
about 5500 compiler errors in org.eclipse.rap.help,
org.eclipse.rap.rwt.test and org.eclipse.rap.w4t.test. Nevertheless, i
tried to run the webappBuilder.xml script, but it didn't export the
plug-ins.

Magnus

Frank Appel wrote:

> Hi again,

> if you use the project set file it should not be absolutely necessary to
> switch the target platform, but I encountered problems with the RCP
> namespaces on serveral occasions with this approach. So I recommend to use a
> different target than the eclipse installation.

> Back to the deployment problem. Your current deployment misses the
> org.eclipse.equinox.app bundle as you switched to 3.3. Hopefully that
> helps...

> Ciao
> Frank
Re: Deployment problem (javax.servlet) [message #39418 is a reply to message #38700] Wed, 18 July 2007 07:24 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: fappel.innoopract.com

Hi,

I would adjust the config.ini file as described in the deployment-tutorial.
But as you have the org.eclipse.update.configurator installed I'm not sure
that this will help a lot. I'm not very familiar with the jetty engine, so I
can't say whether the jetty-default configuration makes any problems. You
may try to deploy your WAR for testing purpose on a tomcat, so that we can
see if there is any difference.

I forgot to mention that, if you are using the CVS checkout for development,
the help plugin doesn't compile against the target, it should be removed
from the team set as it has nothing to do with the RAP runtime. It belongs
to a kind of RAP-Development-Tooling like the launcher, but therefore a
RCP-target must be used. The test plug-ins need JUnit. After that the
workspace should compile again.

Ciao
Frank

"Magnus Konze" <bodomchild@web.de> schrieb im Newsbeitrag
news:2c1d7ee6e661340d97c7e83d2235e4ae$1@www.eclipse.org...
> Hi!
> Thanks again for the quick help.
> I simply copied the org.eclipse.equinox.app bundle to the plugin directory
> of the WAR (is this correct?). The result looks a little bit better, but
> it's still not working.
>
> osgi> ss
>
> Framework is launched.
>
> id State Bundle
> 0 ACTIVE org.eclipse.osgi_3.3.0.v20070530
> Fragments=31
> 1 ACTIVE org.eclipse.core.commands_3.3.0.I20070605-0010
> 2 ACTIVE org.eclipse.core.contenttype_3.2.100.v20070319
> 3 ACTIVE org.eclipse.core.expressions_3.3.0.v20070606-0010
> 4 ACTIVE org.eclipse.core.jobs_3.3.0.v20070423
> 5 ACTIVE org.eclipse.core.runtime_3.3.100.v20070530
> 6 ACTIVE org.eclipse.equinox.common_3.3.0.v20070426
> 7 ACTIVE org.eclipse.equinox.http.registry_1.0.0.200707171051
> 8 ACTIVE
> org.eclipse.equinox.http.servletbridge_1.0.0.200707171051
> 9 ACTIVE org.eclipse.equinox.http.servlet_1.0.0.200707171051
> 10 ACTIVE org.eclipse.equinox.preferences_3.2.100.v20070522
> 11 ACTIVE org.eclipse.equinox.registry_3.3.0.v20070522
> 12 ACTIVE org.eclipse.osgi.services_3.1.200.v20070605
> 13 INSTALLED org.eclipse.rap.demo_1.0.0.200707171051
> 14 INSTALLED org.eclipse.rap.jface_1.0.0.200707171051
> 15 INSTALLED org.eclipse.rap.rwt_1.0.0.200707171051
> 16 INSTALLED org.eclipse.rap.ui.workbench_1.0.0.200707171051
> 17 INSTALLED org.eclipse.rap.w4t_1.0.0.200707171051
> 18 ACTIVE org.eclipse.update.configurator_3.2.100.v20070615
> 24 ACTIVE org.eclipse.equinox.app_1.0.0.v20070606
> 31 RESOLVED
> org.eclipse.equinox.servletbridge.extensionbundle_1.0.0
> Master=0
>
> If i try to start org.eclipse.rap.w4t, i get a BundleException saying,
> that javax.servlet could not be resolved.
> I'm using the Jetty default configuration (etc/jetty.xml), could this be
> the problem?
> The other 4 NON-ACTIVE bundles depend on org.eclipse.rap.w4t.
>
>
> I also tried switching the target platform to the RAP M5 platform. I got
> about 5500 compiler errors in org.eclipse.rap.help,
> org.eclipse.rap.rwt.test and org.eclipse.rap.w4t.test. Nevertheless, i
> tried to run the webappBuilder.xml script, but it didn't export the
> plug-ins.
>
> Magnus
>
> Frank Appel wrote:
>
>> Hi again,
>
>> if you use the project set file it should not be absolutely necessary to
>> switch the target platform, but I encountered problems with the RCP
>> namespaces on serveral occasions with this approach. So I recommend to
>> use a different target than the eclipse installation.
>
>> Back to the deployment problem. Your current deployment misses the
>> org.eclipse.equinox.app bundle as you switched to 3.3. Hopefully that
>> helps...
>
>> Ciao
>> Frank
>
Re: Deployment problem (javax.servlet) [message #39663 is a reply to message #39418] Thu, 19 July 2007 08:54 Go to previous message
Magnus Konze is currently offline Magnus KonzeFriend
Messages: 35
Registered: July 2009
Member
Hi!
I tried to deploy the demo application on a tomcat (5.5 with Java 1.5) and
THERE IS a difference! Now it works :-)
I still don't have an idea what's the problem with Jetty... but for now i
use Tomcat.
Thanks again for your help!
Regards
Magnus

ss

Framework is launched.

id State Bundle
0 ACTIVE org.eclipse.osgi_3.3.0.v20070530
Fragments=31
1 ACTIVE org.eclipse.core.commands_3.3.0.I20070605-0010
2 ACTIVE org.eclipse.core.contenttype_3.2.100.v20070319
3 ACTIVE org.eclipse.core.expressions_3.3.0.v20070606-0010
4 ACTIVE org.eclipse.core.jobs_3.3.0.v20070423
5 ACTIVE org.eclipse.core.runtime_3.3.100.v20070530
6 ACTIVE org.eclipse.equinox.common_3.3.0.v20070426
7 ACTIVE org.eclipse.equinox.http.registry_1.0.0.200707171051
8 ACTIVE
org.eclipse.equinox.http.servletbridge_1.0.0.200707171051
9 ACTIVE org.eclipse.equinox.http.servlet_1.0.0.200707171051
10 ACTIVE org.eclipse.equinox.preferences_3.2.100.v20070522
11 ACTIVE org.eclipse.equinox.registry_3.3.0.v20070522
12 ACTIVE org.eclipse.osgi.services_3.1.200.v20070605
13 ACTIVE org.eclipse.rap.demo_1.0.0.200707171051
14 ACTIVE org.eclipse.rap.jface_1.0.0.200707171051
15 ACTIVE org.eclipse.rap.rwt_1.0.0.200707171051
16 ACTIVE org.eclipse.rap.ui.workbench_1.0.0.200707171051
17 ACTIVE org.eclipse.rap.w4t_1.0.0.200707171051
18 ACTIVE org.eclipse.update.configurator_3.2.100.v20070615
24 ACTIVE org.eclipse.equinox.app_1.0.0.v20070606
31 RESOLVED org.eclipse.equinox.servletbridge.extensionbundle_1.0.0
Master=0


Frank Appel wrote:

> Hi,

> I would adjust the config.ini file as described in the deployment-tutorial.
> But as you have the org.eclipse.update.configurator installed I'm not sure
> that this will help a lot. I'm not very familiar with the jetty engine, so I
> can't say whether the jetty-default configuration makes any problems. You
> may try to deploy your WAR for testing purpose on a tomcat, so that we can
> see if there is any difference.

> I forgot to mention that, if you are using the CVS checkout for development,
> the help plugin doesn't compile against the target, it should be removed
> from the team set as it has nothing to do with the RAP runtime. It belongs
> to a kind of RAP-Development-Tooling like the launcher, but therefore a
> RCP-target must be used. The test plug-ins need JUnit. After that the
> workspace should compile again.

> Ciao
> Frank
Previous Topic:missing org.eclipse.ui.internal.servlet.RequestHandler
Next Topic:Align text in Table items
Goto Forum:
  


Current Time: Sun Sep 24 10:37:05 GMT 2023

Powered by FUDForum. Page generated in 0.02722 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top