Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » Up coming changes for efxclipse 3.9
Up coming changes for efxclipse 3.9 [message #1851650] Mon, 11 April 2022 16:58 Go to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6649
Registered: July 2009
Senior Member
Hi,

Supported Java Versions
We are about to release e(fx)clipse 3.8.0 which will be the last 3.x release providing support for Java-8, we'll lift the platform afterwards and the minimum Java Version from there on will be Java-11. Customers with support contracts can request 3.8.x releases to get bug fixes.

If you have any concerns please follow up at https://github.com/eclipse-efx/efxclipse-rt/issues/449

Licensing change
Currently larg parts of the e(fx)clipse code base are licensed under EPLv1.0, we'll upgrade to EPLv2.0.

If you have concerns please follow up at https://github.com/eclipse-efx/efxclipse-rt/issues/416

My plan is to get 3.9 out of the door very fast (only bugfixes) so that you can all enjoy the upgraded platform but that heavily depends on my day job duties and how much regressions I have to work around from the platform upgrade.
Re: Up coming changes for efxclipse 3.9 [message #1851805 is a reply to message #1851650] Sun, 17 April 2022 11:02 Go to previous messageGo to next message
Stephane  fournier is currently offline Stephane fournierFriend
Messages: 337
Registered: July 2009
Senior Member
Hi Tom,
I will be very pleased to test this new efx version in my RCP app to provide you with feedbacks if it can help.

Stéphane.


Thomas Schindl wrote on Mon, 11 April 2022 18:58
Hi,

My plan is to get 3.9 out of the door very fast (only bugfixes) so that you can all enjoy the upgraded platform but that heavily depends on my day job duties and how much regressions I have to work around from the platform upgrade.

Re: Up coming changes for efxclipse 3.9 [message #1851860 is a reply to message #1851805] Wed, 20 April 2022 12:27 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6649
Registered: July 2009
Senior Member
Thanks for the offer - I'm currently trying to get a target-platform setup but as you might imagine many bundle have been changed - I'm currently fighting to get JAXB working but its a bit of a nightmare. I already know this is going to hit me and now I'm forced to address this long standing problem - and man this sucks soooo much.
Re: Up coming changes for efxclipse 3.9 [message #1853274 is a reply to message #1851860] Sat, 25 June 2022 09:12 Go to previous messageGo to next message
Stephane  fournier is currently offline Stephane fournierFriend
Messages: 337
Registered: July 2009
Senior Member
Hi Tom,
Would it be possible to have some news about efx 3.9 and the platform upgrade please ?
Would it be possible to test an alpha version to help you ?

Stéphane.

Thomas Schindl wrote on Wed, 20 April 2022 14:27
Thanks for the offer - I'm currently trying to get a target-platform setup but as you might imagine many bundle have been changed - I'm currently fighting to get JAXB working but its a bit of a nightmare. I already know this is going to hit me and now I'm forced to address this long standing problem - and man this sucks soooo much.

Re: Up coming changes for efxclipse 3.9 [message #1853303 is a reply to message #1853274] Mon, 27 June 2022 10:08 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6649
Registered: July 2009
Senior Member
So I had all this stuff working for 2022-03 and then 202206 came along and things have been broken once more. I think I've finally fixed that and - after a lot of trial and error - convinced the Eclipse CI-Infrastructure to publish the 3.9.0 snapshot. Please note there've been a few changes:
- httpclient has been removed
- equinox.ds has been removed
- javax.xml.bind is now jakarta.xml.bind

I haven't really tested all this in a larger app but a dead simple osgi-e4-application started sucessfully on ZuluFX-17.
Re: Up coming changes for efxclipse 3.9 [message #1853325 is a reply to message #1853303] Mon, 27 June 2022 20:32 Go to previous messageGo to next message
Stephane  fournier is currently offline Stephane fournierFriend
Messages: 337
Registered: July 2009
Senior Member
Hi Tom,
Thank you very much Tom for your efforts.

I will make it a try on my own e4 app (at least next week-end) and let you know.
I downloaded the site_assembly.zip containing 3.9.0 snapshot.

Stéphane.


Thomas Schindl wrote on Mon, 27 June 2022 12:08
So I had all this stuff working for 2022-03 and then 202206 came along and things have been broken once more. I think I've finally fixed that and - after a lot of trial and error - convinced the Eclipse CI-Infrastructure to publish the 3.9.0 snapshot. Please note there've been a few changes:
- httpclient has been removed
- equinox.ds has been removed
- javax.xml.bind is now jakarta.xml.bind

I haven't really tested all this in a larger app but a dead simple osgi-e4-application started sucessfully on ZuluFX-17.

Re: Up coming changes for efxclipse 3.9 [message #1853467 is a reply to message #1853325] Sun, 03 July 2022 16:56 Go to previous messageGo to next message
Stephane  fournier is currently offline Stephane fournierFriend
Messages: 337
Registered: July 2009
Senior Member
Hi,

I made this afternoon a try to EFX 3.9.0 snapshot (built on 3.9.0.202206270944) + platform as Eclipse Modeling 2022-06 build.

Since I have my own features to reference EFX + Eclipse platform, I had some time, to fetch additional bundles related to p2 support + jakarta.xml.bind bundle.

At the end, I got a successful app running with the same OpenJDK (Temurin 17.0.3) + OpenJFX version (15.0.1) already used with efx 3.8.0/2019-12 platform.

N.B: Make sure to run your efx app with a freshly created runtime workspace ( same thing for the osgi bundle configuration).

The only thing I had to change is maybe linked to DS removal ?
Indeed, I used extension-point "org.eclipse.e4.workbench.model" to contribute a 'Theme' menu (as in the very old efx contacts app example).
It seems this extension-point is not called anymore by EFX 3.9.0 (in extension-point documentation it is written it is not an API).
is it true ? DefaultThemeManager is still instantiated (no issue).

I've replaced this MenuThemeProcessor, by declaring the menu items in the application.e4xmi file directly and it works.
MenuThemeProcessor class is useless, but all other artefacts remain (class that extends AbstractTheme, ServiceComponent registration in Manifest.MF, Command to switch themes).

As far as I know, 3.9.0-snapshot seems to run as 3.8.0.


Does anyone can provide other feedbacks please ?

Regards,
Stéphane

[Updated on: Sun, 03 July 2022 17:13]

Report message to a moderator

Re: Up coming changes for efxclipse 3.9 [message #1853579 is a reply to message #1853467] Fri, 08 July 2022 18:32 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6649
Registered: July 2009
Senior Member
So I hope I fixed your problem and now the registration should once more work correctly
Re: Up coming changes for efxclipse 3.9 [message #1853594 is a reply to message #1853579] Sun, 10 July 2022 13:43 Go to previous message
Stephane  fournier is currently offline Stephane fournierFriend
Messages: 337
Registered: July 2009
Senior Member
Hi Tom,
Yes you did it ! It runs as per 3.8.0 now.

Thomas Schindl wrote on Fri, 08 July 2022 20:32
So I hope I fixed your problem and now the registration should once more work correctly

Previous Topic:Extension point org.eclipse.e4.workbench.model doesn't work anymore
Next Topic:Bug 475347 is raising its ugly head again
Goto Forum:
  


Current Time: Thu Dec 08 03:52:06 GMT 2022

Powered by FUDForum. Page generated in 0.03122 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top