Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » OpenJDK11 and eclipse link 2.7.1 Compatibility issue - Named query not found
OpenJDK11 and eclipse link 2.7.1 Compatibility issue - Named query not found [message #1849084] Mon, 03 January 2022 04:53 Go to next message
Venkat Reddy Bandi is currently offline Venkat Reddy BandiFriend
Messages: 1
Registered: January 2022
Junior Member
Below jars worked fine with OracleJDK 11 but not with openJDK11.

1. eclipselink.2.7.1.jar
2. javax.persistence.2.1.1.jar

Getting below exception when migrating to openjdk.

java.lang.IllegalArgumentException: NamedQuery of name: abcd not found.
at org.eclipse.persistence.internal.jpa.QueryImpl.getDatabaseQueryInternal(QueryImpl.java:362)
at org.eclipse.persistence.internal.jpa.EntityManagerImpl.createNamedQuery(EntityManagerImpl.java:1236)
at org.eclipse.persistence.internal.jpa.EntityManagerImpl.createNamedQuery(EntityManagerImpl.java:1257)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.base/java.lang.reflect.Method.invoke(Method.java:566)

Re: OpenJDK11 and eclipse link 2.7.1 Compatibility issue - Named query not found [message #1850169 is a reply to message #1849084] Sat, 19 February 2022 03:09 Go to previous message
Brad Mising name is currently offline Brad Mising nameFriend
Messages: 21
Registered: September 2009
Junior Member
I get the same issue, but different versions. Happens for me on Oracle jdk11, as well as openjdk 11, 16 and 17

1. eclipselink.3.0.2.jar
2. jakarta.persistence-api.3.0.0.jar

I have found that it is much more likely to happen when I have higher latency between my application and the database server. Initially found when distantly located on the network vs in the same room. Confirmed by adding bandwidth throttling to my server. Still not 100% either way, but occurs 90% of the time with throttled connection and 10% of the time with fast connection.
Previous Topic:EclipseLink fails with to connect to DB
Next Topic:EclipseLink Validation Exception in Library Eclipse Version 2.7.8
Goto Forum:
  


Current Time: Wed Feb 21 06:32:44 GMT 2024

Powered by FUDForum. Page generated in 0.02981 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top