Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Install Remediation Page(Help explain error message)
Install Remediation Page [message #1848166] Tue, 23 November 2021 08:30 Go to next message
Piwo Laschzkywiz is currently offline Piwo LaschzkywizFriend
Messages: 3
Registered: November 2021
Junior Member
Hi,

I am using Eclipse IDE for Java Developers 2021-09.

I try to install "Oracle WebLogic Server Tools"
from oepe tools 12.2.1.10

I get the following error message.

Can you help me understand what is the problem here? There are 8 "Cannot satisfy dependency" entrys but I don't understand which is the most relevant one and how to fix it.

Cannot complete the install because some dependencies are not satisfiable
Software being installed: Oracle WebLogic Server Tools 17.3.0.202009281559 (oracle.eclipse.tools.weblogic.feature.group 17.3.0.202009281559)
Software currently installed: JustJ OpenJDK Hotspot JRE Complete 16.0.2.v20210721-1149 (org.eclipse.justj.openjdk.hotspot.jre.full.feature.group 16.0.2.v20210721-1149)
Cannot satisfy dependency:
From: jersey-core 1.17.1.p002 (com.sun.jersey.core 1.17.1.p002)
To: java.package; javax.xml.bind.annotation raw:[-M,-M]
Cannot satisfy dependency:
From: Oracle Java EE Tools 17.3.0.202009281559 (oracle.eclipse.tools.javaee.feature.group 17.3.0.202009281559)
To: org.eclipse.equinox.p2.iu; oracle.eclipse.tools.jaxrs.v11 [17.3.0.202009281559,17.3.0.202009281559]
Cannot satisfy dependency:
From: Oracle JAX-RS Tools (1.1) 17.3.0.202009281559 (oracle.eclipse.tools.jaxrs.v11 17.3.0.202009281559)
To: osgi.bundle; com.sun.jersey.core [1.17.1,2.0.0)
Cannot satisfy dependency:
From: Oracle WebLogic Server Tools 17.3.0.202009281559 (oracle.eclipse.tools.weblogic.feature.group 17.3.0.202009281559)
To: org.eclipse.equinox.p2.iu; oracle.eclipse.tools.javaee.feature.group 0.0.0
Cannot satisfy dependency:
From: JustJ OpenJDK Hotspot JRE Complete 16.0.2.v20210721-1149 (org.eclipse.justj.openjdk.hotspot.jre.full 16.0.2.v20210721-1149)
To: org.eclipse.equinox.p2.iu; a.jre.javase 0.0.0
Cannot satisfy dependency:
From: JustJ OpenJDK Hotspot JRE Complete 16.0.2.v20210721-1149 (org.eclipse.justj.openjdk.hotspot.jre.full.feature.group 16.0.2.v20210721-1149)
To: org.eclipse.equinox.p2.iu; org.eclipse.justj.openjdk.hotspot.jre.full [16.0.2.v20210721-1149,16.0.2.v20210721-1149]
Re: Install Remediation Page [message #1848175 is a reply to message #1848166] Tue, 23 November 2021 16:08 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4219
Registered: July 2009
Senior Member

Are you certain that 2021-09 is a supported release for those tools?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Install Remediation Page [message #1848177 is a reply to message #1848175] Tue, 23 November 2021 18:57 Go to previous messageGo to next message
Piwo Laschzkywiz is currently offline Piwo LaschzkywizFriend
Messages: 3
Registered: November 2021
Junior Member
I am certain it is not. I already talked to oracle but they say that the oepe tools are phased out and not longer in active development.

I just want to install the plugin for starting and stopping the weblogic server.

As I encountered "Cannot satisfy dependency" errors before and never understood how to read/interpret them correctly I took this example for asking. So this question is about interpreting dependency errors.
Re: Install Remediation Page [message #1848180 is a reply to message #1848177] Wed, 24 November 2021 01:06 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4219
Registered: July 2009
Senior Member

Well, in this case it's indicating that Oracle WebLogic Server Tools has an unsatisfiable dependency on com.sun.jersey.core, which has an unmet dependency on the javax.xml.bind.annotation package that isn't present in anything after Java 10, or at least I think that's the case since I've never heard of it but do know that's what happened to javax.xml.bind in http://openjdk.java.net/jeps/320.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Install Remediation Page [message #1848185 is a reply to message #1848180] Wed, 24 November 2021 10:45 Go to previous messageGo to next message
Piwo Laschzkywiz is currently offline Piwo LaschzkywizFriend
Messages: 3
Registered: November 2021
Junior Member
First: thank you for reply!

So the uppermost entry tells the problem:
From: jersey-core 1.17.1.p002 (com.sun.jersey.core 1.17.1.p002)
To: java.package; javax.xml.bind.annotation raw:[-M,-M]

I took a look at the manifest of com.sun.jersey.core_1.17.1.p002.jar

There I can find an
Import-Package: resolution:=optional,javax.xml.bind;version="0.0.0,0.0.0]",javax.xml.bind.annotation;version="[0.0.0, 0.0.0]"

That's what "To:java.package" means, right?

The packages were removed from the JDK as you described.

Is there a way to add a JAR containing the javax.xml.bind.* packages to Eclipse so that the Import-Package from jersey-core can be resolved?

Perhaps a mechanism that can add the packages contained in the JAR so they are available for all plugins?
Re: Install Remediation Page [message #1848300 is a reply to message #1848185] Sat, 27 November 2021 03:43 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4219
Registered: July 2009
Senior Member

Yes, since most plug-ins are regular jars with extra information in them. Usually that information is added using a Maven plug-in like Tycho
or org.reficio.p2-maven-plugin as part of their build process, and then it's installed like any other dependency.


Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Eclipse is occasionally unresponsive
Next Topic:Unable to Find fg_runs in the Gradle Tasks Tab
Goto Forum:
  


Current Time: Sun May 22 12:25:06 GMT 2022

Powered by FUDForum. Page generated in 0.03478 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top